Jump to content
    

Отключил я эхо с помощью ATE0, и после этого перестал вообще получать какие либо ответы по запросу. Шлю AT, ATI,CREG, и т.д. - а в ответ тишина. Это что так и должно быть? И вообще вы используете эхо, для чего это нужно? Для проверки отосланной команды?

Share this post


Link to post
Share on other sites

Можно поподробнее - чем и что запрашиваете, был ли ответ на АТЕ0 и т.д. По эху сразу видно, есть модем на линии или нет.

Share this post


Link to post
Share on other sites

После Call Ready послал ATE0,AT&W, получил ОК, OK.

Выключаю\включаю SIM300DZ, дожидаюсь Call Ready и посылаю AT, в ответ - тишина, на другие команды тоже молчит.

Я так понял ATE0 - отключить только возврат отправленных данных? Общаюсь с помощью МК.

Edited by Anthoni

Share this post


Link to post
Share on other sites

В примерах у него написано, что после посылки команды ATE0;&W (еквивалент двух команд) модем выдаст ОК и дальше будет молчать. как пленный партизан, кроме ОК при старте. По опыту, лучше эхо не отключать, поскольку каждый модем при отключении эха начинает выдавать свои нюансы.

Share this post


Link to post
Share on other sites

AT+CLIP=1

При звонке номер будет сам рассказывать. Или же AT+CLCC после получения RING.

Мануал по командам есть? ;)

Share this post


Link to post
Share on other sites

(Пардон за оффтоп) Я вообще специально не учил, только немецкий на 5 ;) - со временем нахватался, это неизбежно.

На русском мануал есть для Q24xx от Wavecom, многие команды совпадают. Во всяком случае, позвонить-отправить-принять SMS и т.п. стандартные процедуры делаются одинаково что с теми, что с теми. Здесь где-то ссылка должна быть, поищите...

Share this post


Link to post
Share on other sites

Отключил я эхо с помощью ATE0, и после этого перестал вообще получать какие либо ответы по запросу. Шлю AT, ATI,CREG, и т.д. - а в ответ тишина. Это что так и должно быть? И вообще вы используете эхо, для чего это нужно? Для проверки отосланной команды?

 

Это ЭХО отключается (от вводимых в модем символов), а не вывод вообще. Ответы должны быть, а для наглядности

в терминале можно включить локальное эхо. Даже если с помощью ATQ (если не ошибаюсь...) отключить ответы текстом, так они кодами (цифрами) пойдут. То ли модему совсем плохо, то ли ещё что.

Share this post


Link to post
Share on other sites

На русском мануал есть для Q24xx от Wavecom, многие команды совпадают. Во всяком случае, позвонить-отправить-принять SMS и т.п. стандартные процедуры делаются одинаково что с теми, что с теми. Здесь где-то ссылка должна быть, поищите...

Есть такой мануал для Wavecom мне хорошо помог ;)

вот первая часть архива AT_Command.part1.rar

 

Вот вторая часть архиваAT_Command.part2.rar

 

А вот и третья часть :) AT_Command.part3.rar

Share this post


Link to post
Share on other sites

Не понимаю, почему получаю ERROR, на команды AT+CMGD=1, AT+CMGL=”ALL”, AT+CMGR=1...? В чем может быть проблема?

С другими, НЕ СМС-командами всё ОК.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...