Jump to content
    

SIM7020 не регистрируется в сети

On 1/16/2024 at 3:26 PM, MiklPolikov said:

Вы сами его прошивали ? И все получалось, и он начинал работать ? 

Именно SIM7020E не прошивал. У меня SIM7020G. Буква имеет значение. Прошивку нигде найти не удалось.

Прошивал SIM7080, Quectel_BC95-G. Причём много раз один и тот же экземпляр модема. Проблем не возникало.

Судя по логу, в консоль у вас валится дамп памяти. Поэтому и предположил об ошибке в процессе перепрошивки.

Share this post


Link to post
Share on other sites

25 minutes ago, nemo444 said:

Прошивал SIM7080, Quectel_BC95-G. Причём много раз один и тот же экземпляр модема. Проблем не возникало.

Понятно. Значит при перепрошивке что-то испортилось.
Он после прошивки сразу работает и всё ? Нет какой-нибудь хитрости, скажем отправить какую-то специальную команду, или ли дернуть питание 10раз .. ?

Share this post


Link to post
Share on other sites

За SIM7020E сказать не могу.

Те модемы, что я перепрошивал, требовали после успешного окончания процесса один раз дёрнуть питанием.

Процесс прошивки у всех примерно одинаков. Разница только в тулзах и формате прошивки.

 

Повторюсь, в вашем логе видно, что постоянно в консоль летит дамп памяти модема.

Очень похоже, что перепрошивка прошла неуспешно, либо прошивка не соответствует аппаратной ревизии.

Share this post


Link to post
Share on other sites

28 minutes ago, nemo444 said:

Повторюсь, в вашем логе видно, что постоянно в консоль летит дамп памяти модема.

Очень похоже, что перепрошивка прошла неуспешно, либо прошивка не соответствует аппаратной ревизии.

Это я понимаю.
Моет, кто-нибудь такое видел, и подскажет как исправить. 

Share this post


Link to post
Share on other sites

SIM7080G:

Такая же проблема иногда (редко) возникает:

AT+CGREG? 
+CGREG: 0,2

...через 40-45 секунд:

AT+CGREG?
+CGREG: 0,0

При следующем ресете и соединении через минуту после прооблемы уже опять нормально, "+CGREG: 0,2" меняется на "+CGREG: 0,1" через 2-3 секунды.

+CSQ: 16,99

Причины внешние (сеть) или внутренние (прошивка? настройки модема?) ? Что-то в регистрах можно посмотреть, чтобы понять причину?

Share this post


Link to post
Share on other sites

On 4/11/2024 at 4:15 PM, Ruslan1 said:

+CSQ: 16,99

Повнимательнее посмотрите даташит в части описания команды AT+CSQ и статусы AT+CGREG.

+CGREG: 0,2. Не зарегистрированы. Ищем сеть.

+CGREG: 0,0 . Не зарегистрированы. Уже не ищем. Похоже, ничего не нашли.

+CGREG: 0,1. Зарегистрированы в Home PLMN.

+CSQ: 16,99. RSSI примерно на уровне -82.

Предположительно, низковат уровень сигнала на входе приёмника.

Либо что-то с антенным трактом, либо надо пробовать направленную антенну, если есть возможность.

Ещё питание посмотреть. Нет ли просадок каких.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...