Jump to content
    

не подвязывается msp-тулчейн к Eclipse

Привет. прикручиваю толчейн к эклипс. Делаю по схеме https://openwsn.atlassian.net/wiki/spaces/OW/pages/11534370/msp430gcc+on+Eclipse+with+mspdebug+Preferred

На шаге 2 плагин отлично добавляется. Но вот когда начинаю конфигурировать, на шаге 3 у меня открывается пустое окно. Хорошо. Жму Add и выбираю папку с тулчейном. НО по факту в окно ничего не добавляется....я подумал глюк попробовал с перезагрузкой эклипс/компа. Нет, все равно не добавляется (рис.1)... Попробовал создать проект "Empty Project" из "MSP430 Cross Target Application", но когда дохожу до выборки процессора, там пусто (рис.2)... Поставил старый эклипс 2018 года, пробовал другой тулчейн, та же фигня... Где ошибаюсь???

2020-05-03_135213.png.e99f7a0bb0e92944a0928b1f8acbaac5.png2020-05-03_135049.png

Share this post


Link to post
Share on other sites

пути к директориям где-то напутались. Может нестандартый директорий (руские буквы, сильно глубокий итп ) или диск. 

Share this post


Link to post
Share on other sites

Ещё в путях не стоит делать пробелов.

Радикальный путь: перейти на систему сборки, например, make, SCons. О работе make с eclipse на форуме масса информации.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...