Jump to content

    

Start page не отключается

Capture 17.2 HF049, не активен checkbox отображения start page.

В Capture.ini установка EnableStartPage в FALSE не оказывает никакого влияния.

Т.е. при запуске Start page отображается всегда.

Прошу подтвердить или опровергнуть данный баг, а так же возможные пути решения.

Share this post


Link to post
Share on other sites

У меня вылечилось только удалением Cadence. После установки базового комплекта можно эту галку на Start Page нажать (можно даже без патча exe, dll). После этого можно накатывать любой Hotfix.

Share this post


Link to post
Share on other sites

Да, спасибо, я такой момент тоже вычислил.

Интересно что и где он(HF049) сносит ...?

И поправилась ли эта ситуация в HF050? 

Share this post


Link to post
Share on other sites

Даже с HF037 был такой глюк.

Share this post


Link to post
Share on other sites

Пугает даже не этот глюк а то, что нет реакции на изменения в Capture.ini, и в каких ещё параметрах это ещё сказывается...

Share this post


Link to post
Share on other sites

Столкнулся с данной проблемой при переустановке SPB17.2 - сразу накатил хотфикс 54 и получил неотключаемую начальную страницу в Capture (чекбокс присутствует, но не нажимается).

Лечение следующее:

1. Заходим в подкаталог SPB_17.2\tools\capture\tclscripts\capStartPage\html\js\

2. Делаем резервную копию файла menu.js с сохранением его таймстемпа (это нужно, чтобы не сломать систему накатки хотфиксов).

3. Открываем menu.js в текстовом редакторе, находим функцию initClickFunctions() и видим, что инициализация #disableStartup отключена (закомментирована  при помощи "//"). Изменяем файл, убирая комментирование.

4. Запускаем Capture, теперь чекбокс "не показывать start page" работает. Ставим в нем галочку, выходим из Capture.

5. Восстанавливаем menu.js из бакапа (чтобы восстановился и таймстемп файла тоже).

 

Если просто отредактировать menu.js не делая бакап, таймстемп файла обновится, что может повлиять на применение будущих хотфиксов (файл может остаться не обновленным). Если это не важно, достаточно выполнить пункты 1 и 3.

Share this post


Link to post
Share on other sites

Простите, не могу найти этот чекбокс "не показывать start page". Подскажите, plz, где он

 

Share this post


Link to post
Share on other sites
В 10.05.2019 в 21:09, En_Serg сказал:

Простите, не могу найти этот чекбокс "не показывать start page". Подскажите, plz, где он

Чекбокс в Orcad Capture находится на самой Start Page, в левом нижнем углу. 

Share this post


Link to post
Share on other sites
On 1/22/2019 at 4:07 AM, -=az=- said:

Capture 17.2 HF049, не активен checkbox отображения start page.

В Capture.ini установка EnableStartPage в FALSE не оказывает никакого влияния.

Т.е. при запуске Start page отображается всегда.

Прошу подтвердить или опровергнуть данный баг, а так же возможные пути решения.

You can disable Capture Start page by adding following entry inside [Start Page] section of spinfo.ini and Capture.ini file at %home% location .

[Start Page]
EnableStartPage= False

 

Попробуйте. Может быть, у вас EnableStartPage в другом разделе ини-файла.

Должна быть в

[Start Page] section

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now