Jump to content
    

Камень 10CL006YE144I7G, не идет программирование в среде Quartus(R) Prime Lite в

Всем доброго дня или ночи.
Камень 10CL006YE144I7G,
не идет программирование в среде Quartus(R) Prime Lite
в чем проблемы - в подтягивающих резисторах? или тупо не проплаченная версия тормозит?

Share this post


Link to post
Share on other sites

Камню флешка ещё нужна... И программатор нужен, без него шиться не будет. Питание надо включить.
Вы хотя бы какую нибудь информацию дайте, схему подключения ПЛИС, что пишет и так далее.
Сам работал и с этой ПЛИС и с Lite версией среды - никаких проблем не было, всё шилось мгновенно.

Share this post


Link to post
Share on other sites

Он вам пишет, что есть проблема с цепочкой JTAG. Проверьте подключение кабеля и наличие 3.3В на 4 контакте разъема.

Share this post


Link to post
Share on other sites

Надо полагать msel0, msel1 подключены.

Посмотрите рапорт *pin проекта. Какое питание на банки рекомендовано подавать  (по умолчанию I/O standard обычно 2.5В).

Посмотрите какое питание на плате подано на банк, к которому относятся пины JTAG. По идее, если Вы бластер запитали от 3.3В, то и банк с пинами JTAG должен быть запитан от 3.3В. Если этот банк запитан от 2.5В, 1.8В, то и питание на разъеме для бластера должно быть таким же. Смотрите даташит. Соответственно и резистивные подтяжки JTAG к питанию.

Share this post


Link to post
Share on other sites

Есть ли способ проверки, припаяно ли пузо микросхемы, без ее демонтажа.
Может оно влиять?
 

Share this post


Link to post
Share on other sites

Вот такие напряжения на камне 1.2v  2.5v 3.1v
Может 3.1v который должен быть 3,3в влияет?

Share this post


Link to post
Share on other sites

1 час назад, andrei_moiseev сказал:

Есть ли способ проверки, припаяно ли пузо микросхемы, без ее демонтажа.
Может оно влиять?

Да, влиять оно будет. Пузо в обязательном порядке должно быть подключено к 0 В, иначе прошиваться ничего не будет. Примерно такая ошибка и должна быть.
Я для проверки всегда предусматриваю отверстие в несколько мм под пузом.

Проверить физически не знаю как, но по схеме и печати это обычно 145 контакт. Может забыли к 0 В подключить?
 

Цитата

Может 3.1v который должен быть 3,3в влияет?

Не должно. Хотя это плохой знак, если должно быть 3,3 В, а есть 3,1 В - значит где то, что-то слишком много кушает и возможно больше не будет работать. 

+ По поводу питания. Подключено неправильно (хоть и должно работать).
Даже при питании в 3 В TMS и TDI должны быть подтянуты к 2.5 В.

++ Ещё по схеме не понятно куда подтянуты MSEL0/MSEL1

Share this post


Link to post
Share on other sites

38 минут назад, selax сказал:


Даже при питании в 3 В TMS и TDI должны быть подтянуты к 2.5 В.
 

В каком документе это можно посмотреть. 

Share this post


Link to post
Share on other sites

1 минуту назад, andrei_moiseev сказал:

может влиять версия бластера? у меня клон 1

Не должно. Тоже клоном пользуюсь. Ну разве что бластер нерабочий.
Если бластер какую нибудь другую плату прошивает, то всё должно быть хорошо.

Share this post


Link to post
Share on other sites

2 часа назад, andrei_moiseev сказал:

Есть ли способ проверки, припаяно ли пузо микросхемы, без ее демонтажа.

Методом обратной прозвонки через защитные диоды на пинах: ставите красный щуп мультиметра в режиме прозвонки диода на землю, а черным щупом щупаете сигнальные пины ПЛИС. Если пузо припаяно и земля есть, то вы увидите около 0.4 В падение на нижнем защитном диоде ячейки ввода-вывода ПЛИС. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...