Jump to content

    

mn2=n

Участник
  • Content Count

    26
  • Joined

  • Last visited

Everything posted by mn2=n


  1. Проблема оказывается была описана на оф. сайте, однако у меня не получилось с первого раза все устранить. Метод решения проблемы описан по ссылке https://www.keil.com/support/docs/4204.htm Выполнив действия описанные там, у меня все заработало
  2. Понял, а как тогда при отладке проверить правильность настройки периферии? Вот например хочу использовать UART, настроил тактирование,порты, сам юарт. А он взял и не заработал. И начинается пляска с даташитом и просмотр кода. При работе с авр удавалось отловить косяки просматривая регистры Все установлено, однако все равно не работает. Гугл и оф. сайт направили на создание sfr файла из файла svd с помощью утилиты SVConv.exe однако я не могу разобраться как ее запустить. При стандартном запуске, как и любую другую программу двумя щелчками курсора, запускается консоль и закрывается, при этом sfr файла так и не появилось. Гугл сказал, что нужно запустить утилиту и прописать специальную команду, однако, как я уже и сказал, я не понял как запустить утилиту
  3. Добрый день Подскажите пожалуйста как в Keil просматривать регистры контроллера при отладке программы, например, как в AVRStudio
  4. Я обновил ее сразу как появилась ошибка по KEIL 5. В данный момент прошивка самая последняя
  5. Ура. Проблема была в самом KEIL. Я ставил предыдущую версию KEil 5 ошибка осталась, скачал KEIL 4, установка предложила поставить драйвер и все заработало. Работает только в KEIL 4. Версия 4,74 Буду писать в поддержку если скажут как лечить это в KEIL 5 обязательно отпишусь. Всем огромное спасибо за помощь
  6. И так и так. Вот только что подключил плату к компу, зашил через ST-link Utility - Keil ругается, стер - все равно ругается
  7. Нашел комп на который никогда не устанавливался Keil, на нем тоже не заработало. Неужели дело в самой плате? По идее, если бы дело было в плате, то и ST-link Utility ничего бы не делал или не так?
  8. 1. На плате всего 3 джампера, все они подключены 2. стандартная частота 10 МГц, я понижал до 1 МГц с шагом в 1 МГц. К сожалению не помогло 3. В данной вкладке вообще было пусто. Я выбрал из списка (фото раздела приложил) не помогло. Кстати, заметил, когда переустанавливал среду, при установке файлов для работы с семействами контроллеров ругается на компиляцию svd файла, однако модуль числится установленным. 4. Попробовал через KEil, просто выдает ошибку и ничего не стирает. Я стер камень через ST-link Utility 5. Так как на STM32VLdiscovery установлен ST-Link первой версии, для него hardware reset не доступен. Об этом сообщил Keil, ST-link Utility этого пункта вообще нет. Есть в наличии только Software system reset и core reset. Потрогал и то и то, через ST-link Utility все работает как и было, но в Keil нет. Я пробовал разные настройки в подразд еле settings раздела utilities, поэтому прикрепляю текущие настройки. Возможно, какой-то из данных пунктов действительно рабочий и я делаю что-то не так. К сожалению уже ничего не понимаю.
  9. Спасибо большое за ответ, к сожалению не помогло(
  10. Доброго времени суток! Есть две платы STM32VLdiscovery и STM32F4discovery. Поначалу работал с первой платой и все работало как часы (Keil шил контроллер и запускал отладку), затем решил поработать со второй, она работала аналогично, однако когда перешел снова к первой то Keil перестал шить и запускать отладку. Появилась ошибка "Error: Flash Download failed - Target DLL has been cancelled". В ST-link Utility камень на плате виден и его можно как очистить так и зашить. Однако kEil зашить не может. Так же я заметил одну особенность, STM32F4discovery отображается в диспетчере задач как "STMicroelectronics STLink Virtual COM Port", STM32VLdiscovery я толком и не нашел. Драйвера были скачены и установлены еще в самом начале, без них бы не работало, ведь STM32VLdiscovery раньше работала, а сейчас нет. Пробовал и среду переустанавливать и колдовать с файлами драйверов, увы, у меня ничего не получилось. Надеюсь кто нибудь знает решение подобной проблемы. Пожалуйста помогите
  11. Хм...Вот формулы энергии и средней мощности на бесконечном интервале. Ни как не могу понять как ими пользоваться. Знания по данным вопросам улетучились после выпуска, если конечно они были...
  12. Добрый день В данный момент пытаюсь освоить курс "основы обработки цифровых сигналов". У меня есть задание (см. вложение) Мне известна формула как энергии, так и мощности, но как ими воспользоваться, увы, я не понимаю. Имею значительные пробелы в высшей математике. Было бы здорово, если разжуете мне данную задачу, чтобы я смог разобраться в данном вопросе. Заранее спасибо
  13. Спасибо за ваш ответ. Я правильно вас понял? Я передвигаю компоненты, что находятся справа от антенны в другое место и непосредственно под антенной убираю металлизацию? И на данном участке не должно быть никаких проводников, верно?
  14. Сделал работу над ошибками, большинство устранил. С развязывающими конденсаторами вообще стыдно, натыкал просто и все, ни один не работал. Модуль использую HC-05 в даташите не нашел мест, где трассировка не должна быть, но проверю еще раз. К сожалению не видел Ваше сообщение и уже успел все переделать. Про антенну модуля даже не задумывался( В настоящий момент плата выглядит так. Видимо придется переделывать еще раз...
  15. А чем плохо питание полигоном? Слабо понимаю в данной теме. Сделал полигоном, потому что показалось, что так будет более "правильно".
  16. Спасибо за ответ. После устранения всех ошибок планирую плату заказать. Спасибо за ответ. Не подумал об этом, теперь буду знать) Спасибо большое за ответ. Объясните мне пожалуйста важность данной ошибки "Silk To Solder Mask Clearance Constraint Violation" в правилах установлено 0,2 мм, чип-компоненты спроектированы с 0,1 мм, а у контроллера вообще 0,05 мм
  17. Спасибо огромное за ответ. 1. Да, я забыл его добавить. 2. Передвину конденсатор. 3. Да, конденсаторы С3, С4, а также С1, С2 по питанию, расположил симметрично и близко к контроллеру, как это позволили привила. Тогда сделаю по другому, дабы конденсаторы стали еще ближе. 4. Как я понимаю это резисторы которые на фото? Добавлю. Спасибо огромное за ответ. А расскажите, пожалуйста, чтобы вы именно изменили. А то у меня возникло еще больше вопросов
  18. С надписями разобрался, а вот с зазорами связанными с компонентами, увы, нет. Данных ошибок подавляющее большинство
  19. Доброго времени суток! Спроектировал плату для радиолюбительской поделки. Нужно профессиональное мнение. В настоящий момент плата не прошла DRC в основном по поводу зазоров в библиотечных компонентах. Пока не устранял, возможно потребуется переработка платы. Control board.PcbDoc
  20. Доброго времени суток! Я спроектировал ПП, нашел стандартный набор правил, проверил, а мне выдало кучу ошибок. Возник вопрос, а необходимо ли устранять подобные ошибки (см. скриншот) Если да, то как грамотно это сделать? Огромное спасибо за помощь
  21. Фуууух, я нашел в чем косяк. Кто ищет, тот всегда найдет. Как оказалось, в свойствах компонента, в группе "Comment" я установил расположение данного коммента в слое бот, а не в слое бот оверлей. Исправив данный косяк, альтиум прекратил ругаться и я смог проложить проводники там, где раньше не мог. Всем огромное спасибо за помощь))
  22. Я не знаю, что я натворил, но в области, помеченной красным прямоугольником, я не могу провести проводник
  23. Да, я это понимаю, но к сожалению никак не могу сообразить как это вылечить. Если переместить разъем в глубь платы, то ругань исчезает. Но приходится переместить разъем где то на сантиметр. Согласно сообщению, которое показывает альтиум, конфликт между текстом на боте и падом на боте, все как вы и сказали. Но у меня текст расположен на топе. и ииза этого я совсем запутался
  24. Да, Вы правы, я где-то накосячил, при создании, при чем несколько раз. Установив Jumper ID в 0 и вручную указав цепь, большинство ошибок исчезло. За исключением той, которая указана в скрине. Подскажите пожалуйста, что это за текст, который мешает, ни как не могу сообразить