реклама на сайте
подробности

 
 
 
Reply to this topicStart new topic
> SIM5320E зависает при использовании ручного чтения данных (AT+CIPRXGET)
borman11
сообщение Apr 25 2018, 18:29
Сообщение #1


Участник
*

Группа: Участник
Сообщений: 20
Регистрация: 16-03-06
Из: Москва
Пользователь №: 15 298



Работаю с модулем через USB.
Если включен автоматический прием данных (AT+CIPRXGET=0), то все работает нормально. Когда включаю ручной режим (AT+CIPRXGET=1), то работает, НО... если я закрою TCP соединение (AT+CIPCLOSE=0) и снова попытаюсь его открыть, то модуль перестает отвечать на команды, а через 1-2 минуты перезагружается.
Во всех AppNote описывается этот режим (ручное чтение). Т.е. вроде как должно работать.
Это я что-то делаю неправильно или так оно и есть?
Ниже лог АТ команд:

Код
AT+CGMR

+CGMR: 1575B14SIM5320E

OK
AT+CNSMOD?

+CNSMOD: 0,5

OK
AT+CIPRXGET=1

OK
AT+CGSOCKCONT=1,"IP",""

OK
AT+CSOCKSETPN=1

OK
AT+NETOPEN

OK

+NETOPEN: 0
AT+IPADDR

+IPADDR: 10.151.50.63

OK
AT+CIPOPEN=0,"TCP","ya.ru",80

OK

+CIPOPEN: 0,0

AT+CIPSEND=0,

>GET / HTTP/1.1
Host: ya.ru
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Accept: text / html


OK

+CIPSEND: 0,143,143



RECV FROM:87.250.250.242:80

+IPD478

+CIPRXGET: 1,0
AT+CIPRXGET=2,0,1024

+CIPRXGET: 2,0,478,0
HTTP/1.1 302 Found
Date: Wed, 25 Apr 2018 18:46:49 GMT
Cache-Control: no-cache,no-store,max-age=0,must-revalidate
Location: https://ya.ru/
Expires: Wed, 25 Apr 2018 18:46:49 GMT
Last-Modified: Wed, 25 Apr 2018 18:46:49 GMT
P3P: policyref="/w3c/p3p.xml", CP="NON DSP ADM DEV PSD IVDo OUR IND STP PHY PRE NAV UNI"
Set-Cookie: yandexuid=8066237061524682009; Expires=Sat, 22-Apr-2028 18:46:49 GMT; Domain=.ya.ru; Path=/
X-Content-Type-Options: nosniff
Content-Length: 0



OK
************ Закрываю TCP соединение
AT+CIPCLOSE=0

OK

+CIPCLOSE: 0,0
************ Снова пытаюсь открыть
AT+CIPOPEN=0,"TCP","ya.ru",80

OK
************ Модуль не отвечает ...

Go to the top of the page
 
+Quote Post
glader
сообщение Jul 25 2018, 12:35
Сообщение #2





Группа: Новичок
Сообщений: 4
Регистрация: 6-03-18
Пользователь №: 102 179



Цитата(borman11 @ Apr 25 2018, 21:29) *
Работаю с модулем через USB.
Если включен автоматический прием данных ...

У меня хуже. Работаю с модулем через UART.
Хоть ручной режим, хоть автоматический (AT+CIPRXGET), хоть командный режим, хоть режим данных -
коннект через ~3 min. после посылки отваливается:
+IPCLOSE: 0,1 (Closed by remote, passive) or
+IPCLOSE: 0,2 (Closed for sending timeout) -
c завидным постоянством для целой вереницы серверов.
CODE
AT+CGMR
AT+CGMR
+CGMR: 1575B13SIM5320E
OK
AT+CIPRXGET=0
AT+CIPRXGET=0
OK
AT+CNSMOD?
AT+CNSMOD?
+CNSMOD: 0,5
OK
AT+CGSOCKCONT=1,"IP",""
AT+CGSOCKCONT=1,"IP",""
OK
AT+CSOCKSETPN=1
AT+CSOCKSETPN=1
OK
AT+NETOPEN
AT+NETOPEN
OK
+NETOPEN: 0
AT+CIPOPEN=0,"TCP","google.com",80
AT+CIPOPEN=0,"TCP","google.com",80
OK
+CIPOPEN: 0,0
AT+CIPSEND=0,
AT+CIPSEND=0,
GET / HTTP/1.1\nHost: google.com\nUser-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0\nAccept: text/html\n\n
>GET / HTTP/1.1\nHost: google.com\nUser-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0\nAccept: text/html\n\n
OK
+CIPSEND: 0,141,141
+IPCLOSE: 0,1

AT+CIPCCFG?
AT+CIPCCFG?
+CIPCCFG: 10,0,1,1,0,0,500
OK
AT+CIPTIMEOUT?
AT+CIPTIMEOUT?
+CIPTIMEOUT:120000,120000,120000
OK

На тот же самый GET-запрос (в точности), посланный PacketSender, немедля прилетает ответ:
CODE
HTTP/1.1 301 Moved Permanently
Location: http://www.google.com/
Content-Type: text/html; charset=UTF-8
Date: Wed, 25 Jul 2018 10:33:50 GMT
Expires: Fri, 24 Aug 2018 10:33:50 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 219
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN

<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.com/">here</A>.
</BODY></HTML>

Описанные в SIMCom_3G_TCPIP_Application Note _V3.70 сценарии "TCP Client/Server" для command/data
режимов завершаются точно также - отвалом; а "UDP Socket" для обоих режимов работают без проблем (сервер на белом
адресе). Из встроенных приложений по FTP файл забираю; как только HTTP - "+CHTTPSNOTIFY: PEER CLOSED".
Таймауты для TCP и config (AT+CIPCCFG?) стоят умалчиваемые (см.).
В чем может быть причина такого странного поведения?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 


RSS Текстовая версия Сейчас: 14th August 2018 - 08:05
Рейтинг@Mail.ru


Страница сгенерированна за 0.01022 секунд с 7
ELECTRONIX ©2004-2016