реклама на сайте
подробности

 
 
2 страниц V  < 1 2  
Reply to this topicStart new topic
> Запуск PCIE HARD IP Core, поделитесь опытом.
DuHast
сообщение Apr 26 2018, 16:03
Сообщение #16


Местный
***

Группа: Свой
Сообщений: 305
Регистрация: 13-07-06
Из: Москва
Пользователь №: 18 797



Цитата(Kuzmi4 @ Apr 26 2018, 15:21) *
Это вы про AN693 ??

Да. Вы пробовали? Как впечатление? Много возни? Можно ли быстро поднять без опыта работы с NIOS ?
Go to the top of the page
 
+Quote Post
new123
сообщение Apr 29 2018, 11:18
Сообщение #17


Частый гость
**

Группа: Участник
Сообщений: 129
Регистрация: 30-11-17
Пользователь №: 100 438



Пока пытаюсь прикрутить качественно логи, выяснил, что ip core не выдает в приложение тактовый сигнал pld_clk (пытаюсь от него сделать делитель на 1гц и подать на диод моргание). Пока только мнение, что корка не тактируется шиной refclk и она не завелась. Либо получается что то у нее внутри не так.

Сообщение отредактировал new123 - Apr 29 2018, 11:19
Go to the top of the page
 
+Quote Post
Kuzmi4
сообщение May 4 2018, 08:46
Сообщение #18


Гуру
******

Группа: Свой
Сообщений: 3 297
Регистрация: 13-02-07
Из: 55°55′5″ 37°52′16″
Пользователь №: 25 329



Цитата(DuHast @ Apr 26 2018, 19:03) *
Вы пробовали?

Пока только планирую. Сам думал уже кто то пробовал laughing.gif
Go to the top of the page
 
+Quote Post
new123
сообщение May 4 2018, 11:27
Сообщение #19


Частый гость
**

Группа: Участник
Сообщений: 129
Регистрация: 30-11-17
Пользователь №: 100 438



не ожидал я подвоха от кода альтеры. Если по пину pcie perstl (reset) приходит низкий сигнал, статусные диоды L0, gen2, gen3 и тд все равно показывает ОК. Потому что регистры сбрасываются в ноль, этим самым зажигая диоды. Так что я пошел изначально по ошибочному пути
Go to the top of the page
 
+Quote Post
new123
сообщение May 8 2018, 13:20
Сообщение #20


Частый гость
**

Группа: Участник
Сообщений: 129
Регистрация: 30-11-17
Пользователь №: 100 438



Залез я в саму корку. Начал доставать внутренние сигналы. И сразу смотря на них, пришла идея проверить все питания, указанные по трансиверам в datasheet.
Vcchssi нет в трех точках из шести. Это PCS power
Go to the top of the page
 
+Quote Post
new123
сообщение Jun 22 2018, 15:56
Сообщение #21


Частый гость
**

Группа: Участник
Сообщений: 129
Регистрация: 30-11-17
Пользователь №: 100 438



Вообщем проблема ясна. После того как попытался запустить 10G с нуля.
Микруха внешняя PLL что то не то генерирует, не те частоты. Вокруг нее паленая обвязка из резисторов. Трансиверы не тактируются.

Сообщение отредактировал new123 - Jun 22 2018, 15:57
Go to the top of the page
 
+Quote Post

2 страниц V  < 1 2
Reply to this topicStart new topic
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 


RSS Текстовая версия Сейчас: 17th August 2018 - 18:06
Рейтинг@Mail.ru


Страница сгенерированна за 0.00996 секунд с 7
ELECTRONIX ©2004-2016