реклама на сайте
подробности

 
 
 
Reply to this topicStart new topic
> [Telit-UE866] Внезапно включается загрузчик
smalcom
сообщение Jul 5 2018, 08:43
Сообщение #1


Профессионал
*****

Группа: Свой
Сообщений: 1 292
Регистрация: 26-06-07
Пользователь №: 28 718



День добрый.
Столкнулся со странной проблемой с указанными модемами. Модем в устройстве работает нормально какое-то время, а потом впадает в странное состояние, из которого потом не выходит.
В этом состоянии происходит следующее:
1, Включаю питание модема;
2. Жду 6 секунд;
3. Отправля. "АТ\r\n";
4. Получаю не OK, а странную последовательность
"0xf0, 0x16, 0x51, 0x94, 0x2, 0x0, 0x1a, 0x0, 0x0, 0x0, 0x93, 0x21, 0x10, 0x1, 0x95, 0x0, 0x8d, 0xf2, 0x50, 0x0, 0x0, 0xe0, 0xff, 0xff"
Последовательность сия всегда одна и та же, что натолкнуло на мысль - может это обработчик сбоя какой-то отправляет.

Поговорил с ТП Телита. Всего лишь через два месяца они ответили, что эта последовательность - это ответ загрузчика модема. И выйти из загрузчика программно нельзя, надо выключать питание.
Но отключение питания не помогает. Т.е. если модем вошёл в это состояние в загрузчике, то больше оттуда не выходит.

Уже всё отпаял от модема, оставил только RX, TX и те через выключатели, чтоб модем запускался аки девица - не помогает. Один раз помогло одно действие - выпаял и впаял модем назад, после
этого он где-то час проработал нормально, а потом опять включился загрузчик.

Уже не могу придумать куда копать.
Go to the top of the page
 
+Quote Post
Tweeek
сообщение Jul 5 2018, 09:04
Сообщение #2


Участник
*

Группа: Участник
Сообщений: 74
Регистрация: 23-01-13
Из: СПб
Пользователь №: 75 303



Цитата(smalcom @ Jul 5 2018, 11:43) *
День добрый.
Столкнулся со странной проблемой с указанными модемами. Модем в устройстве работает нормально какое-то время, а потом впадает в странное состояние, из которого потом не выходит.
В этом состоянии происходит следующее:
1, Включаю питание модема;
2. Жду 6 секунд;
3. Отправля. "АТ\r\n";
4. Получаю не OK, а странную последовательность
"0xf0, 0x16, 0x51, 0x94, 0x2, 0x0, 0x1a, 0x0, 0x0, 0x0, 0x93, 0x21, 0x10, 0x1, 0x95, 0x0, 0x8d, 0xf2, 0x50, 0x0, 0x0, 0xe0, 0xff, 0xff"
Последовательность сия всегда одна и та же, что натолкнуло на мысль - может это обработчик сбоя какой-то отправляет.

Поговорил с ТП Телита. Всего лишь через два месяца они ответили, что эта последовательность - это ответ загрузчика модема. И выйти из загрузчика программно нельзя, надо выключать питание.
Но отключение питания не помогает. Т.е. если модем вошёл в это состояние в загрузчике, то больше оттуда не выходит.

Уже всё отпаял от модема, оставил только RX, TX и те через выключатели, чтоб модем запускался аки девица - не помогает. Один раз помогло одно действие - выпаял и впаял модем назад, после
этого он где-то час проработал нормально, а потом опять включился загрузчик.

Уже не могу придумать куда копать.


Пришлите номер case из переписки с TS - посмотрю, что там было.
Вообще загнать модуль в режим загрузки можно только отправляя ему после включения <BootChars> каждые 60 мс - 0x41 0x54.
В противном случае надо снимать дамп и смотреть, что происходит. Но меня смущает тот факт, что после перепайки он какое то время работал... поэтому скорее всего вариант с BootChars.
Go to the top of the page
 
+Quote Post
smalcom
сообщение Jul 5 2018, 09:17
Сообщение #3


Профессионал
*****

Группа: Свой
Сообщений: 1 292
Регистрация: 26-06-07
Пользователь №: 28 718



Цитата
Но меня смущает тот факт, что после перепайки он какое то время работал...

Да, в том и моё недоумение: устройства прийдя с завода работают нормально какое-то время: кто-то неделю, кто-то день, кто-то полчаса.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 


RSS Текстовая версия Сейчас: 21st September 2018 - 18:34
Рейтинг@Mail.ru


Страница сгенерированна за 0.01032 секунд с 7
ELECTRONIX ©2004-2016