Jump to content

    
Sign in to follow this  
bureau

EE & Linux

Recommended Posts

Как известно ЕЕ очень тормозит под Ubuntu 11.10. Проблема связана с MainWin.

Кто-нибуть разбирался, пытался понять причину такой ситуации?

 

нашел (СДЕСЬ) предложение по решению (СДЕСЬ), в моем случае не помогло :(

Share this post


Link to post
Share on other sites

По поводу EE & Linux очень ёмко выразились вот здесь. Если не секрет, а что именно заставляет работать с EE под ОС, отличной от windows? Вроде столько копий уже сломано, но все равно как в анекдоте: ежики плакали, кололись но продолжали есть кактус. :laughing:

Share this post


Link to post
Share on other sites
По поводу EE & Linux очень ёмко выразились

Давайте не вести демагогию. Есть проблемма, человек попросил о помощи...

Если у кого-то проблемы с двумя мониторами, то это уже не проблемма ЕЕ. Есть официальная поддержка ЕЕ под некоторые дистрибутивы Linux, а это уже что-то. Разница между разными дистрибутивами не очень большая: некоторые библиотеки и пути к ним.

Вот когда уже сам ЕЕ глючит, это другое дело... Но я пока этого не замечал. Если знаете о проблеммах которое проявляются только под Linux, я бы не против бы о них услышать, веть для этого я эту ветку и создал...

Share this post


Link to post
Share on other sites

Подробно разбирался с этим вопросом (собственно, тема по первой ссылке - моя).

 

После боданий с MainWin забил на линуксовый дистриб EE. Просто запускаю Win под VirtualBox, а затем из Win - EE.

Для меня такой подход оказался наиболее рабочим, сейчас им и повседневно пользуюсь. Altium тоже так запускаю.

Share this post


Link to post
Share on other sites

Я ставил такие

 

export MGLS_HOME="/opt/design/lic/flexlm"
export MGLS_DEBUG_LOG_DIR="/opt/design/lic/flexlm"
export MGLS_LICENSE_FILE="/opt/design/lic/flexlm/mentor.lic"

export SDD_ROOT="/opt/design/mentor"
export SDD_HOME="$SDD_ROOT/7.9.2EE/SDD_HOME"
export MGC_HOME="$SDD_ROOT/7.9.2EE/MGC_HOME.ixl"
export WDIR="/opt/project/expedition/wdir:$SDD_HOME/standard"

export MGC_EGS_LOG_STDOUT_ENABLE=1
export MGC_EGS_LOG_FILE="/opt/design/egs_trace.txt"
export MGC_EGS_LOG_LEVEL=verbose
export MGC_EGS_LOG_MASK=all

 

Хотя, понятно, что не все они обязательны.

Share this post


Link to post
Share on other sites

Некоторая помощь от http://communities.mentor.com

 

Well, yes, most such troubles are about MainWin. Not sure what historical reasons lets them use it and why it was not ported

to something like Qt - like other vendors do.

 

Anyway, these are 3 most common problems with Expedition/DxD:

 

1. wrong host ip /etc/hosts. For some reason MainWin gets crazy if hostname does not point to local loopback.

This causes usually segfaults in that funny registration procedure.

however, pointing hostname to 127.0.0.1 is a bad idea as that is the localhost. Instead point hostname to 127.0.0.2

 

2. location of tmp directory. For some reason, if system is configured for private temp-dir below user $HOME, it does not play

well with Mentor/Mainwin. Make sure you have common tmp in /tmp

 

3. yeah, X11 libs too new. Typically startup script just hangs in each registration step.

Those "experts" at Mentor always link the stuff against ancient SLES x11 libs. Take older

libs from older distro and use "export LD_LIBRARY_PATH=/your/path/to/oldx11libs:${LD_LIBRARY_PATH}"

in your start script and you have good chances to run is under your latest distro version. Often just an old libx11.so.6.2.0 will do.

 

In some cases, setting "export MWWM=allwm" helps to play more nicely with the windows manager

 

Mostly you will get it work, but generally MainWin on linux is nothing but a bad joke. Not speaking about printing,

filesystems with 64bit inodes, etc...

Share this post


Link to post
Share on other sites

Для интересующихся работой с ЕЕ под Linux...

================

EE7.9.3;

Ubuntu 12.04 64bit

================

Работает без тормозов.

Все устанавливал из под user. Пользователя root не использовал.

Share this post


Link to post
Share on other sites
Кто-то пробовал ставить ЕЕ7,9,4 на Ubuntu 12.04(12.10)?

У меня ставится, но при попытке запустить Dashboard выдает кучу ошибок...

 

Ubuntu под рукой нет, а на Debian Squeeze 6.0.6:

Linux maximus 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64 GNU/Linux

Libc 2.11.3-4

 

Все запускается, но Expedition PCB падает после попытки преобразования проекта, сделанного в EE7.9.3.

Буду разбираться.

 

Share this post


Link to post
Share on other sites

После нескольких падений Expedition PCB я закрыл Dashboard и он тоже перестал запускаться. Ругался на что-то связанно с OLE.

 

В итоге я кажется разобрался. Проблема была видимо в том, что EE7.9.3 поставляется с MW 5.2, а EE7.9.4 идет с MW 5.4.

И что-то у них внутри поменялось. После удаления директории .mw из директории все стало хорошо.

Проверил Dashboard, Library Manager, Expedition PCB, Cell Editor, Symbol Editor, DxDesigner.

Share this post


Link to post
Share on other sites

И так...

Вот что имеем... И так на все подряд...

 

regedit /opt/mentor/7.9.4EE/SDD_HOME/common/linux/epd.reg

/opt/mentor/7.9.4EE/SDD_HOME/common/linux/MainWin5/bin-linux_optimized/regedit: symbol lookup error: /usr/lib/i386-linux-gnu/libXext.so.6: undefined symbol: _XGetRequest

ERROR-REGISTER FAILED - /opt/mentor/7.9.4EE/SDD_HOME/common/linux/epd.reg

 

Похоже что не та версия библиотеки... Установлена 6.4.0

У вас какая версия libXext установлена?

 

Дополнение1

На Ubuntu12.04, ЕЕ7.9.3 с версией libXext.so.6.4.0 работает нормально

 

Дополнение2

Your libXext was compiled against libX11 1.5 but you're running it with an older libX11 not containing the new function added in 1.5.

 

$ ldd libXext.so.6

linux-gate.so.1 => (0xf77ca000)

libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7664000)

libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf74ba000)

libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf7498000)

libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7493000)

/lib/ld-linux.so.2 (0xf77cb000)

libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf748f000)

libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf7488000)

strings libXext.so.6 | grep _XGet

_XGetRequest

_XGetScanlinePad

_XGetBitsPerPixel

strings libX11.so.6 | grep _XGet

_XGetRequest

_XGetAsyncReply

_XGetAsyncData

_XGetHostname

_XGetScanlinePad

_XGetWindowAttributes

_XGetBitsPerPixel

_XGetLCValues

 

Share this post


Link to post
Share on other sites

Сообщения вида:

/opt/mentor/7.9.4EE/SDD_HOME/common/linux/MainWin5/bin-linux_optimized/regedit: symbol lookup error: /usr/lib/i386-linux-gnu/libXext.so.6: undefined symbol: _XGetRequest

в ЕЕ 7.9.4 починил коррекцией файлов посредством комментирования строк, относящихся к использованию Х-библиотек, поставляемых с MainWin5: /SDD_HOME/common/linux/MainWin5/setup-mwuser

	   export _THREAD_LOCKS_MISALIGNED
fi
;;

linux)
#~ LD_LIBRARY_PATH=${LD_LIBRARY_PATH:-}
#~ libX11=`ldd "${MWHOME}"/bin-${MWARCH_OS}/mwxcbtest | grep libX11.so | awk '{print $3}'`
#~ libxcb=`ldd ${libX11} | grep libxcb.so | awk '{print $3}'`
#~ if [ "x$libxcb" != "x" ]; then
	#~ MWUSE_XCB=true
	#~ LD_LIBRARY_PATH="${MWHOME}"/lib-${MWARCH_OS}/X11:${LD_LIBRARY_PATH}
	#~ if [ "x$XLOCALEDIR" = "x" ]; then
		#~ XLOCALEDIR=`strings ${libX11} | grep "/locale" | head -n 1`
		#~ export XLOCALEDIR
	#~ fi
	#~ if [ "x$XKEYSYMDB" = "x" ]; then
		#~ XKEYSYMDB=`strings ${libX11} | grep "XKeysymDB"`
		#~ export XKEYSYMDB
	#~ fi
#~ fi
#~ export LD_LIBRARY_PATH
# For backwards-compatible behaviour of setjmp/longjmp
# in glibc-2.4 and higher
glibcver=`rpm -q glibc | sed -n -e '1s/^glibc-\([0-9]*\.[0-9]*\)[.-].*$/\1/p'`

case ${glibcver} in
2.4) LD_POINTER_GUARD=1;;

и

/SDD_HOME/common/linux/MainWin5/setup-mwuser.csh :

    unsetenv osver

   breaksw
case linux:
   #~ if (! ${?LD_LIBRARY_PATH}) then
       #~ setenv LD_LIBRARY_PATH ""
   #~ endif
   #~ setenv libX11 `ldd "${MWHOME}"/bin-${MWARCH_OS}/mwxcbtest | grep libX11.so | awk '{print $3}'`
   #~ setenv libxcb `ldd ${libX11} | grep libxcb.so | awk '{print $3}'`
   #~ if ( x${libxcb} != x) then
       #~ setenv MWUSE_XCB true
#~ if (! ${?XLOCALEDIR}) then
	#~ setenv XLOCALEDIR `strings ${libX11} | grep "/locale" | head -n 1`
#~ endif
#~ if (! ${?XKEYSYMDB}) then
	#~ setenv XKEYSYMDB `strings ${libX11} | grep "XKeysymDB"`
#~ endif
#~ setenv LD_LIBRARY_PATH "${MWHOME}"/lib-${MWARCH_OS}/X11:${LD_LIBRARY_PATH}
   #~ endif
   unsetenv libxcb
   unsetenv libX11
   # For backwards-compatible behaviour of setjmp/longjmp
   # in glibc-2.4 and higher
   set glibcver=`rpm -q glibc | sed -n -e '1s/^glibc-\([0-9]*\.[0-9]*\)[.-].*$/\1/p'`

   switch ($glibcver)

Одна проблемма:

DX стартует очень долго, бывает до полторы минуты, при выключении DX так же долго пишет резерв какой то базы данных.

OpenGL работает нормально.

дистрибутив - Gentoo

X: xorg-server-1.13.1

glibc-2.15

драйвер nvidia - 313.18

оконная система - Gnome - 2.32

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this