Jump to content

    
Sign in to follow this  
vitko

"Нелюбимые" Ethernet-пакеты

Recommended Posts

Есть устройство на LPC2378 + трансивер DP83848I. Работает на 10Мбит как TCP-сервер.

На одном из объектов стабильно не приходят ответы на одну из команд загрузки данных в устройство. Сама команда выполняется и ответ как бы отправляется устройством, но в сети его не видно. В пакете присутствует циклический номер, поэтому он каждый раз разный, обмен по принципу запрос - ответ.

Этот эффект стабильно наблюдается на протяжении рабочего дня, часов в 7 вечера весь обмен уже идет нормально. Сеть довольно нагруженная, но разницы в интенсивности траффика днем и вечером нету.

Может кто-то объяснить этот эффект?

Edited by vitko

Share this post


Link to post
Share on other sites
ответ как бы отправляется устройством

А как Вы определяете что пакет в сеть уходит? Можно взять свитч с функцией Port Mirrorring, и промониторить что именно приходит-уходит на сетевом уровне с устройства. Если пакет из устройства таки уходит, то копать уже саму сеть.

 

P.S. У меня тоже похожий прикол есть - сайт Микрела на рабочем компе не открывается. Не зависит от браузера, FW нету, VPN нету. Рядом в той же локалке с ноута или другого компа все работает, то есть с маршрутом все OK. Мониторинг WireShark-ом показывает что пропадает первый TCP-пакет высылаемый сервером в ответ на HTTP GET, следующие пакеты за выпавшим приходят нормально, но TCP поток уже разрушен. Почему так - непонятно. Заголовки HTTP-запросов GET от работающего рядом ноута и от проблемного компа - одинаковые (это отметает вопросы по кукам и прочей виновности браузера).

 

Share this post


Link to post
Share on other sites
Сеть довольно нагруженная, но разницы в интенсивности траффика днем и вечером нету.

Может кто-то объяснить этот эффект?

Похожая фигня была из-за настроек сети. Админы устраивали ряд препонов в рабочее время, что бы народ не гонял по сети фильмы, не подсоединялся к цветному принтеру и т.д. Причём настраивали так, что в конце рабочего дня эти препятствия автоматически отключались. Возможно у вас та же хрень.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this