Jump to content

    

Не работает Спектре в Cadence 6.14

 

Я гонял версию 5.141 уже несколько месяцев в 32-битном режиме на 64 битном Scientific Linux..

Сейчас начинаю использовать активно версию 6.14, установил MMSIM10. 017 Updateи 10. 029 Hotfix

 

Симулирую простой инвертер, когда запускаю ADE XL выставляю параметры и стартую, то он мне в консоле просто выдает:

t

nil

 

и все...стоит. Как быть в чем может быть проблема? Я сам Cadence 6.14 лечил сфк патчем, а также папки установки с Ассурой и MMSIM, пробовал переустановить MMSIMи не лечить...и кстати запускался тоже без проблем! но всеравно не идет симуляция!

 

помогите победить, что может быть нетак?

Share this post


Link to post
Share on other sites

Тоже долго исследовали этот вопрос и выяснили, что ADE XL, в отличие от ADE L, использует абсолютные пути к установленным шрифтам.

Лечение:

1. В home папке найти папку "./vnc-cds", посмотреть в каком либо из логов какой путь к шрифтам хочет ADE XL (последняя строка), обычно это "/usr/X11R6/lib/X11/fonts".

2. Найти где фактически в вашем линуксе лежат шрифты. В моем Убунту это там: "/etc/X11/fonts".

3. Создать папку "/usr/X11R6/lib/X11" и в ней сделать символьный линк "fonts" на папку со шрифтами "/etc/X11/fonts".

 

Заработало без перезапуска виртуозо и без перезагрузки линукса)

Share this post


Link to post
Share on other sites

посмотрел я этот лог файл, последняя строчка там такая:

Font directory '/usr/share/X11/fonts/' not found - ignoring

 

 

но дело в том что данная папка: /usr/share/X11/fonts/ существует, и внутри нее папки есть со шрифтами!

 

Я попробовал дать разрешение на эту папку полностью пользователю..тоже не помогло.

 

Ведь то что он говорит что не может найти: not found - ignoring, это странно как то... ведь папка то есть!

 

 

что еще может там быть?

Share this post


Link to post
Share on other sites

yum не может найти такого пакета. в инете этот пакет находится только для Дебиан и Убунту.

 

его точно нужно устанавливать? и где его найти?

 

я этой командой:

yum list available | grep xorg-x11-font

 

проверил какие есть шрифты имеющие отношение к Х11, и все что вышло установил. там xfonts-base не было

 

 

а может проблема в чем то еще другом?

 

3. Создать папку "/usr/X11R6/lib/X11" и в ней сделать символьный линк "fonts" на папку со шрифтами "/etc/X11/fonts".

 

 

у меня есть папка: /etc/X11/fontpath.d

внутри которой есть три линка:

xorg-x11-fonts-75dpi:unscaled:pri=20

xorg-x11-fonts-100dpi:unscaled:pri=30

xorg-x11-fonts-cyrillic

 

которые указывают на определенные папки со шрифтами в /usr/share/X11/fonts

 

 

я попробовал сделать:

ln -s /etc/X11/fontpath.d/ /usr/X11R6/lib/X11/fonts не помогло

ln -s /usr/share/X11/fonts/ /usr/X11R6/lib/X11/fonts тоже не помогло

 

еще раз замечу, /usr/share/X11/fonts/ это реальная папка где лежат все установленные шрифты Х11. т.е. ваш пункт №3 не сработал.

а чисто логически... в моем случае папка которую АДЕ ХЛ запрашивает уже содержит шрифты...т.е. линки и вовсе не нужны. но по любому ни то ни другое не сработало.

 

 

не могу понять чтоже там еще может быть не так? помогите пожалуйста, очень нужно

Share this post


Link to post
Share on other sites

В моем линуксе в папке fonts есть подпапки с такими именами:

100dpi

75dpi

Type1

misc

 

Предположу что виртуозо использует один из первых двух шрифтов, а м.б. и оба вместе...

Share this post


Link to post
Share on other sites

да эти шрифты у меня есть. у меня в папке /usr/share/X11/fonts лежат папки:

75dpi

100dpi

cyrillic

encodings

misc

Type1

util

 

я сейчас решил попробовать сделать чистую инсталляцию на другой комп, с 32-битным линуксом SL6.1, установил средства Кэденс, поправил sfkпатчем, указал лицензию.

 

начинаю симулировать...тоже самое. не идет и все. понятия не имею в чем дело!

 

 

действительно ли проблема в шрифтах?! Я полазил в нете, и увидел что когда проблема именно с каким то шрифтом, то в логе vnc сервера обычно ругается что нет папки с конкретным шрифтом, но в моем случае это ведь не так.

 

В моем случае он просто пишет что не может найти папку /usr/share/X11/fonts в то время как эта папка существует! что там еще может быть? почему vnc не видит папку которая на самом деле есть где надо?

Share this post


Link to post
Share on other sites

Права на доступ к папкам стоят правильные?

 

PS. А еще шрифты д.б. не просто в этих папках, но и д.б. инсталлированы в систему...

Share this post


Link to post
Share on other sites
Права на доступ к папкам стоят правильные?

я даже давал полные права на доступ пользователю, не помогло.

 

PS. А еще шрифты д.б. не просто в этих папках, но и д.б. инсталлированы в систему...

ну так я же с yum install устанавливаю в систему значит и установилось! ....шрифты в этой папке /usr/share/X11/fonts ...где еще в системе они должны быть?

Share this post


Link to post
Share on other sites

Ну вобщем такое тут дело, я узнал, что законный (не тот который лечению подвергается) Кэденс установленный на 32 битную машину с таким же линуксом, СЛ6.1 работает нормально, и что самое интерестное - там тоже выдается сообщение в лог файле что папка со шрифтами не найдена(!). Однако симуляция идет и все работает как надо!

 

отсюда вывод - дело в данном случае не в шрифтах, а в лечилке, которая каким то образом может портит файлы кэденса или что еще, или же дело в лицензии корявой.

 

возможно то что я в нете скачивал, и в закромах не работает как надо?

 

Кто может поделится своим лекарством или вылеченной лицензией? Если можно скиньте кто-нибудь в личку или дайте как то мне знать?

 

Заранее спасибо!

Share this post


Link to post
Share on other sites

Jurenja, M@kar

 

спасибо, скачал тот патч с линка, сработал на кэденсе установленном на 32-битную машину.

 

Но...с 64-битной версией та же проблема.

 

 

А нельзя ли каким то образом сделать так, чтобы на 64-битной машине, когда я запускал АДЕ ХЛ из схематика, то вызывалась 32-битная версия?

 

где это можно прописать?

 

после установки переменной:

setenv CDS_AUTO_64BIT "EXCLUDE:spectre"

 

симулятор во время запуска выдал вот такого рода ошибки в лог файле :

>>> Running isReadable /home/soft/cadence/ic614/tools/dfII/lib/libsrrjava.* 21:

ERROR: Cannot read file /home/soft/cadence/ic614/tools/dfII/lib/libsrrjava.*. Possible installation problem.
OKAY


------------------------------------------------------------------------------


>>> Running isReadable /home/soft/cadence/ic614/tools/dfII/lib/libwslicense.* 22:

ERROR: Cannot read file /home/soft/cadence/ic614/tools/dfII/lib/libwslicense.*. Possible installation problem.
OKAY


------------------------------------------------------------------------------


>>> Running isReadable /home/soft/cadence/ic614/tools/dfII/lib/libskeoceanmeas.* 23:

ERROR: Cannot read file /home/soft/cadence/ic614/tools/dfII/lib/libskeoceanmeas.*. Possible installation problem.
OKAY


------------------------------------------------------------------------------


>>> Running isReadable /home/soft/cadence/ic614/tools/dfII/lib/libacvmeasreader.* 24:

ERROR: Cannot read file /home/soft/cadence/ic614/tools/dfII/lib/libacvmeasreader.*. Possible installation problem.
OKAY

 

может как то по другому надо исключать спектру из запуска в 64-битном режиме?

Share this post


Link to post
Share on other sites

Возможно что-то не то со связкой виртуозо+лечилка для 64-битного линукса...

А поработать в этом виртуозо на 32-битном линуксе - чем не вариант?

Share this post


Link to post
Share on other sites
Jurenja, M@kar

 

спасибо, скачал тот патч с линка, сработал на кэденсе установленном на 32-битную машину.

 

Но...с 64-битной версией та же проблема.

 

 

А нельзя ли каким то образом сделать так, чтобы на 64-битной машине, когда я запускал АДЕ ХЛ из схематика, то вызывалась 32-битная версия?

 

где это можно прописать?

 

после установки переменной:

setenv CDS_AUTO_64BIT "EXCLUDE:spectre"

 

симулятор во время запуска выдал вот такого рода ошибки в лог файле :

 

может как то по другому надо исключать спектру из запуска в 64-битном режиме?

 

Согласно документации по умолчанию запускаются 32-битные приложения.

Может стоит попробовать наоборот включить все в 64 бита?

setenv CDS_AUTO_64BIT "ALL"

 

P.S. Использую 32-битную 6.14 на 64-битной CentOS 5.7. Все прекрасно работает.

Share this post


Link to post
Share on other sites
А поработать в этом виртуозо на 32-битном линуксе - чем не вариант?

конечноже это вариант. думаю так и сделаю.

 

P.S. Использую 32-битную 6.14 на 64-битной CentOS 5.7. Все прекрасно работает.

32-битный 6.14 на 64-битном SL6.1 выдает Segmentation Fault

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this