Jump to content

    
Sign in to follow this  
Koluchiy

? по симуляции NIOS в ModelSim

Recommended Posts

Здравствуйте, уважаемые гуру.

 

Пытаюсь я тут освоить симуляцию NIOS в ModelSim-Altera.

Quartus со всеми своими частями - версии 9.1, не ломаный (имеет файл лицензии с некоторым количеством пунктов).

 

Ну так вот.

Делаю примерно по AN351, но трабла в том, что на альтеровском сайте оно уже всё под V11 и QSYS.

Не заделится ли кто-нибудь аппнотом и прилагающимся к нему проектом под SOPC Builder?

Или подскажите, где лежат старые версии...

 

Тем не менее, если сделать в духе имеющегося AN351.

Создаю простенькую систему в SOPC Builder. Создаю проект в NIOS. Ставлю в свойствах BSP галку "Modelsim Only, no hardware support".

Компилирую, ни на чего не ругается.

 

При попытке сделать "Run As" в Моделсиме, вижу, что этот самый пункт "Run As" содержит только один подпункт - "Local c/c++ application".

Т.е., пункт "Run As/Nios II ModelSim" отсутствует.

 

Что может приводить к такому явлению?

Чего-то не так настроил, или дело в отсутствующей лицензии.

Share this post


Link to post
Share on other sites
При попытке сделать "Run As" в Моделсиме, вижу, что этот самый пункт "Run As" содержит только один подпункт - "Local c/c++ application".

смахивает на перманентный косяк эклипса/жабы: периодически пропадают конфигурации запуска/симуляции. пункта "запустить на железе" тоже нет? что вообще в Run(Debug)/Configurations?

Share this post


Link to post
Share on other sites

Нда...

 

Я тут подумал - может ли быть вся фишка в том, что у меня Win7 64bit? :)

 

Кстати, два квартуса разных версий хорошо вместе живут, или плохо?

Share this post


Link to post
Share on other sites

У меня Win7 64bit, никаких проблем нету. Но я работаю с админ правами и выключенным контролем пользователей. И у меня стоит два квартуса 10.2 и 11, проблем нету)

Share this post


Link to post
Share on other sites

Кто-нибудь пробовал гонять 9.1 на Win7 64bit?

После сноса 9.1 и установки 10.1 больше без никаких телодвижений проблема решилась.

 

Застрелиццо, в 10 и 11 версиях не работает одна нужная фича, в 9 не работает другая :wacko: .

Share this post


Link to post
Share on other sites
Тем не менее, если сделать в духе имеющегося AN351.

Создаю простенькую систему в SOPC Builder. Создаю проект в NIOS. Ставлю в свойствах BSP галку "Modelsim Only, no hardware support".

Попытался тоже отсимулировать, но дал ошибку:

Error: (vsim-19) Failed to access library 'unnamed_sim' at "unnamed_sim".

 

Share this post


Link to post
Share on other sites

После большого перерыва вернулся к вопросу.

 

Quartus 12.0sp2, Modelsim Altera Edition.

Win7 64bit.

 

При запуске "Run as Modelsim" вылезает окошко с ошибкой (см. картинку).

Кто-нибудь сталкивался с таким? Кто виноват, и как обойти.

Делал всё в точном соответствии с AN351.

 

На Альтеровском форуме удалось найти нечто похожее про Ubuntu (там зачем-то правят sh.jar.sh), но попытки что-то взять оттуда к результату не привели.

 

Всем заранее спасибо за ответы.

post-47543-1347866328_thumb.png

Share this post


Link to post
Share on other sites

2 Koluchiy

я обычно SoPC системы симулирую без гуя (пишу сам скрипты, всегда работает B) ). Могу заслать примерчик что для студеров писал, проверялось на железе - фунциклирует ;)

( Quartus II Version 10.0 Build 262 08/18/2010 Service Pack 1 SJ Full Version)

Share this post


Link to post
Share on other sites

Ну если Вы не против пояснять, что к чему - то я тем более не против.

Почту написать? :)

 

Но хотелось бы, конечно, запустить по классике, через GUI.

Должно же оно работать :).

Share this post


Link to post
Share on other sites
Ну если Вы не против пояснять, что к чему - то я тем более не против.

Почту написать? :)

...

Там всё просто :biggrin: можно в личку.

 

...Но хотелось бы, конечно, запустить по классике, через GUI.

Должно же оно работать :).

Ну тут я не помошник :laughing: хилые отбили у меня всякое желание использовать гуи

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this