Jump to content

    

Eclipse + Nios II на Linux Ubuntu - как залить elf ?

Имеется Cyclone IV GX Transceiver Starter Kit

Систему залил программатором из Quartus II

Но Run->Debug Configurations->Nios II Hardware->Target Connection

в окошке Connections говорит:

No Nios II target connection paths were located. Check connections and that a Nios II .sof is downloaded

 

Пробовал из консоли:

nios2-download -g nios_start_app.elf

There are no Nios II CPUs with debug modules available which match the values

specified. Please check that your PLD is correctly configured, downloading a

new SOF file if necessary.

 

В Windows подключил - залил - заработало.

 

В чём может быть проблема в Linux?

У кого-нибудь есть опыт поднятия этого в Linux?

Share this post


Link to post
Share on other sites
Имеется Cyclone IV GX Transceiver Starter Kit

.........

 

В чём может быть проблема в Linux?

У кого-нибудь есть опыт поднятия этого в Linux?

хм. конечно страно запускать nios2-download, сначала нужно nios2-configure-sof тоесть SOF залить в плис, а потом софт

 

и попробуйте запустите jtagconfig из консоли

что выдаёт?

Share this post


Link to post
Share on other sites
хм. конечно страно запускать nios2-download, сначала нужно nios2-configure-sof тоесть SOF залить в плис, а потом софт

Согласен с вами, поэтому сначала sof заливаю.

Даже пробовал sof залить с Linux, а потом с Windows elf заливать - работает. Выходит, sof заливается правильно. Причём в Windows говорит, что какие-то идентификаторы не совпадают и при заливке с Linux, и при заливке с Windows, я ставлю галочки "игнорировать", прошиваю в Windows, и работает.

 

и попробуйте запустите jtagconfig из консоли

что выдаёт?

$./jtagconfig

1) USB-Blaster [4-1]

028010DD

 

$ ./jtagconfig -d

1) USB-Blaster [4-1]

028010DD (IR=10)

 

Captured DR after reset = (028010DD) [32]

Captured IR after reset = (155) [10]

Captured Bypass chain = (0) [1]

Edited by Juzujka

Share this post


Link to post
Share on other sites
Согласен с вами, поэтому сначала sof заливаю.

Даже пробовал sof залить с Linux, а потом с Windows elf заливать - работает. Выходит, sof заливается правильно. Причём в Windows говорит, что какие-то идентификаторы не совпадают и при заливке с Linux, и при заливке с Windows, я ставлю галочки "игнорировать", прошиваю в Windows, и работает.

...........

а eclipse как вы запускаете? дело в нём похоже

 

Share this post


Link to post
Share on other sites

Из QSys, самым обычным способом

Tools -> Nios II Software Buikd Tools foe Eclipse

Share this post


Link to post
Share on other sites

то-же самое и у меня. Стоит linux opensuse 11.4. Гружу sof нормально, elf eclipse грузить не хочет - говорит нет коннекта.

Кто-нибудь решил это под linux ?

Share this post


Link to post
Share on other sites

Та же песня. если у кого получится сделать - отпишитесь. Сам тоже буду копать.

Share this post


Link to post
Share on other sites

А у меня и под виндами такая беда. jtagconfig видит USB-blaster, а Eclipse Run Configurations - не видит =(

 

Решение найдено: http://electronix.ru/forum/index.php?showt...71863&st=15

 

Проблема оказалась в том, что Nios II 9.1 несовместим с Windows 7, которая и установлена на моем компьютере (32 бит). Запуск в режиме совместимости сразу же устранил проблему.
Это подтверждает и подобная тема на другом форуме: http://www.alteraforum.com/forum/showthread.php?t=19765

 

Предупреждать надо. Это проблема не IDE nios, а java машины под которой он работает.
Edited by Кузнецофф Ю.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this