Jump to content

    
Sign in to follow this  
DreamTwister

Проблема с UDP в SIM300D.

Recommended Posts

Добый день.

Вопрос в следующем. Отправляем команду:

 

AT+CIPSTART="UDP","ХХХ1.ru","ХХХ"

 

Соединяемся, работаем, отправляем/принимаем данные.

 

Потом:

 

AT+CIPCLOSE

 

Получаем ОК, далее:

 

AT+CIPSTART="UDP","ХХХ2.ru","ХХХ"

 

Соединяемся, данные уходят, но на сервере тишина.

Перезапускаем модем полностью, коннектится на 2-ой сервер нормально.

 

Не перезапуская модем удалось переключиться между серверами только используя AT+CIPSHUT.

Ну и зачем, спрашивается, нужна AT+CIPCLOSE, если она все равно не работает?

Или у SIMCOM 1 сессия = 1 соединение?

 

 

Share this post


Link to post
Share on other sites

:blink: Вы порносайты Ддосите ? )))

 

по теме. у мну работает как положено. только в TCP в UDP непробовал. может попробуйте CIPSTATUSOM посмотреть ?

Share this post


Link to post
Share on other sites

Возможно в том то и дело, что UDP.

Вариантов 2:

1. неправильно отрабатывает модем

2. неправильно отрабатывает NAT ОПСоСа.

 

С TCP все просто - канал закрылся, канал открылся. А с UDP все извращаются как могут (или как сумеют).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this