Jump to content

    

Вопрос к SAURIS GmbH

OlegSP, поищите cmd файл в тексасовских примерах для Вашего кристалла.

Share this post


Link to post
Share on other sites
yvk!

А можно ссылку если не затруднит?!

По сайту ti побродите, оно не совсем сверху. Для 28035 не искал, для 28044 это называется sprc324.zip, "C2804x C/C++ Header Files and Peripheral Examples". Должно быть что-то подобное.

Share this post


Link to post
Share on other sites

Вопрос к SAURIS GmbH все таки остался! Версию сменил, а поддержки 28035 как не было, так и нет!

 

 

з.ы: yvk! Спасибо! Пример нашел и разобрался!

Edited by OlegSP

Share this post


Link to post
Share on other sites

Вы про то, что нету именно названия "TMS320F28035" в списке? Ну мы-то тут не причем. Это вопрос к TI. Пока они не сделали апдейт композера с этим процом, юзайте ближайший похожий, или сами соберите через закладку "advsnced" редактора конфигураций - 28xx все как один представляют собой CPU "C28xx" в JTAG-цепочке.

Share this post


Link to post
Share on other sites

SAURIS GmbH нет, Вы Меня не поняли! "TMS320F28035" в композере ЕСТЬ! Если подключать его через JTAG отладочной платы! Он пропадает только когда подключаем его к вашему SAU510-USB JTAG Emulator IsoPlus.

Edited by OlegSP

Share this post


Link to post
Share on other sites

упс...

 

пофиксили. Заодно добавили Cortex A9, C646x, PRU и пофиксили ETB_CS. Может уже стоит и новый инсталлятор собрать...

 

раскройте архив и перебросьте XML-ки из него в соотв. директорий композера.

xmladd.rar

Share this post


Link to post
Share on other sites

Очередной вопрос к SAURIS GmbH по подключению эмулятора SAU-510USB Iso Plus.

Система Win7 x64, драйвера ставлю из sau510usb_Install-v1.2.0.2.zip с сайта.

 

После установки драйверов система сообщает в окне диспетчера устройств следующее: Запуск этого устройства невозможен. (Код 10).

На эмуляторе горит оранжевый светодиод ACT, светодиод PWR горит зеленым при USB подключении и оранжевым, если подключить к устройству.

Соответственно и CCS v4 сообщает об ошибке при подключении: Error 0x80000240/-141 Fatal Error during: Initialization, OCS,

Пробовал обновить драйвер из директории ..\Sauris\driver\ - естественно неудачно. Несколько раз делал переустановку драйверов с отключенным антивирусом, с перезагрузкой - результат 0.

 

Есть предположение (печальное) - девайс не работает, тем более грустное, что он новый, покупался в конце 2009 года (sn 001198) и с тех пор лежал в столе, а теперь в нем возникла потребность при переходе на Win7.

Share this post


Link to post
Share on other sites

А подробнее - в свойствах этого "устройства, запуск которого невозможен" - есть какая либо информация?

 

А то, может быть, надо всего лишь обновить сертификаты корневые в системе, если проблема в подписывании.

Edited by SAURIS GmbH

Share this post


Link to post
Share on other sites

Отписываюсь о решении проблемы, описаной мною выше, может быть кому-нибудь еще пригодится.

 

Ключ к решению оказался в выборе порта USB. Все это время я пытался подключить эмулятор к разъемам на передней панели компа. Устройство устанавливалось и определялось, однако несмотря на то, что данный эмулятор IsoPlus, системой он определялся просто как SAU510-USB (а я и не знал, что должно быть по-другому).

 

Для проверки функциональности я подключил устройство к другому компу с ХР. Драйвера встали без всяких ошибок, при подключении устройство определилось как SAU510-USB v.2 (Iso). Причем подключал как к передним разъемам, так и к задним.

 

Порадовался, что устройство живое и подключил к задней панели своего компа - все заработало!!

 

Остается философский вопрос - чем вызвано такое поведение устройства? Недостаточно питания? А может быть длинным переходным кабелем от мат. платы к передней панели компа. Куча других устройств USB 2.0 (включая внешние диски и старый эмулятор SAU510-USB) на этих разъемах функционировали абсолютно адекватно.

Share this post


Link to post
Share on other sites

Возможно, USB-кабель эмулятора бракованный, согласование нарушено, и лишние провода дают о себе знать, при тестировании это не обнаруживается. Попробуйте другим кабелем от какого-нить другого устройства подключить. Вообще такое впервые происходит, особенно то, что эмулятор определяется как не тот, кто на самом деле. Это прямо фантастика какая-то, чтобы VID/PID/версия могли измениться от того, в какой порт воткнули.

Edited by SAURIS GmbH

Share this post


Link to post
Share on other sites

Когда ставятся ваши драйвера, можно поставить Flash/EEPROM standalone programming tools. Они работают? И если да, то как?

Share this post


Link to post
Share on other sites
Когда ставятся ваши драйвера, можно поставить Flash/EEPROM standalone programming tools. Они работают? И если да, то как?

 

Да, они работают. Вот как-то так, как в описаниях, которые в этом посте. Они полнохалявноопенсурсные, так что можете под многие платформы и разные виды памятей сами портировать. Если не поддержано семейство само по себе - пишите письма, поддержим (пока только без DAP-ов к сожалению по техническим причинам).

sauflash_ug.pdf

tclxds_rm.pdf

Edited by SAURIS GmbH

Share this post


Link to post
Share on other sites

Да, вдогонку. Просьба, если кто-то что-то дописал во флеш-тулзы (новые CPU, новые виды памяти), и ему это не жалко для всех - присылайте мне на sauris_support*at*scanti.ru - включу в дистрибутив очередных драйверов с указанием авторства.

Edited by SAURIS GmbH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now