Jump to content

    

Проблема с TCD1304DG

Здравствуйте.

Пытаюсь заставить работать линейку TCD1304 с микроконтроллером ATMega328, но она не хочет считываться, и АЦП выдает постоянные значения.

Использовал следующий код по алгоритму, описанному в этой ветке, на Си:

 

PORTB |= (0 << SH) | (1 << FM) | (1 << ICG);

TCCR2B |= (0 << CS22) | (0 << CS21) | (1 << CS20);

PORTB &= ~(1 << ICG);

_delay_us(0.5);

PORTB |= (1 << SH);

_delay_us(1);

PORTB &= ~(1 << SH);

_delay_us(1);

PORTB |= (1 << ICG);

TCCR0B |= (0 << CS02) | (1 << CS01) | (0 << CS00);

while (*point_number_ptr != pix_count - 1)

{

if (adc_buffer)

{

array_data[*point_number_ptr] = adc_buffer;

adc_buffer = 0;

++(*point_number_ptr);

}

}

 

Таймер 2 предварительно настроен на частоту 0.8 МГц в режиме CTC с переключением FM.

Таймер 0 предварительно настроен на запуск АЦП с частотой (0.8 / 4 / 6) МГц, поскольку хочу запускать АЦП на измерение каждого 6 пиксела.

 

Может, кто сталкивался с подобной проблемой? Уже кучу времени потратил и не могу все никак решить вопрос...

Edited by Zhekas

Share this post


Link to post
Share on other sites

Держите в тайне на что "потратил кучу времени".

Тактирование на пин матрицы поступает ? Частота в диапазоне [мин-макс] ?

Диаграмма в соответствии с даташитом соблюдается ?

(это все надо проверить аппаратно).

Если постоянное значение на выходе, оно зависит от засветки (пискселя или всей линейки) ?

 

 

 

Share this post


Link to post
Share on other sites
Тактирование на пин матрицы поступает ? Частота в диапазоне [мин-макс] ?

Попробую в понедельник глянуть на двухканальном осциллографе и доложу результаты.

Если постоянное значение на выходе, оно зависит от засветки (пискселя или всей линейки) ?

Матрица вообще не реагировала на освещение.

Если честно, почитав кучу информации по матрицам, я так и не совсем понял полностью алгоритм, который нужно применить для интегрирования и считывания, и поэтому у меня есть вопросы:

1)Какую диаграмму нужно использовать: на странице 6 или на странице 8? Или на странице 6 приведен больше, чем 1 период сигналов для матрицы?

2)На диаграммах даны исходные сигналы или инверсные, для даташитовской схемы управления? В моем случае контроллер подключен непосредственно к матрице без инвертора.

3)До этого мне удавалось заставить матрицу работать, но сигнал я генерировал постоянно в бесконечном цикле, а к выходу матрицы подключал осциллограф. Не получается именно задать управляющие сигналы и считать результат АЦП. Такое впечатление, что постоянно упускаю какую-то мелочь...

Toshiba_TCD1304AP_CCD_array.pdf

Edited by Zhekas

Share this post


Link to post
Share on other sites

Грубо говоря, по ICG=0 объёктив закрывается виртуальной крышкой, спустя 500 нс по SH=1 накопленный в ячейках кадр начинает переноситься из них в аналоговый сдвиговый регистр и заканчивает это делать спустя 1 мкс по SH=0, далее задержка 5 мкс и ICG=1, по каковому событию крышка с матрицы снимается, её начинает засвечивать следующий кадр, а из сдвигового регистра начинает выдвигаться текущий, по 4 такта на точку, из расчёта, что АЦП должен фиксировать данные в УВХ в конце 4-го такта.

Share this post


Link to post
Share on other sites

Провел ряд экспериментов. При этом, если гонять программу в бесконечном цикле, а результат ловить осциллографом, то вроде все работает, матрица на свет реагирует. Еще заметил, что выходной сигнал, хоть и меняется, имеет весьма малую амплитуду в несколько сотых милливольт. Также определил, что в даташите приведены сигналы в соответствии с описанной там схемой, т.е. инвертированные. Без инвертора сигналы должны быть перевернутые, иначе матрица на свет не реагирует.

При попытке однократного запуска интегрирования и измерения выходного сигнала АЦП, то его значения постоянны и не зависят от засветки матрицы. В этом же режиме все сигналы исправно поступают на входы матрицы.

Может быть дело в малой величине выходного сигнала, поскольку я подаю сигнал на АЦП прямо с матрицы? Хотя 0.3-0.5 В должно без проблем детектироваться АЦП с ИОН на 5,046 В на разрядностью 10 бит.

P.S. верхняя линия - ICG, нижняя - SH.

post-107032-1535456313_thumb.jpg

Edited by Zhekas

Share this post


Link to post
Share on other sites
приведены сигналы в соответствии с описанной там схемой, т.е. инвертированные

Рис.7:

 

https://www.cezarchirila.com/documents/SSET...zar_Chirila.pdf

 

Ну и, заодно там же полезно почитать, как люди выполняют требования производителя к диаграмме сигналов, а конкретнее, никакими не "delay_us".

Share this post


Link to post
Share on other sites
. . . Может быть дело в малой величине выходного сигнала, поскольку я подаю сигнал на АЦП прямо с матрицы? . . .

Кроме амплитуды надо учитывать работу входных цепей АЦП, а именно УВХ (если оно реализовано) или входную емкость АЦП.

Если сигнал с матрицы маломощный, то при высокой частоте выборок матрица может не успевать "накачивать" УВХ или емкость по входу.

Посмотрите настройки АЦП Вашего контроллера, есть ли там УВХ. Если есть - должна быть настройка "времени захвата". Можно попробовать

проверить работу на мин и макс. значениях (хотя это может и не помочь). Более реально - буферизировать выход матрицы

(если в этом проблема).

--

У меня практ. опыта по этому девайсу нет. Лежит извлеченная из старого сканера матрица, ждет своей "реинкарнации" :)

 

ps

. . .

PORTB |= (0 << SH) | (1 << FM) | (1 << ICG);

. . .

Судя по оператору, бит разряда с номером SH должен быть сбошен в 0. В правой части так и будет.

но если он (SH) до этого был в 1, то после |= так ней и останется.

---

далее я код не проверял, проанализируйте сами.

 

 

Share this post


Link to post
Share on other sites
ps

Судя по оператору, бит разряда с номером SH должен быть сбошен в 0. В правой части так и будет.

но если он (SH) до этого был в 1, то после |= так ней и останется.

---

далее я код не проверял, проанализируйте сами.

Этот код для однократного интегрирования. А до этого были все биты выставлены в нуль (эта часть кода не приведена).

А по поводу АЦП спасибо, буду пробовать разбираться.

Как я писал выше, дело именно в фиксации данных с помощью АЦП. А delay сделал для теста. Для точной генерации FM я использую таймер 2 в режиме сброса при совпадении и инвертирования состояния пина FM, а для времени интегрирования-таймер 1А в режиме прерывания и сброса при совпадении.

 

Рис.7:

 

https://www.cezarchirila.com/documents/SSET...zar_Chirila.pdf

 

Ну и, заодно там же полезно почитать, как люди выполняют требования производителя к диаграмме сигналов, а конкретнее, никакими не "delay_us".

Спасибо, почитаю.

Share this post


Link to post
Share on other sites

Прочитал статью. Там автор использует для генерации сигналов PWM на ICG и SH, используя для этого отдельные таймеры. Я изначально тоже так хотел сделать, однако в моем контроллере один 16 битный таймер, состоящий из 2 частей с общим количеством тактов. По этой причине тяжело настроить их запуск независимо друг от друга, чтобы сделать задержку между ICG и SH, да и время интегрирования будет меняться дискретно с изменением предделителя частоты счетчика (по переполнению).

Поэтому на данный момент я остановился на генерации импульса с помощью delay, а импульсы повторяются по совпадению значения счетчика с последующим его сбросом. Хотя я полностью признаю, что генерация сигнала с помощью delay - плохой метод.

По поводу АЦП есть идея. Возможно моя проблема связана с периодом повторения сигнала ICG - 1 мс. При этом предыдущий кадр не успевает полностью выйти из матрицы, как начинается следующий. В результате они накладываются друг на друга, и матрица оказывается все время в насыщении, а АЦП меряет не то что нужно. Попробую выставить данный интервал на 20 мс.

Edited by Zhekas

Share this post


Link to post
Share on other sites

Провел еще ряд экспериментов: увеличил время интегрирования до 20 мс, присваивал значения регистров таймеров через переменную, подключал эмиттерный повторитель к матрице и делал принудительный запуск АЦП для его первоначальной инициализации. В результате нуль - матрица как не считывалась, так и не считывается АЦП при однократном измерении. При этом в бесконечном цикле генерирования тактов осциллограф регистрирует изменяющейся выходной сигнал. АЦП тоже нормально работает (меряет напряжение на батарейке верно), и контроллер пересылает верные значения на ПК.

Даже уже и не знаю что делать, все идеи закончились...

Единственное, что я программировал таймер, отвечающий за тактирование, на 800 кГц, но ведь реальная частота должна быть 400 кГц, если брать период. В тоже время, запуск считывания я программировал на 200 кГц. Может быть, нужно выставить последнее значение на 100 кГц?

Edited by Zhekas

Share this post


Link to post
Share on other sites

Сделайте полный "ресет" работ. И начните его с проверки "распиновки" матрицы в соотв-ии с даташитом :)

(уж очень много там пинов NC)

и правильности подключения. Затем осцилографом - выполнение диаграммы сигналов по даташиту.

(частота тактирования должна быть в диапазоне мин-макс).

 

Share this post


Link to post
Share on other sites
Сделайте полный "ресет" работ. И начните его с проверки "распиновки" матрицы в соотв-ии с даташитом :)

(уж очень много там пинов NC)

и правильности подключения. Затем осцилографом - выполнение диаграммы сигналов по даташиту.

(частота тактирования должна быть в диапазоне мин-макс).

Там я проверял, все должно быть нормально. Такое впечатление, что просто АЦП не попадает в момент выхода сигнала пиксела из матрицы, посколько они появляются в виде узких линий (по осциллографу). Поэтому я и спрашиваю: частота - это время срабатывания таймера по совпадению или период, т.е. удвоенное время таймера? Просто в первом случае соотношение времен таймеров FM/ADC будет 1 к 4, а в другом 1 к 8. У меня сейчас 1 к 4.

Share this post


Link to post
Share on other sites

Нашел одну ошибку: соотношение времен таймеров должно быть 1 к 8, поскольку таймер изменяет состояние порта, а период - это когда сигнал меняется дважды. Теперь матрица иногда выдает какие-то значения, но каждый раз они меняются, иногда даже для пикселей в середине матрицы. На свет детектор по-прежнему не реагирует.

Share this post


Link to post
Share on other sites

Сегодня помучал еще прибор, и есть прогресс! Оказалось, что операции написанные на Cи достаточно медленные. Я засек время выполнения операции выключения порта на 20 МГц и оно оказалось 560 нс! Соответственно, до этого у меня были неверно выставлены тайминги. Я это поправил.

Теперь матрица реагирует на свет, и даже иногда нужно несколько циклов вычитывания, чтобы на выходе у нее были темновые значения. Но она все равно выдает постоянное значения вне зависимости от локального освещения. Если освещать только часть матрицы, то на выходе напряжение будет одинаковое. Еще имеется один вопрос по поводу начальных логических состояний пинов ICG, SH и FM (до процесса измерения в режиме ожидания). Просто если их выставить в соответствии с даташитом, то ведь матрица будет постоянно интегрировать падающий световой поток...

Edited by Zhekas

Share this post


Link to post
Share on other sites
Сегодня помучал еще прибор, и есть прогресс! Оказалось, что операции написанные на Cи достаточно медленные. . . . .

Если Вам приходится высчитывать наносекунды (пусть даже и сотни), то вывод - одно из двух: или надо брать более мощный процессор, или - выносить из софта критичные по времени операции во внешние (аппаратные) схемы. Есть еще вариант - изменить алгоритм, как "в консерватории подправить" :)

ps - респект за настойчивость.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this