Jump to content

    

Повороты компонентов на боттоме

Всем привет!

Я чуть капитально не встрял в производстве.

Альтиум неверно указывает углы поворота компонентов, расположенных на боттоме!

 

Вот нижняя сторона платы в режиме flip board:

7b6e0dc0dd80.gif

В библиотеке компонент нарисован первым выводом сверху слева

Все микросхемы так нарисованы

 

че за???....

 

Ладно бы он все вращал, так половину то он верно указывает!

b8b4cb0d7cdc.gif

 

Ощущение, что неправильно показывает компоненты, повернутые на 0 и 180...

Или я где то галочку не поставил?

Share this post


Link to post
Share on other sites

чото непонятно, в чём проблема. Поподробнее пожалуйста.

Share this post


Link to post
Share on other sites

На первой картинке угол должен быть 0, а там 180. В этом и проблема

Share this post


Link to post
Share on other sites
На первой картинке угол должен быть 0, а там 180. В этом и проблема

 

Похоже, что не настроена парность слоев для графики.

Share this post


Link to post
Share on other sites
Похоже, что не настроена парность слоев для графики.

 

Какая парность?

это не механикал графикс, это компонент.

и что, парность для каждого компонента настраивается?

Share this post


Link to post
Share on other sites
На первой картинке угол должен быть 0, а там 180. В этом и проблема

На чем строится эта гипотеза?

Share this post


Link to post
Share on other sites

У нас есть плата, давно спроектированная в ПИКАДе и проблем с автоматической установкой компонентов на станке нет, значит угол поворота в файле правильный, например у компонента U59 на Bottom 0.0deg - рис.1. При трансляции файла этой же платы в АД он указывает угол поворота этого же компонента U59 180 - рис.2.

Получается, что такой глюк не только у peshkoff, а у всех?!! :07: Вот это да...

post-58141-1288343776_thumb.jpg

post-58141-1288343782_thumb.jpg

Edited by Rodavion

Share this post


Link to post
Share on other sites

я так думаю, неважно при производстве, какой угол поворота указан для компонента. Это всего лишь выбор точки отсчёта. Т.е. начальной фазы. Главное чтобы такая же начальная фаза учитывалась при расчёте угла поворота всех компонентов. А само значение начальной фазы при автомонтаже настраивается технологом (для всех компонентов сразу).

Share this post


Link to post
Share on other sites
я так думаю, неважно при производстве, какой угол поворота указан для компонента. Это всего лишь выбор точки отсчёта. Т.е. начальной фазы. Главное чтобы такая же начальная фаза учитывалась при расчёте угла поворота всех компонентов. А само значение начальной фазы при автомонтаже настраивается технологом (для всех компонентов сразу).

Оказывается, этот глюк давно известен, наша контора с ним сталкиваласть при работе с платами, разведенными в Аллегро, устраняется технологом при подготовке файла для станка-установщика. Но это ошибка работы АД, он должен был перевернуть плату при определении угла поворота компонента, как это делает ПИКАД, а не "смотреть" на нее сверху. Если эту ошибку не знать и не устранить вовремя - плату в мусорную корзину, а это большие убытки со всеми вытекающими... :twak:

Разработчики АД! Помните ПИКАД и не делайте таких глупостей !!! :1111493779:

Edited by Rodavion

Share this post


Link to post
Share on other sites

скопировал компонент 8 раз с углом поворота на 90 град на каждом слое

Угол нормально увеличивается на каждые 90 град при следующем повороте

 

Share this post


Link to post
Share on other sites

Замечал такую особенность: при вставке с нетлиста компоненты имеют угол ориентации 0.

Стоит его хоть раз крутануть и ноля уже не бывает(хотя можно руками вбить) 180 и 360.

Может это фича такая? А может это только у меня.

Share this post


Link to post
Share on other sites
скопировал компонент 8 раз с углом поворота на 90 град на каждом слое

Угол нормально увеличивается на каждые 90 град при следующем повороте

Похоже проблема имеет место быть. При переносе компонента на нижний слой, угол поворота сразу меняется с 0 на 180, это не есть хорошо.

Share this post


Link to post
Share on other sites
Похоже проблема имеет место быть. При переносе компонента на нижний слой, угол поворота сразу меняется с 0 на 180, это не есть хорошо.

Из-за таких глупых ошибок можно терять потенциальных клиентов. Народ не понимает, как в таком серьезном, навороченном пакете могут быть такие подставы. У меня начальство сказало: "нуууу, а ты ее пропагандируешь!!! :cranky:

Кстати, и ПАДы сложной формы, полигонами, как в ПИКАДе надо сделать!!! :beer:

Из - за их отсутствия неправильно транслируются РСВ файлы из ПИКАДа в АД, теряется связь между SCH и РСВ в этих компонентах, короче, возникает куча проблем!!! :wacko:

Edited by Rodavion

Share this post


Link to post
Share on other sites

Чтото вы наговариваете на Altium!

Кучу плат уже собрали на машине - проблем с углами никогда небыло!!!

Похоже проблема имеет место быть. При переносе компонента на нижний слой, угол поворота сразу меняется с 0 на 180, это не есть хорошо.

Какраз проблемы то и нет - так и должно быть!!! Ведь чтоб "физически" установить элемент на BOT его необходимо перевернуть...

Edited by filmi

Share this post


Link to post
Share on other sites
Чтото вы наговариваете на Altium!

Кучу плат уже собрали на машине - проблем с углами никогда небыло!!!

А Сабунин проблему признает...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this