Jump to content

    

AvrUsb500 by Petka. продолжение

Petka

Добрый день. собираю ваш программатор.

Какие дросселя можно поставить? я уже читал что не мение 0.5А.

1uH 2.5А можно? или лучше 330uH?

Edited by Steel_Eloy

Share this post


Link to post
Share on other sites
...

Какие дросселя можно поставить? я уже читал что не мение 0.5А.

Да, желательно не менее 0,5 А.

1uH 2.5А можно? или лучше 330uH?

Можно.

 

Share this post


Link to post
Share on other sites

Вроде все нормально припаял, но подключаю до компа, то все юсб устройства перестают работать. (зависают)

Share this post


Link to post
Share on other sites
Определился программатор, вот PonyProg выбевает ошибку x86 на win7 64(((

что же делать?

 

 

v2.06f BETA стала на win7 64 без проблем

 

Дальше запустил пони, выставил invent sckl, invent d-in, invent d-out и ком порт 4.

выбрал avr micro - atmega8

проделал калибровку

потом:

06.gif

Нажимаю write жду и выбевает ошибку 24

Share this post


Link to post
Share on other sites

Все ошибки исправил. Но есть 1 вопрос почему при прошивке программатора в конце на 100% выбивает ошибку failed

Share this post


Link to post
Share on other sites
Все ошибки исправил. Но есть 1 вопрос почему при прошивке программатора в конце на 100% выбивает ошибку failed

Ошибки ponyprog надо адресовать разработчикам ponyprog так как никто кроме них не сможет диагностировать ошибку.

Для первоначальной прошивки рекомендую использовать avrdude. Т.к. avrdude имеет расширенную диагностическую информацию и открытые исходники, то можно будет установить причины ошибок.

Share this post


Link to post
Share on other sites
Ошибки ponyprog надо адресовать разработчикам ponyprog так как никто кроме них не сможет диагностировать ошибку.

Для первоначальной прошивки рекомендую использовать avrdude. Т.к. avrdude имеет расширенную диагностическую информацию и открытые исходники, то можно будет установить причины ошибок.

Я потом скачал ponyprog 2.05, попробывал через него прошить и таки прошился без проблем.

В avr studio определяется как STK500

 

Share this post


Link to post
Share on other sites

добрый, собрал по схеме v2, прошивка v8.

atmega8, 18,432МГц. overclock

фьюзы, программа прошились нормально.

при включении 6 вспышек, светодиод после не тухнет, горит.

на выводе aref 0, вставая тестеров на miso ловит помехи и мигает светодиодом... ляпов и кз не обнаружил под лупой.

не знаю что и думать...

Share this post


Link to post
Share on other sites
...

светодиод после не тухнет, горит.

на выводе aref 0,

...

Разберитесь сначала с выводом aref. прозвоните сопротивление на землю.

Share this post


Link to post
Share on other sites

aref на землю не звонится, при включении на нем 0.00V.

R8/R9 без подключения 0V, с подопытным 0.63V

 

плата промыта, просушена. atmega раньше на таком же программаторе использовалась и работала.

Share this post


Link to post
Share on other sites
....

R8/R9 без подключения 0V, с подопытным 0.63V

....

Что это значит?

Share this post


Link to post
Share on other sites
Что это значит?

да уже ничего..)

заменил на новую atmega8,

пересобрал прошивку, прошил. avrstudio-6 больше не ругается.

спасибо за устройство, сорри за тупые вопросы)

Edited by palko

Share this post


Link to post
Share on other sites

Здравствуйте. Скажите можалуйста можно ли сигналы "TG_SCK", "TG_MISO", "TG_RESET" и "TG_MOSI" перенести на PD5, PD6, PD7 и PB0? Или их можно переносить только в предалах порта C?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this