Jump to content

    

AvrUsb500 by Petka. продолжение

к сожалению не помогло

при соединении AREF с землей через конденсатор светодиод гаснет совсем

....

Он и должен гаснуть. Зажигается только при подключении программируемого контроллера.

Share this post


Link to post
Share on other sites
Он и должен гаснуть. Зажигается только при подключении программируемого контроллера.

 

видимо, невнимательно читал, думал должен моргнуть 6 раз и продолжать гореть, независимо от того подключен программируемый контроллер или нет

в таком случае проблема решена

спасибо большое

Share this post


Link to post
Share on other sites
прошил фьюзы, все ок, программатор видится в терминальном режиме

но при подключении программатора к USB светодиод, моргнув 6 раз, продолжает моргать, но уже с большей частотой

 

Столкнулся с такой же проблемой. Спасибо за подсказку с кондером, помогло. шью заново 8 версию щас, а то думал что проблема в 8 и залил с перепугу 6, а там тоже самое...

 

Насчет терминала - как определить видется или нет? У меня Win7x64, гипертерминал скопировал из винды XP, запускаю, выбираю порт... и тишина... Не подскажите ли по шагам что нужно ему делать и что должно при этих дейтсвиях отображаться?

 

 

Кстати насчет прошивки програматора - так как у меня винда 7 х64, то сетап понипрога наотрез отказывался устанавливать что либо. было решено делать через виртуальную машину. взялся VMWarePlayer, поставилась ХР, дейвай был подключен и присоединен к виртальной машине (ВМ) как любое юсб устройство. на ХР поставлены дрова (FTDI), всё с виду заработало, но случались рандомно в пони всякие ошибки, то при чтении фьюз через раз получается всякая лабудень, то поня внезапно девайса не видит... про прошивку вообще молчу - долго и всегда неверна получается.

Выходом из такой ситуации был перенос установленной пони собсна на Win7x64 путом тупого копирования папки с установленной поней. Все недостающие библиотеки, а это DLPORTIO.DLL, был взят из system32 ХР и положен в папке с выдраной пони. В результате - понька шьет всё прям из Win7x64, ни на что не ругаясь и 100% безошибочно.

 

Может быть инфа будет полезна в нынешние времена, и в каком то виде ее добавить в фак ?

Share this post


Link to post
Share on other sites

Кто-нибудь в курсе, работает ли этот программатор с "новыми" АВРами, которые с буквой A - Mega8A/16A/32A/128A?

Спасибо.

Share this post


Link to post
Share on other sites
Кто-нибудь в курсе, работает ли этот программатор с "новыми" АВРами, которые с буквой A - Mega8A/16A/32A/128A?

Спасибо.

 

По моему нет причин не работать. Программатор эмулирует работу STK500 в режиме ISP программирования. Привязки к конкретным каким то контроллерам нет.

 

Насчет гипертерминала - вопрос отпал, всё заработало, ура!! :)

Share this post


Link to post
Share on other sites

Петька собрал давно Ваш программатор с Вашей помощью, прошивал во сонвном Amega 8 TQFP без проблем, а Atmega 8 PDIP прошить вашим программатором не получается. В чем проблема объясните?

Share this post


Link to post
Share on other sites
Петька собрал давно Ваш программатор с Вашей помощью, прошивал во сонвном Amega 8 TQFP без проблем, а Atmega 8 PDIP прошить вашим программатором не получается. В чем проблема объясните?

Для программатора эти чипы ничем не отличаются. Посмотрите на различия в подключении выводов программирования. Нет ли других внешних устройств на линиях программирования? Есть ли возможность проверить на другой меге в DIP корпусе?

Share this post


Link to post
Share on other sites

Все разобрался, на кварце убрал емкости и все заработало

Share this post


Link to post
Share on other sites

Спалил программатор, заменил контроллер на обновленную версию atmega8A. Шьется без проблем, но вот почему-то схема не программируется. ДРугой схемы или другого программатора для проверки нет.

ПОдходит ли прошивка для mega8 для контроллера Mega8a ?

Share this post


Link to post
Share on other sites

Подходит. Я собрал себе на TQFP ATMega8A, залил прошивку Mega8, прекрасно работает.

Share this post


Link to post
Share on other sites

Залил 8 прошивку на ATMega88, теперь светодиод после морганий непрерывно светится, - раньше такого небыло. нормально ли это с данной микросхемой? Студией определяется без проблем....

Share this post


Link to post
Share on other sites
Залил 8 прошивку на ATMega88, теперь светодиод после морганий непрерывно светится, - раньше такого небыло. нормально ли это с данной микросхемой? Студией определяется без проблем....

При подключенном контроллере - да, нормально. должен гореть. При отключенном не должен. Вероятно ты имел ввиду при отлюченном горит. Ну тогда скорее не горит а моргает изза шума. Если так то нужно поставить конденсатор (например 0,1мкф) между AREF и GND (это 20 и 21 ногами у ATMega8A в TQFP корпусе)

Share this post


Link to post
Share on other sites
Ну тогда скорее не горит а моргает изза шума. Если так то нужно поставить конденсатор (например 0,1мкф) между AREF и GND (это 20 и 21 ногами у ATMega8A в TQFP корпусе)

Светодиод именно постоянно светится, а не моргает без подключенного таргета. Конденсатор стоит.

 

Share this post


Link to post
Share on other sites

Может где то под соседними ножками капля олова сныкалась? или по разводке где то... То что светится означает что контроллер по выводу Reset на разъеме определил что другой контроллер подключен. Если прошивка залилась и проверилась и без ошибок то дело только в схематике. Проверь точно ли те что нужно сопротивления поставил в цепи выхода Reset на разъем? там делители напряжения и значения сопротивлений должны быть точно подобраны!

post-73462-1353000393_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this