Jump to content

    

AvrUsb500 by Petka. продолжение

у меня в авр студии программатор не нахоится((

 

Выкладываю свою печатку, надеюсь Вам пригодится. Подписал номиналы всех элементов. По крайней мере можете взять верхнюю часть с обвязом для PL-ки. А можете просто собрать, только прошивать придется другим шнурком, там для подпайки проводов пятачки на плате предусмотрены.

Timm_STK500v2_PL2303_Mega8_withoutSelfProg.zip

Share this post


Link to post
Share on other sites

в терминале можно с программатором пообщаться...сменить версию...но программа-программатор не находит его((

Edited by DEm__2006

Share this post


Link to post
Share on other sites
в терминале можно с программатором пообщаться...сменить версию...но программа-программатор не находит его((

что за "программа программатор"?

если в терминалке программатор откликается, значит программатор прошит, связь есть.

добейтесь зажигания светодиода при подключении к программируемому устройству программатора. проверьте номиналы резисторов!

Share this post


Link to post
Share on other sites

"программа программатор" это CVAVR и AVRStudio еще есть Зина, но я не понял, что там нужно выбирать...

 

резисторы все правильно...косяков не нашел...ппц какой-то

по какому принципу этот светодиод вообще загорается при подключении контроллера?

Edited by DEm__2006

Share this post


Link to post
Share on other sites
"программа программатор" это CVAVR и AVRStudio еще есть Зина, но я не понял, что там нужно выбирать...

 

резисторы все правильно...косяков не нашел...ппц какой-то

по какому принципу этот светодиод вообще загорается при подключении контроллера?

читайте FAQ на первой странице. Вы питание на программируюмую микросхему подавали?

Share this post


Link to post
Share on other sites

светик загорелся....

 

AVRStudio определил и чего-то просит или скачать или обновить...хз... и еще в терминале "Reset target at connector polarity test" что означает?

 

питание везде есть

 

 

соде вижн пишет "AVRISP error entering programm mode" AVRStudio -

Setting mode and device parameters.. OK!

Entering programming mode.. FAILED!

Leaving programming mode.. FAILED!

Share this post


Link to post
Share on other sites
светик загорелся....

 

AVRStudio определил и чего-то просит или скачать или обновить...хз... и еще в терминале "Reset target at connector polarity test" что означает?

 

питание везде есть

и на этот вопрос есть ответ в FAQ

Share this post


Link to post
Share on other sites

а что на счет ...

"соде вижн пишет "AVRISP error entering programm mode" AVRStudio -

Setting mode and device parameters.. OK!

Entering programming mode.. FAILED!

Leaving programming mode.. FAILED!"

?

 

Reset target at connector polarity test

если ставлю "1" - авр студия не определяет программатор, если 0- определяет...

я так понимаю это "определение наличия контроллера по уровню "ресет"" если да - то как оно влияет на авр студию в поиске программатора??

 

подскажите, в чем проблема....

Share this post


Link to post
Share on other sites
подскажите, в чем проблема....

Вы со светодиодом разобрались?

"Reset target at connector polarity test" выставите в 1.

И добейтесь, что бы при подключении программируемого контроллера светодиод зажигался.

Для этого проверьте мультиметром какое напряжение на выводе "reset" программируемого контроллера. (и вообще, подтянут ли ресет к питанию?)

Share this post


Link to post
Share on other sites

на ресете 3.19В

 

получилось прошить и прочитать контроллер замклув 25 и 26 выводы... замкнул пинцетом, отпустил и теперь прошивает норм...щас его еще потестю...

 

Мегу8 прошивает просто отлично, огромное спасибо Вам, Petka!

Edited by zltigo

Share this post


Link to post
Share on other sites

Надо фузы для mega 8 пересмотреть. Как и писал в предыдущей ветке один человечек, слетает EEPROM.

В один прекрасный момент перестал работать мой программатор. :crying:

Благо есть второй, запасной. Посмотрел в терминале один, посмотрел второй.

Версия у неисправного обнулилась. Поставил 2 и все опять заработало.

Фузы выставлял как в описании.

Edited by ds1307

Share this post


Link to post
Share on other sites
Надо фузы для mega 8 пересмотреть. Как и писал в предыдущей ветке один человечек, слетает EEPROM.

На днях будет новая версия, заодно и фузы поправим =)

Share this post


Link to post
Share on other sites
На днях будет новая версия, заодно и фузы поправим =)

Ждем с нетерпением :laughing:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this