Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

Добрался до осциллогорафа. В режиме генерации "1 МГц" выдает на 23-й ноге меандр частотой 145 КГц.

отлично

Т.е. я так понимаю проц прошился нормально, тактирование работает нормально. Где же тогда копать?

Я так понимаю хаотичного моргания светодиода не должно быть?

Не должно. Хотя может быть какие-то проблемы с цепочкой R8, R9 (сверьте номиналы)

С avrdude никогда не работал, сейчас буду разбираться и проверять. Petka, Вы имели в виду проверить работу программатора с avrdude с уже прошитой прошивкой?

Да

 

Share this post


Link to post
Share on other sites
Не должно. Хотя может быть какие-то проблемы с цепочкой R8, R9 (сверьте номиналы)

 

Номиналы проверил, установлено как по схеме R8=220k, R9=100k. При отключенном таргете напряжение RST_ADS = 0 В, при подключенном таргете 1,5 В.

Кстати, на всякий случай, фьзы у меня прошиты так: lfuse=FF, hfuse=C9.

 

Чуть позже еще с avrdude поиграюсь, хотя интересует работа программатора именно в AVRStudio.

Edited by james77

Share this post


Link to post
Share on other sites

Попробовал avrdude, а вернее avrdude вместе с "AVR8 Burn-O-Mat avrdude GUI". Читает и пишет без проблем. С AVRStudio по-прежнему не работает. Похоже AVRStudio программатор просто не видит.

Грешил на проблемы с кварцем (а вернее на конденсаторы на кварце), но раз с avrdude работает, значит все номально. Petka, может глянете на всякий случай на печатку (она у меня от Вашей немного отличается), у меня небольшие сомнения в правильности расположения кварца и "кварцевых" конденсаторов.

Ну и по-прежнему хаотично моргает светодиод...

 

У меня уже закончились идеи, даже не представляю в какую сторону копать, чтобы заставить программатор и AVRStudio увидеть друг друга.

PCB1.pdf

SCH1.pdf

Share this post


Link to post
Share on other sites

Я конечно не уверен, но кажется я понял в чем проблема при стыковке программатора с AVRStudio. При попытке подключиться к программатору в логе AVRStudio вылазит следующее:

 

16:10:45.031: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.281: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.953: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.953: [ERROR] Unable to connect to tool context: 'Atmel.VsIde.AvrStudio.Services.TargetService.TCF.Internal.Services.Remote.To
olProxy+ToolContext'.

 

Я так понимаю AVRStudio просто не признает этот программатор, так что-ли?

Share this post


Link to post
Share on other sites
Я конечно не уверен, но кажется я понял в чем проблема при стыковке программатора с AVRStudio. При попытке подключиться к программатору в логе AVRStudio вылазит следующее:

 

16:10:45.031: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.281: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.953: [ERROR] TCF command: Tool:connect failed:  Code:1 ,Service: ,Message from peer:The signature of the attached tool is AVRISP_2, which is unexpected.
16:10:45.953: [ERROR] Unable to connect to tool context: 'Atmel.VsIde.AvrStudio.Services.TargetService.TCF.Internal.Services.Remote.To
olProxy+ToolContext'.

 

Я так понимаю AVRStudio просто не признает этот программатор, так что-ли?

А Вы какой программатор выбирали? Какие варианты он ещё предлагает?

Share this post


Link to post
Share on other sites
А Вы какой программатор выбирали? Какие варианты он ещё предлагает?

 

Выбирал STK500 и указывал COM порт.post-70052-1329836308_thumb.jpg

А вот возможные варианты для конкретного контроллераpost-70052-1329836661_thumb.jpg

 

 

P.S.

Обновил студию. В последнем релизе в логе при попытке подключения программатора пишет почти тоже свмое:

# Communication server listening on port 1087.
17:47:25: [ERROR] The signature of the attached tool is AVRISP_2, which is unexpected., ModuleName: TCF (TCF command: Tool:connect failed.)
17:47:25: [ERROR] Unable to connect to tool context: 'Atmel.VsIde.AvrStudio.Services.TargetService.TCF.Internal.Services.Remote.To
olProxy+ToolContext'.

 

Попробовал еще раз в AVRStudio 4 и... о, чудо!!! Заработало. Пишет и читает. Вот только при попытке прочитать напряжение питания пишет:

post-70052-1329840562_thumb.jpg

 

 

С AVRStudio 5 по-прежнему не работает.

И что-же все-таки означает хаотичное помаргивание светодиода?

 

Edited by james77

Share this post


Link to post
Share on other sites
...

И что-же все-таки означает хаотичное помаргивание светодиода?

Пока обьяснение только одно. Непропаи/закоротки. При первоначальном программировании программатора верификация прошла успешно? Сколько людей не собирало программатор - ни разу такого спецэффекта не было.

Share this post


Link to post
Share on other sites
Пока обьяснение только одно. Непропаи/закоротки. При первоначальном программировании программатора верификация прошла успешно? Сколько людей не собирало программатор - ни разу такого спецэффекта не было.

 

Сегодня третий раз проверил на непропаи/закоротки, ничего не нашел. В программатор уже два раза заливал прошивку, оба раза верификация прошла успешно. После второй прошивки ведет себя также, как после первой. Затем перешил фьюзы lfuse=1F, hfuse=C9 (включил и задал уровень BOD). Поведение светодиода и программатора в целом идентично первоначальному.

Share this post


Link to post
Share on other sites
Сегодня третий раз проверил на непропаи/закоротки, ничего не нашел. В программатор уже два раза заливал прошивку, оба раза верификация прошла успешно. После второй прошивки ведет себя также, как после первой. Затем перешил фьюзы lfuse=1F, hfuse=C9 (включил и задал уровень BOD). Поведение светодиода и программатора в целом идентично первоначальному.

Есть возможность поменять мегу в программаторе?

Share this post


Link to post
Share on other sites
Есть возможность поменять мегу в программаторе?

 

В принципе возможность есть. Но перед этим хотелось бы подитожить. Имеем следующее поведение программатора:

1. Железо: ATmega8A-AU, FT232RL, кварц 14,7456 МГц. Вся рассыпуха SMD, все новое, ни откуда не выпаивалось.

2. Хаотичное моргание светодиода при отключенном таргете, постоянное свечение при подключенном.

3. При первоначальной прошивке в PonyProg верификацию проходит.

4. В терминале отзывается, настройки запоминает.

5. Работа с avrdude, CodeVision - пишет, читает, ошибок не выдает.

6. Работа с AVRStudio 4 - пишет, читает, ошибка при обработке команды Get VTARGET

7. С AVRStudio 5 не хочет работать (в логе выдает "[ERROR] The signature of the attached tool is AVRISP_2, which is unexpected.")

 

А теперь собственно вопросы:

1. Хаотичное моргание светодиода при отключенном таргете нормально или нет?

2. Должен ли видеться программатор при отключенном таргете?

3. На какое напряжение настраивать BOD 2,7 или 4 В? (хотя мне кажется это вообще не критично, но на всякий случай)

2. Поддерживает ли Ваш программатор обработку команды Get VTARGET? (судя по исходникам должен, но у меня выдает ошибку. Хоть момент и не критичный, но может это симптом)

3. Работает ли Ваш программатор с AVRStudio 5?

Share this post


Link to post
Share on other sites
...

А теперь собственно вопросы:

1. Хаотичное моргание светодиода при отключенном таргете нормально или нет?

Так не должно быть.

2. Должен ли видеться программатор при отключенном таргете?

В зависимости от найстройки в терминальном режиме. По умолчанию не видится без таргета.

3. На какое напряжение настраивать BOD 2,7 или 4 В? (хотя мне кажется это вообще не критично, но на всякий случай)

4В.

4. Поддерживает ли Ваш программатор обработку команды Get VTARGET? (судя по исходникам должен, но у меня выдает ошибку. Хоть момент и не критичный, но может это симптом)

Не отлаживал. может и не работать.

5. Работает ли Ваш программатор с AVRStudio 5?

Не проверял. Где-то на форуме проскакивала информация, что можно поменять сигнатуру в прошивке и будет работать в новой студии.

Share this post


Link to post
Share on other sites
1. Хаотичное моргание светодиода при отключенном таргете нормально или нет?

Так не должно быть.

Какие могут быть причины кроме непропая/КЗ/соплей (их я практически исключаю, потому что во-первых уже несколько раз проверял монтаж, а во-вторых при самопрограммировании хаотичного моргания нет)

 

2. Должен ли видеться программатор при отключенном таргете?

В зависимости от найстройки в терминальном режиме. По умолчанию не видится без таргета.

А что нужно настроить в терминальном режиме? (там ведь только версия, 1МГц/fast и проверка подтяжки на ресете таргета)

 

4. Поддерживает ли Ваш программатор обработку команды Get VTARGET?

Не отлаживал. может и не работать.

 

5. Работает ли Ваш программатор с AVRStudio 5?

Не проверял. Где-то на форуме проскакивала информация, что можно поменять сигнатуру в прошивке и будет работать в новой студии.

 

Могли бы Вы проветить это на досуге?

Share this post


Link to post
Share on other sites

Проблему с хаотичным морганием светодиода решил. Долго копаясь в исходниках и даташите. Вот что написано в даташите:

 

...In either case, the external AREF pin is directly connected to the ADC, and the reference voltage can be made
more immune to noise by connecting a capacitor between the AREF pin and ground....

 

На схеме из первого поста вывод контроллера AREF висит в воздухе. После подключения конденсатор 0,1 мкФ между выводом AREF и землей хаотичное моргание прекратилось.

Share this post


Link to post
Share on other sites
Проблему с хаотичным морганием светодиода решил. Долго копаясь в исходниках и даташите. Вот что написано в даташите:

 

...In either case, the external AREF pin is directly connected to the ADC, and the reference voltage can be made
more immune to noise by connecting a capacitor between the AREF pin and ground....

 

На схеме из первого поста вывод контроллера AREF висит в воздухе. После подключения конденсатор 0,1 мкФ между выводом AREF и землей хаотичное моргание прекратилось.

Проглядел. Будем знать.

Share this post


Link to post
Share on other sites
2. Поддерживает ли Ваш программатор обработку команды Get VTARGET?

 

Чтобы Студия использовала эту команду и не ругалась, нужно изменить ответ на команду CMD_SIGN_ON с AVRISP_2 на STK500_2.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this