Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

Решил собрать Ваш программатор. Необходимо уточнить подойдет ли Atmega8L (лайтовая версия) и актуальны ли прошивки выложенные в первой части в начале темы (в папке v6 вложена папка v5), и если нет тогда можно ссылку на свежую прошивку. Заранее спасибо.

Share this post


Link to post
Share on other sites
Решил собрать Ваш программатор. Необходимо уточнить подойдет ли Atmega8L (лайтовая версия) и актуальны ли прошивки выложенные в первой части в начале темы (в папке v6 вложена папка v5), и если нет тогда можно ссылку на свежую прошивку. Заранее спасибо.

Подойдёт, только на неё нужен кварц 7,372800 МГц.

И немного другая прошивка (в старой теме от 2009 года) : http://electronix.ru/forum/index.php?act=a...st&id=30117

Прошивки в начале темы актуальны (фича в названием папки v5 известна давно)

Share this post


Link to post
Share on other sites

Я собрал ваш программатор.Использовал Atmega8A AU1111,кварц 14.7456.

Прошивка с первого поста.Программатор прошиваеться и его видит АВР Студия.

Прошивать им еще не пробывал.Но после подключения и шести миганий индикатора

он не выключаеться а переодично мигает.Подскажите куда смотреть.

Share this post


Link to post
Share on other sites
Я собрал ваш программатор.Использовал Atmega8A AU1111,кварц 14.7456.

Прошивка с первого поста.Программатор прошиваеться и его видит АВР Студия.

Прошивать им еще не пробывал.Но после подключения и шести миганий индикатора

он не выключаеться а переодично мигает.Подскажите куда смотреть.

Питание? Закоротки? Залипухи? Непропаи? Флюс отмыть?

Share this post


Link to post
Share on other sites
Питание в норме,короткого нет все прозвонил,флюс смыл еще раз спиртом.

В прогаматор с терминала захожу.Индикатор все равно мигает.

Вольтметром посмотрите питание, когда мигает. Что пишет в терминале когда мигает?

Share this post


Link to post
Share on other sites

Питание если я правильно понял замерял на плате программатора равно 4.85-4.9В.

В терминале при подключении кроме изменения стандартных опций программатора

ничего нет.

Share this post


Link to post
Share on other sites
Собрал программатор на 232RL. Подключаю к USB порту, комп ругается "неизвестное устройство". Как установить дрова? У меня ХР.

Элементарно.Набираеш в гугле скачать драйвера для FT232RL,качаеш,устанавливаешь через диспетчер устройств,даеш номер ком порта

свободного но не более чем четвертый.Прошиваешь как написано в хелпе.

Share this post


Link to post
Share on other sites
Собрал программатор на 232RL. Подключаю к USB порту, комп ругается "неизвестное устройство". Как установить дрова? У меня ХР.

http://www.ftdichip.com/Drivers/CDM/CDM20814_Setup.exe

Share this post


Link to post
Share on other sites

Хочу собрать ваш программатор на 232RL, 88 Меге и кварце 18,432МГц, возникло несколько вопросов:

1. Конденсаторы частотозадающие на кварце 0,1uF не многовато-ли, обычно 15-47пик

2. Попалась старая схема на FT232BM, там резистор R13 (в новой R9) имел разные номиналы в зависимости от кристалла, имеет ли это значение в новой схеме?

Share this post


Link to post
Share on other sites

Купил уже собранный программатор вместе с отладочной платой. У продавца все работало, а у меня ни CVAVR (вер. 2.05) ни AVR Studio (вер. 4.18) не видят программатор.

При подключении программатор мигает 6 раз как и положено, в устройствах появляется USB serial port COM9 (настроил его на 115200). Программатор подключаю к разъему ISP на отладочной плате, подаю дополнительное свое питание на плату, включаю плату (при этом выполняется программа, записанная в МК- бегают светодиоды).

Пытаюсь прочитать FLASH, но выдает ошибку. При этом светодиод на программаторе орит постоянно.

 

В AVR Studio выбираю STK500 или AVRISP- вся уже пытался. Пробовал без питания отладочной платы, тоже не видит.

 

Что я не так делаю? Где рыть?

post-68390-1321703488_thumb.png

Share this post


Link to post
Share on other sites
Хочу собрать ваш программатор на 232RL, 88 Меге и кварце 18,432МГц, возникло несколько вопросов:

1. Конденсаторы частотозадающие на кварце 0,1uF не многовато-ли, обычно 15-47пик

2. Попалась старая схема на FT232BM, там резистор R13 (в новой R9) имел разные номиналы в зависимости от кристалла, имеет ли это значение в новой схеме?

1. Многовато. Эта опечатка была исправлена в более поздних версиях документации (в первом посте "старой" темы в самом низу есть "актуальные прошивки и докуентация")

2. Имеет. Этот резистор зависит от опорного напряжения АЦП контроллера.

 

Купил уже собранный программатор ....

Любопытно, а где купил?

... появляется USB serial port COM9

....

Что я не так делаю? Где рыть?

Перенастройте COM9 на COM1, COM2, COM3 или COM4

Share this post


Link to post
Share on other sites
Любопытно, а где купил?

 

купил на Молотке вместе с отладочной платой, самоделка. Человек для себя спаял, а сейчас у него параллельный программатор и это стала не нужна.

 

Перенастройте COM9 на COM1, COM2, COM3 или COM4

 

Да, я честно прочитал всю ветку и встречал, что надо СОМ не больше четвертого.

Поэтому так тоже пробовал уже, но не помогает.

А в терминале как мне проверить его. Нужно перемычки перекидывать будет какие-нибудь? Может просто USB-кабель чего не фурычит или порт в компе.

Плата вот такая же (это фото не моё, но оно было в одном из сообщений в этой ветке, просто она один в один). Как проверить, что связь на уровне программатора и компа нормальная. Или я что-то не допонимаю.

post-68390-1321796427_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this