Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

Вопрос еще в силе. Возможно у автора этого замечательного программатора есть хоть какие-то мысли по этому поводу? Спасибо.

Дело не в железе. Это точно. Проблемы со студией - обращайтесь в саппорт атмела.

Share this post


Link to post
Share on other sites

А в пятой студии сей девайс и не должен работать, так как он определяется как AVR ISP а не STK-500, новая студия AVR ISP не поддерживает.

 

Дело не в железе. Это точно. Проблемы со студией - обращайтесь в саппорт атмела.

Представляю что они ответят ... http://electronix.ru/forum/style_emoticons...ault/maniac.gif

Share this post


Link to post
Share on other sites
А в пятой студии сей девайс и не должен работать, так как он определяется как AVR ISP а не STK-500, новая студия AVR ISP не поддерживает.

Спасибо Атмелу.

Как вариант программируйте внешней программой программатором. avrdude, например. Давно с ней работаю - полёт нормальный. Поддержку железных программаторов не уменьшают, а только расширяют.

Share this post


Link to post
Share on other sites
Спасибо Атмелу.

Как вариант программируйте внешней программой программатором. avrdude, например. Давно с ней работаю - полёт нормальный. Поддержку железных программаторов не уменьшают, а только расширяют.

Чтож значит пока не буду сносить 4ку - будет программатором :laughing:

Спасибо Vasiliy P. за то, что внес ясность, а то я думал может что не так делаю.

Edited by Altais

Share this post


Link to post
Share on other sites

Добрый день! собрал программатор заработал сразу, программировал в PonyProg , установил как писали СОМ 1 запрограммировал с папки AVRUSB500_by_Petka_HEX 8.НЕХ но забыл установить фьюзы,програмировался 15 мин при проверке выдал ошибку 24 подключил программатор замигал 6 раз за 10 сек.Почитал рекомендации РЕТКИ и поставил фьюзы проверил совпало только ещё 1SPIEN,но он вне зоны доступа. Подключил стал мигать быстро 2-3сек.Подключил программировать АТМЕЛ 16 АУ от внешнего питания (общий - ) не горит,отключил,поставил перемычку+усб на +5 замигал и потух,а комп выдаёт звук подключения нового устройства.при проверке чипа 16 ау на чистоту пишет устройство отсутствует или неисправно куда рыть? изменил поставил разъём - возле +5в от источника и провода 10 см с чередованием на - а то от руки фон и горит диод

Share this post


Link to post
Share on other sites
Добрый день!

Добрый. Давайте по порядку:

.. собрал программатор заработал сразу, программировал в PonyProg , установил как писали СОМ 1 запрограммировал с папки AVRUSB500_by_Petka_HEX 8.НЕХ но забыл установить фьюзы,програмировался 15 мин при проверке выдал ошибку 24

Для начала перезалейте с помощью Pony ещё раз прошивку (не забудьте перед прошивкой стереть чип). Добейтесь что бы верификация прошивки была успешной.

...при проверке чипа 16 ау на чистоту пишет устройство отсутствует или неисправно куда рыть? ....

После того как у вас будет гарантия, что прошивка программатора верифицирована. Идём дальше.

Если при подключении программируемого устройства к программатору светодиод на программаторе не будет гореть непрерывно, то значит софт тоже не будет выдеть программируемый чип.

Share this post


Link to post
Share on other sites

Спасибо !!! ткните пожалуйста пальцем где описано как стереть , или нужен другой программатор а то читаю сзади в начало то это уже кто то делал просто приходится впервые сталкиваться спасибо

Share this post


Link to post
Share on other sites
Ткните пожалуйста пальцем где описано как стереть.

В понипроге есть иконка на которой изображена стирательная резинка и полустёртый чип. Это и есть функция "стереть чип".

Share this post


Link to post
Share on other sites
делал но постоянно выскакивает ошибка 24 я её игнорирую но она всё равно есть

"С начала рекомендуется перед записью прочитать контроллер, это позволит лишний раз убедиться в том, что он определяется, что программа правильно настроена и все остальное работает как нужно.

Сообщение об ошибке Device missing or unknown device (-24) (Устройство неизвестно или повреждено) - говорит о том что Понипрог не может прочитать микросхему и нужно еще раз проверить правильность подключения, подается ли питание на программируемый контроллер и настройки самой программы"

Share this post


Link to post
Share on other sites
Подскажите можно ли заменить 27 омные резюки 30 омными и смд дроссель 10uH 0,5 А на выводной 30 uH?

Дроссель можно безболезненно заменить. 27 Ом рекомендует FTDI. 30 Ом тоже будет работать.

Share this post


Link to post
Share on other sites
Ещё такой вопрос. Какой последней версией avr studio вы советуете пользоваться для работы с AvrUsb500 by Petka.

Я AVRStudio не использую. Программирую через avrdude. Если удобная вам версия AVRStudio поддерживает программаторы stk500, то смело используйте её.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this