Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

Вот печатка в jpg

....

и по второй схеме собирал тоже не получается

Ни на одной из "схем" не вижу, что вы называете R4-R7

Кроме того, ни одну из этих "схем" я не рисовал. Вы пробовали собрать устройство по моей "печатке", размещённой на этом форуме?

...

и терминал не видит как только отсоединяю 4 верхних резистора на выходе с меги терминал вроде 2 раза ентер принимает но приветствия никакого не выдает.

...

В смысле терминал не видит?

Что значит "2 раза enter принимает"?

P.S. Трудно помочь, когда недостаточно информации. Описывайте свои действия максимально подробно.

Share this post


Link to post
Share on other sites
А у вас печатка есть не в пдф. У меня принтер не хочет печатать в 100%. Ну или исходник если не жалко.

Попробуйте печатать другим софтом. Например Foxit Reader.

Share this post


Link to post
Share on other sites

Для Maksim_9

Схема полностью рабочая и проверена десятком людей. Я лично спаял 2 программатора и пользуюсь уже больше года.

Поэтому не приставайте к разработчику. Там все ВЕРНО!!!

Share this post


Link to post
Share on other sites

Подскажите пожалуйста!!! собрал схему по Petka V2 и по его печатке, с FT232BL и Atmege88 с кварцем 14мГц, все прошилось нормально, моргает при подключении 6 раз, через телнет не откликается жму два раза ентер а в ответ тишина, FVR Studio 4 не подключается, нажимаю конект окно закрывается и опять появляется, может что не так делаю?

 

забыл сказать прошивка 7

 

спасибо всем за помощь разобралсяя, просто не записывались фузы, записал их отдельно и все заработало

Share this post


Link to post
Share on other sites

Доброе время суток! Напишите пожалуйса инструкцию как пользоваться программатором, что за чем подклучать когда и сколько должен моргнуть диод или просто гореть?

 

Телнет по двухкратному нажатию выдает

[0m[2J[0;0favrusb500v2-1.2

EEnter SW Version Major in hex [2]:

если еще раз нажать

EEnter SW Version Minor in hex [a]:

еще раз

ERes t target at connector polarity test(1=on 0=off)[0]:

еще раз

OK, my SW version is now: 2.0a (hex)

Select 'stk500 by petka' mode. (1=1Mhz 0=Fast/debug)[255]

еще раз

EReady. Just close

he terminal. No reset needed.

так и должно быть?

Edited by Maksim_9

Share this post


Link to post
Share on other sites
Доброе время суток! Напишите пожалуйста инструкцию как пользоваться программатором, что за чем подключать когда и сколько должен моргнуть диод или просто гореть?

Когда программатор подключаете к компу светодиод должен 6 раз быстро мигнуть.

А когда после этого вы подключаете к запитанному программируемому контроллеру светодиод должен зажечься и гореть до отключения.

Телнет по двухкратному нажатию выдает

....

так и должно быть?

Да, вывод программатора такой и должен быть.

Share this post


Link to post
Share on other sites
Когда программатор подключаете к компу светодиод должен 6 раз быстро мигнуть.

А когда после этого вы подключаете к запитанному программируемому контроллеру светодиод должен зажечься и гореть до отключения.

 

Да, вывод программатора такой и должен быть.

Спасибо! А то я переживать уже начал. подключил схему с Атмега32 диод горит хотел прошить ошибку выдает и ни как, ну хоть теперь в программаторе уверен что работает

Share this post


Link to post
Share on other sites
Доброе время суток! Вот нарисовал печатку, спаял, прошил и не работает. Светодиод маргает 6 раз а программа програматор не видит, терминал тоже, помогите пожайлуста.

Диод моргает при запуске проги контроллера - подаче питания в исправную отчасти схему.

А комп видит не программер , а виртуальный СОМ порт с номером , который виден в панели управления Винды после установки дров на тот или другой мост УСВ-СОМ под

конкретную Винду.

Надо как минимум совпадение номеров портов в винде и проге прошивки .

При подключении таргета к программеру по АЦП в программере меряется напруга на РЕСЕТе таргета , и если она есть горит диод постоянно . От остальных ошибок при подкл . ( перепутал сигналы МОСИ и МИСО и т.п. ) оно не застраховано.

Share this post


Link to post
Share on other sites
Читайте пост 446 . Почти стандартная проблема как у Вас и ее решение описано там .

В 446 вы мне и отвечали. Подключение к контролеру правильное уже ни раз проверил. сом порты тоже одинаковые выставил. Кто нибудь знает как это решить

Edited by Maksim_9

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this