Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

скажите Petka. если при соединении с МК светодиод на прогере не горит. Это уже не рабочий МК? Или может быть проблема с фьюзами?

Это не подтянут reset к питанию.

Share this post


Link to post
Share on other sites

В AVRStudio постоянно вылазит сообщение о том что прошивка программатора устарела и предлагает "залить" в него новую прошивку. Можно ли это делать, или как отключить проверку обновлений?

 

post-27289-1272358150_thumb.jpg

Share this post


Link to post
Share on other sites

Добрый день, собрал программатор по приведенной схеме, в режим наладки программатора через терминал заходит, нормально настраивается. При подключении к AVRStudio и CodeVision, определяется нормально. При прошивке целевого контроллера прошивает вроде бы нормально, но при верификации записанных данных выдает ошибку несовпадения первого же байта. В чем может быть проблема? Что необходимо проверять? Заранее благодарен за ответ.

Кстати может ли быть проблема в том, что у меня выход 23 меги подключен на разъём ICP10 напрямую (это выход 1 МГц)

 

PS:Программируется PonyProg где-то около часа с верификацией. Залил прошивку версии 4 или 5 под мегу 8 и кварц 14745600. Использую FT232RL. При подключении к USB прошитого программатора светодиод мигает 5 или 6 раз, точно сказать не могу глаз не успевает увидеть.Как уже написал в консольный режим входит сразу и конфигурируется нормально.

Edited by Melandr

Share this post


Link to post
Share on other sites

Странно, при подключении программируемого контроллера к программатору светодиод мигает несколько раз(5 или 6) и тухнет. При подключении другого программируемого контроллера светодиод сразу загорается и не мигает. В чем может быть проблема?

Share this post


Link to post
Share on other sites
...

Залил прошивку версии 4 или 5 под мегу 8 и кварц 14745600.

...

Рекомендую прошить 6ю версию.

 

Странно, при подключении программируемого контроллера к программатору светодиод мигает несколько раз(5 или 6) и тухнет. При подключении другого программируемого контроллера светодиод сразу загорается и не мигает. В чем может быть проблема?

Видимо контроллер в программаторе перезагружается. Одна из причин - проседает питание. Например, закорочены сигнальные линии до защитных диодов. (проверьте выход 1МГц).

Share this post


Link to post
Share on other sites

В архиве 6-ой прошивки лежит папка с именем 5-ой прошивки, так и должно быть? Это актуальная прошивка? Щас проверю вывод 1МГц. Хотя в платах программируемых устройств он вроде не подключен. Может ли такое быть если используется питание по USB? Просто проверял линию ресета на обоих платах, они идентичны, но на одной плате горит светодиод, а на второй не горит, но при подключении мигает.

 

При подключении одной платы неправильно считывает сигнатуру программируемого чипа. В чем может быть проблема? У меня на программаторе я завел выход 1 Мгц на 3 пин разъёма ICP-10. На программируемой плате вывод 3 не подключен.

PS При использовании внешнего питания на плате программируемого контроллера программатор не може тподключиться, хотя с какой-то другой прошивкой подключался. Непонятно

PS2: Еще наблюдается такая вещь. При чтении сигнатуры AVRStudio она считывается неправильно. А при чтении CodeVision считывается верно.

Edited by Melandr

Share this post


Link to post
Share on other sites

А подскажите, при первом включении AvrUsb500 by Petka что должно происходить. У меня выскакивает сообщение: Устройство USB не опознано. Подскажите в какую сторону копать? Собрал на 232rl.

Share this post


Link to post
Share on other sites

драйвер FTDI установил? В списке устройст USB должен после установки драйвера появиться устройство USB Serial Converter

Также в списке Com портов должен появиться USB Serial port.

Edited by Melandr

Share this post


Link to post
Share on other sites
Скачал какой то последний версия 2.06. На файле ftdiport.inf выбрал установить, но в списке устройств USB ничего не появилось.

Такое бывает, если перепутаны выводы D+ и D- местами. Проверьте.

Share this post


Link to post
Share on other sites

А у не прошитого программатора должен мигать светодиод при подключении к USB?

Такое бывает, если перепутаны выводы D+ и D- местами. Проверьте.

Спасибо наверное так и было. Но еще вариант, паяльник здорово перегревает кое где дорожки по отлетали.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this