Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka. продолжение

Recommended Posts

У меня также заработал и выяснилась проблемка, которая все портила))) Косяк был не в программаторе, а плате программируемого контроллера.

Share this post


Link to post
Share on other sites

Petka, большое спасибо за программатор! Собрал схему на FT232rl и сразу заработало (правда пока готовый девайс не дошли руки прошить.)

 

Хотел задать вопрос. Какая прошивка актуальна, на сегодняшний момент?

 

На первой странице проекта есть два вида прошивки:

 

Готовые прошивки и исходники актуальные на 8 июля 2009 года

 

Обновление IgorKossak - Oct 19 2009, 10:31

 

Я посчитал, что прошивка от октября 2009 должна быть новее июля 2009, но видимо ошибся :laughing:

 

И хотелось бы дать пару советов Petka. :)

Мне кажется стоит довести документацию до ума. Сейчас ее в принципе достаточно, но она как то разбросанна. Вот те недостатки которые заметил я.

 

- Нет четкой ссылки на последнюю, актуальную, версию прошивки. (директория AvrUSB500_by_Petka_HEX_SRC_v5_fast вложенная в директорию AvrUSB500_by_Petka_HEX_SRC_v6_uni тоже не добавляет ясности)

- Стоило бы сделать HowTo и в русской версии

- Скриншот с фьюзами PonyProg можно запихнуть в HowTo

- Описание настройки программатора через гипертерминал размазано по всему форуму.

 

Не сочтите мои советы придирками, но новичкам бы было заметно проще.

Edited by Radistor

Share this post


Link to post
Share on other sites
...

 

на все эти вопросы были ответы. и для Дудика автор давал настройки. и всё становится на УРА... я еще не говорил, но автору огромное СПАСИБО и РЕСПЕКТ!!

Edited by IgorKossak
Бездумное цитирование

Share this post


Link to post
Share on other sites
на все эти вопросы были ответы. и для Дудика автор давал настройки. и всё становится на УРА... я еще не говорил, но автору огромное СПАСИБО и РЕСПЕКТ!!

 

Да я тоже нашел все настройки, и сразу заработало (еще раз большое спасибо Petke).

 

Просто некоторые моменты очевидны не сразу и приходится просматривать форум и FAQ, что не есть гуд.

ИМХО, для новичков было бы хорошо собрать все в одном архиве. Что бы там была самая последняя рабочая версия прошивки, схема, фьюзы и т.д.

Если расписать инструкцию по шагам, типа скачать понипрог по адресу такому-то, поставить фьюзы такие то, меньше было-бы проблем и вопросов. Petka, как-то упоминал, что англоязычный HowTo является своеобразным тестом. Т.е что бы новички, которые не знают английский язык, шли бы повышать свое образование, а потом собирать программатор. Я частично соглашусь с этим мнением, но на мой взгляд совсем уж новичок, не поймет вообще что такое программатор и чего это тут люди обсуждают на сотню листов :biggrin:

А людям хоть немного разбирающимся в электронике (думаю и профессионалам тоже) проще купить нужные детали, вытравить готовую плату, особо не напрягая мозг выполнить ряд действий и получить готовый программатор :)

Ну а тем, кто хочет поэкспериментировать или у кого нет нужных деталей, уже могут делится своими мнениями и советами на форуме.

 

Еще раз повторюсь (что бы ненароком не навлечь гнев форумчан :) ) что это сугубо мое мнение и оно может не совпадать с мнением других участников :rolleyes:

Share this post


Link to post
Share on other sites

Mrgnstrn Мне понравилась Ваша плата на 6-ой странице этой темы по сылке Timm_STK500v2_PL2303_Mega8_withoutSelfProg.zip. Уже собрал и только тогда заметил что назначения портов не соответствует основной схеме. Разобраться и поменять прошивку мне сложно. Не могли бы Вы выложить прошивку к этому варанту схемы. Да, еще МК я использовал AtMega88/

Share this post


Link to post
Share on other sites

Petka ,за подсказку спасибо! Завелось.Было 4 непропая.Теперь очередной вопрос, уж не взыщите.Периодическе в ветке всплывает вопрс- сколько раз мигает светодиод? Из чего я делаю вывод что моргает он быстро.Уменя он моргает ровно 6 раз.Примерно раз в секунду.Это нормально? Если нет, то что делать, куда смотреть?При подключении таргета загорается на постоянно, Студия и Коде вижн программатора не находят, на выходе 1Мгц ничего нет.

Edited by flyer66

Share this post


Link to post
Share on other sites

Всем привет!

На днях стал программировать Atmega128 и столкнулся с тем, что микроконтроллер не хочет прошиваться :crying:

 

Вроде у NicholasR, возникали какие то трудности с программированием Atmega128, буду рад, если поделится своими советами.

 

Вообщем, прошу помощи уважаемые форумчане. Немного о схеме: Выводы MOSI и MISO подключенны к выводам PE0 и PE1. Программатор на 90% должен быть рабочим (быстро мигает 6 раз светодиодом, при подключении к плате светодиод горит постоянно, вобщем все хорошо). Плата типа тестовой, разводка выполнена не очень корректно + нет подтягивающего резистора на RESET. Также на плате сделан разъем под JTAG... тьфу тьфу тьфу с ним проблем не возникло.

А подключаю программатор AvrUsb500 by Petka и контроллер не видится, не AVRStudio не CodeVision. В чем проблема так и не смог разобрать :crying: Если надо могу прислать скриншоты осциллограмм, на разных выводах.

Share this post


Link to post
Share on other sites
Разобраться и поменять прошивку мне сложно. Не могли бы Вы выложить прошивку к этому варанту схемы. Да, еще МК я использовал AtMega88/

Попробуйте сначала сами. На первой странице форума описано как. Что не получится - спрашивайте.

 

Примерно раз в секунду.Это нормально? Если нет, то что делать, куда смотреть?

Неправильно прошиты Фузы. Или вообще не прошиты.

 

Всем привет!

Плата типа тестовой, разводка выполнена не очень корректно + нет подтягивающего резистора на RESET.

Конденсаторы на каждой паре VCC-GND есть?

Программатор хоть одну мегу с момента пайки запрограммировать смог?

Share this post


Link to post
Share on other sites
Конденсаторы на каждой паре VCC-GND есть?

Программатор хоть одну мегу с момента пайки запрограммировать смог?

 

конденсаторов к сожалению нету. Вообщем я еще немного поколдовал. Один раз в AVRStudio удалось прочитать фьюзы и прошить программу, после чего, девайс опять стал недоступен. Скорее всего дело в неправильной схемотехнике моего девайса, но все таки думаю, что конденсаторы по питанию не должны так сильно влиять на возможность программирования, может конечно я ошибаюсь.

 

Из замеченных странностей:

Если программатор подключен только к плате и не подключен к USB, то на выводе RST присутствует низкий уровень (1,8В), если же отключить программатор от платы, то уровень высокий (4,6В)

 

Светодиод программатора, при подключении к плате горит постоянно в независимости от Reset target at connector polarity test

 

При попытке прочитать сигнатуру или фьюзы в AVRStudio светодиод программатора гаснет а потом 6 раз мигает (как при включении в USB)

 

В CodeVision, светодиод просто тухнет на секунду и загорается вновь.

 

Прикладываю осциллограмму с вывода SCK. Видно, что фронты немного завалены, но в целом достаточно хороший сигнал. По остальным ногам также.

 

P.S. Есть возможность прошить Atmega8, но это только дня через 2.

post-55927-1268659766_thumb.jpg

Share this post


Link to post
Share on other sites
конденсаторов к сожалению нету. Вообщем я еще немного поколдовал. Один раз в AVRStudio удалось прочитать фьюзы и прошить программу, после чего, девайс опять стал недоступен. Скорее всего дело в неправильной схемотехнике моего девайса, но все таки думаю, что конденсаторы по питанию не должны так сильно влиять на возможность программирования, может конечно я ошибаюсь.

 

Ошибаетесь и сильно. В цифровых схемах должны обязательно стоять конденсаторы по питанию. Это азы цифровой схемотехники.

И еще если программатор сделан правильно, то меги 128 он программирует без проблем из CodeVision. Проверял лично и неоднократно.

Edited by ds1307

Share this post


Link to post
Share on other sites

Вот немного попытался собрать из всего материала: в частности собиралось для себя кто дополнит буду благодарен

__________________.doc

Edited by IgorKossak
Совершенно ненужное цитирование!!!

Share this post


Link to post
Share on other sites

Спасибо, Petka, за конструкцию.

Собрал 2 варианта, первый с переключателем 3,3/5В на ATmega8 14,7456 МГц, второй на ATmega88 18,432 МГц с добавкой MAX3001 для программирования схем с низковольтным питанием. Одна из ATmega162L прошилась при напряжении питания 2,05 В. Пришлось для этого подбирать R9.

Share this post


Link to post
Share on other sites

Собрал программатор на плате от -JonnS-, Atmega8 прошилась нормально, при нажатии несколько раз на enter в терминале вижу такое:

 

avrusb500v2-1.2

Enter SW Version Major in hex [2]:
Enter SW Version Minor in hex [a]:
Reset target at connector polarity test(1=on 0=off)[1]:

OK, my SW version is now: 2.0a (hex)
Select 'stk500 by petka' mode. (1=1Mhz 0=Fast)[255]:
Ready. Just close the terminal. No reset needed.

 

Программатор не испытывал, т.к. не на чем. Но вот появилась необходимость перепрошить Atmega168-20PU (в нее по ошибке залили другую прошивку), т.е. нужно ее стереть и залить нужную прошивку. В свойствах виртуального ком-порта я установил скорость 115200 и отключил управление потоком. Запускаю AVR Studio4, Tools -> Programm AVR -> Connect, дальше выбираю как на картинке:

 

c21e86a591dbt.jpg

 

Вроди все нормально. Но не могу ничего поделать с Atmega168 - ни фузы прочесть, ни стереть, ни записать.

 

751ee8cfb5d0t.jpg

c0fda28a6956t.jpg

5f48c5e0fef1t.jpg

 

При нажатии на программаторе кнопки S1 загораются светодиоды "Target" и "Program", к атмеге подвел сигналы MOSI, MISO, RESET, GND, VCC и SCK. Подключал по даташиту, неоднократно проверил правильность подключения проводов к атмеге и к программатору. Пожалуйста подскажите где собака порылась - неправильно собрал программатор или атмега умерла?

Share this post


Link to post
Share on other sites
Собрал программатор на плате от -JonnS-,

Эта версия железа мною не поддерживается.

Ищите чем отличается оригинальная схематика от той, что вы собрали. Скорее всего отличия по питанию таргета.

При нажатии на программаторе кнопки S1 загораются светодиоды "Target" и "Program", к атмеге подвел сигналы MOSI, MISO, RESET, GND, VCC и SCK. Подключал по даташиту, неоднократно проверил правильность подключения проводов к атмеге и к программатору. Пожалуйста подскажите где собака порылась - неправильно собрал программатор или атмега умерла?

Либо в таргете неправильно зашиты фузы тактирования, либо отсутствует питание. Судя по скриншотам программатор функционирует. Что за кнопка S1 ? такой никогда не было.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this