Jump to content

    

AVRONE! и XMEGA 16 A4

Доброго времени суток!

Я счастливый обладатель AVRONE! KIT. Купили для AVR32 и XMEGA(не было нужного atjtagicemkII c PDI).

У меня вопрос, как подключать AVRONE! к PDI разьему?

В коробке есть несколько переходников. Какой ставить не знаю. А методом тыка - боюсь спалить.

Share this post


Link to post
Share on other sites
Доброго времени суток!

Я счастливый обладатель AVRONE! KIT. Купили для AVR32 и XMEGA(не было нужного atjtagicemkII c PDI).

У меня вопрос, как подключать AVRONE! к PDI разьему?

В коробке есть несколько переходников. Какой ставить не знаю. А методом тыка - боюсь спалить.

 

В AVR Studio есть полное поисание как подключать аппартно к МК программаторы. Там и посмотрите.

Share this post


Link to post
Share on other sites

Спасибо, в хелпе нашел подключение.

 

Вот только когда отлаживать начал, появилась проблема.

когда я в программе ставлю breakpoint он срабатывает нормально. А вот когда я нажмаю на паузу(halt) в AVR Studio контроллер останавливается мгновенно, а в студия подвисает минуты на две, в нижнем правом углу поморгает паузой, и только потом отображает остановку.

Этот процесс можно как-нибудь ускорить?

Share this post


Link to post
Share on other sites
Спасибо, в хелпе нашел подключение.

 

Вот только когда отлаживать начал, появилась проблема.

когда я в программе ставлю breakpoint он срабатывает нормально. А вот когда я нажмаю на паузу(halt) в AVR Studio контроллер останавливается мгновенно, а в студия подвисает минуты на две, в нижнем правом углу поморгает паузой, и только потом отображает остановку.

Этот процесс можно как-нибудь ускорить?

Это скорее вопрос к Atmel - потому что AVR Studio в определенных условиях (внутрение симуляторы или работа с программатором STK500, AVRISP2 -- больше не пробывал) всегда подтормаживает (иногда и рушеться полностью). Хотя возможно настройки Studio могут помочь - не знаю точно :laughing:

Share this post


Link to post
Share on other sites
всегда подтормаживает

но не на две минуты же :)

 

Насколько я понимаю avrone! скидывает за это время дамп своей памяти(128Mb) и дамп контроллера. Может быть я ошибаюсь.

Какие есть еще идеи?

Share this post


Link to post
Share on other sites

Проблема решилась сама собой, у меня был код:

void wait()
{
    unsigned int i;
    for(i=0;i<1000;i++)
    ;    
}
...
...
...
while(1)
{
    wait();
}

Изменил на:

void wait()
{
    unsigned int i;
    for(i=0;i<1000;i++)
        nop();    
}
...
...
...
while(1)
{
    wait();
}

Теперь останавливается мгновенно.

Share this post


Link to post
Share on other sites

И В чем принципиальная разница между Вашими кодами? (А на каком компиляторе работаете).

Share this post


Link to post
Share on other sites
И В чем принципиальная разница между Вашими кодами? (А на каком компиляторе работаете).

Да в принципе разицы нет. По ходу AVRStudio не может нормально остановиться в блоке

    for(i=0;i<1000;i++)
   ;

 

Компилятор WinAVR(AVR-GCC) версия 20090313

Share this post


Link to post
Share on other sites
И В чем принципиальная разница между Вашими кодами? (А на каком компиляторе работаете).

а что , если скормить -Os gcc ? первый вариант не будет оптимизирован ? и фор останется ? таки разница IMHO есть все-таки

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this