Jump to content

    

Neocell в RHEL5

Понадобилось использовать Neocell в RHEL5.

Не работает...

Точнее встраивается в IC5141 корректно, но при вызове оттуда пишет:

"/path/NeoCell/bin.linux/cedit: relocation error: /path/NeoCell/external/windu/lib.linux_i32/libwinsock50.so: symbol h_errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference"

 

Посмотрев по различным форумам решения так и не нашел.

 

Может кто уже пробовал такое сочетание?

 

***

 

PS!

1) По данным сайта компании Cadence Neocell поддерживается только до RHEL4.

2) Подобная проблема обсуждалась на форуме Cadence: http://www.cadence.com/Community/forums/p/12006/16398.aspx

Но там не говорится о найденном решении. :05:

Share this post


Link to post
Share on other sites

common problem after install IC5141 in REHL5 OS,

"missing libxx... ..".

This is due to RHEL5 not install all necessary rpm for the IC5141.

Solution: get your RHEL5 DISC and find the following rpm

compat-libf2c-34-3.4.6-4.i386.rpm

compat-libf2c-34-3.4.6-4.x86_64.rpm

compat-libstdc++-296-2.96-138.i386.rpm

compat-libstdc++-33-3.2.3-61.i386.rpm

compat-libstdc++-33-3.2.3-61.x86_64.rpm

libXp-1.0.0-8.1.el5.i386.rpm

libXp-1.0.0-8.1.el5.x86_64.rpm

libXp-devel-1.0.0-8.1.el5.i386.rpm

libXp-devel-1.0.0-8.1.el5.x86_64.rpm

ncompress-4.2.4-47.x86_64.rpm

openmotif22-2.2.3-18.i386.rpm

openmotif22-2.2.3-18.x86_64.rpm

openmotif-2.3.1-2.el5.i386.rpm

openmotif-2.3.1-2.el5.x86_64.rpm

openmotif-devel-2.3.1-2.el5.i386.rpm

openmotif-devel-2.3.1-2.el5.x86_64.rpm

copy those rpm into your system and do the install.

Assume you put those rpm files into /tmp/rpm direcotry. do the install as follows:

"rpm -i /tmp/rpm/*rpm"

After the rpm installed, you shall not have any problem to use IC5141.

If you have above rpm install, you also shall not have any issue to run any CADENCE or SYNOPSYS tools.

Share this post


Link to post
Share on other sites

Thanks for the reply.

Firstly I do not have any problem with IC5141 at RHEL5.

But that is not a case for the Neocell.

 

Did you try to use Neocell in RHEL5?

 

 

 

common problem after install IC5141 in REHL5 OS,

"missing libxx... ..".

This is due to RHEL5 not install all necessary rpm for the IC5141.

Solution: get your RHEL5 DISC and find the following rpm

compat-libf2c-34-3.4.6-4.i386.rpm

compat-libf2c-34-3.4.6-4.x86_64.rpm

compat-libstdc++-296-2.96-138.i386.rpm

compat-libstdc++-33-3.2.3-61.i386.rpm

compat-libstdc++-33-3.2.3-61.x86_64.rpm

libXp-1.0.0-8.1.el5.i386.rpm

libXp-1.0.0-8.1.el5.x86_64.rpm

libXp-devel-1.0.0-8.1.el5.i386.rpm

libXp-devel-1.0.0-8.1.el5.x86_64.rpm

ncompress-4.2.4-47.x86_64.rpm

openmotif22-2.2.3-18.i386.rpm

openmotif22-2.2.3-18.x86_64.rpm

openmotif-2.3.1-2.el5.i386.rpm

openmotif-2.3.1-2.el5.x86_64.rpm

openmotif-devel-2.3.1-2.el5.i386.rpm

openmotif-devel-2.3.1-2.el5.x86_64.rpm

copy those rpm into your system and do the install.

Assume you put those rpm files into /tmp/rpm direcotry. do the install as follows:

"rpm -i /tmp/rpm/*rpm"

After the rpm installed, you shall not have any problem to use IC5141.

If you have above rpm install, you also shall not have any issue to run any CADENCE or SYNOPSYS tools.

 

Share this post


Link to post
Share on other sites
Thanks for the reply.

Firstly I do not have any problem with IC5141 at RHEL5.

But that is not a case for the Neocell.

 

Did you try to use Neocell in RHEL5?

 

Тут смысл тот же просто. У вас в системе либо нет необходимых библиотек, либо не подходят версии.

Библиотеки можно нарыть на просторах интернета.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this