Jump to content
    

Проблемы с программированием ATmega64

Давно использую ATmega64L. Не было никаких проблем ни по освоению, ни по программирванию. Выпущено больше тысячи различных приборов на данном чипе. С конца прошлого года появилась проблема - определенная партия микросхем (причем ВСЯ ПАРТИЯ 100%) не шьется по ISP. В первый раз (декабрь 2008) я подумал, что это случайность. Сейчас май 2009 и снова на руках "битая" партия. Конкретно о чипе:

ATMega64L-8AU

маркировка на обратной стороне:

8H6144

355D9E

1-P

0903 e3

Просьба к тем, кто сталкивался с подобным, что это такое вообще и что делать!? Возможно стоит попробовать зашить на STK500(600) (к сожалению не имею в настоящее время) в паралельном режиме или это уже диагноз?

Share this post


Link to post
Share on other sites

А внешний клок пробовали подавать? М.б. партия ошибочно зашита на тактирование от внешнего генератора.

Share this post


Link to post
Share on other sites

Чем шьёте? Сигнатура читается?

Частоту SPI обмена попробуйте уменьшить.

Share this post


Link to post
Share on other sites

Попробую конечно, но в даташите четко указано что по дефолту включен внутренний RC-генератор

 

 

Чем шьёте? Сигнатура читается?

Частоту SPI обмена попробуйте уменьшить.

Не видит прогер чип вообще - ни сигнатура, ничего!

шью Ponyprog-ом, проггер аналогичен STK200 (на LPT, буфер 74hc244). Прикол же в состоит в том, что выкусив из платы "странный" чип и запаяв чип из другой партии ВСЕ нормально программируется и работает! Слышал как-то что бывают "гнилые" чипы распространяемые китайцами , может в этом дело?

Edited by In_vivo

Share this post


Link to post
Share on other sites

Попробую конечно, но в даташите четко указано что по дефолту включен внутренний RC-генератор

 

 

 

Не видит прогер чип вообще - ни сигнатура, ничего!

шью Ponyprog-ом, проггер аналогичен STK200 (на LPT, буфер 74hc244). Прикол же в состоит в том, что выкусив из платы "странный" чип и запаяв чип из другой партии ВСЕ нормально программируется и работает! Слышал как-то что бывают "гнилые" чипы распространяемые китайцами , может в этом дело?

atmega64 шьется по spi, но не через mosi,miso, а через uart0. смотри описание на контроллер.

 

Even though the SPI Programming interface re-uses the SPI I/O module, there is one

important difference: The MOSI/MISO pins that are mapped to PB2 and PB3 in the SPI

I/O module are not used in the Programming interface. Instead, PE0 and PE1 are used

for data in SPI Programming mode as shown in Table 128.

 

Table 128. Pin Mapping SPI Serial Programming

Symbol Pins I/O Description

MOSI(PDI) PE0 I Serial Data In

MISO(PDO) PE1 O Serial Data Out

SCK PB1 I Serial Clock

Share this post


Link to post
Share on other sites

Не видит прогер чип вообще - ни сигнатура, ничего!
Разламывать чипы пробовали? Был случай - купили цапы CS. Не работали гады. Разломали - а кристалла-то нет! Кидалово вобщем...

Share this post


Link to post
Share on other sites

atmega64 шьется по spi, но не через mosi,miso, а через uart0. смотри описание на контроллер.

 

Прикол же в состоит в том, что выкусив из платы "странный" чип и запаяв чип из другой партии ВСЕ нормально программируется и работает!

Share this post


Link to post
Share on other sites

atmega64 шьется по spi, но не через mosi,miso, а через uart0. смотри описание на контроллер.

 

Неужели вы думаете, что мы выпустив больше тысячи приборов, не знали об этом... :) И как же я их программировал?

 

 

 

Разламывать чипы пробовали? Был случай - купили цапы CS. Не работали гады. Разломали - а кристалла-то нет! Кидалово вобщем...

Идея хорошая. Разломал... Не пойму, вроде что-то есть, но на кристалл не очень похоже...Сейчас найду нормальный и тоже разломаю

 

Короче разломал два "кривых" кристалла и один нормальный -

Битые кристаллы ломаются легко, кристалл похоже наличествует, металлическая подложка со стороны "днища" (т.е. противоположной размещения самого кристалла) имеет ярко выраженный красный оттенок (очень похоже на отоженную медь)

Нормальный кристалл ломается несколько потуже, металлическая подлодка имеет выраженный серебристый оттенок, красноты практически нет.

Вывод - похоже сожженая партия ????

Share this post


Link to post
Share on other sites

Битые кристаллы ломаются легко, кристалл похоже наличествует, металлическая подложка со стороны "днища" (т.е. противоположной размещения самого кристалла) имеет ярко выраженный красный оттенок (очень похоже на отоженную медь)

Нормальный кристалл ломается несколько потуже, металлическая подлодка имеет выраженный серебристый оттенок, красноты практически нет.

Вывод - похоже сожженая партия ????

Может просто палёнка? Готовьте акт дефектации, возвращайте поставщику. Заодно поинтересуйтесь у поставщика откуда товар родом. Сравните как нанесена маркировка на нормальные чипы и на "плохие" (под микроскопом), шрифты, нет ли признаков сошлифовки тонкого слоя с корпуса (это заметно на точках, обозначающих первый вывод) какая была упаковка чипов? Напишите в атмел, выпускали ли они такую партию?

P.S. Сравните ещё "брюшки" работающих и неработающих чипов.

Share this post


Link to post
Share on other sites

Для тех кому интересно фото разломаных кристаллов.

Признаков шлифовки нет, маркировка и шрифт идеальны, вплоть до того что в двух круглых углублениях по диагонали на днище есть (можно увидеть при хорошем зрении) надписи TAIWAN и номер какой-то B8 1

Обратите внимание на выделенным желтым цветом участке фото обломки "кривого" кристалла, хорошо заметно что проводники отходящие от кристалла тоже имеют красноватый оттенок. на обломках нормального чипа (отмечено синим) все серебристое и чистое

 

Может просто палёнка? Готовьте акт дефектации, возвращайте поставщику. Заодно поинтересуйтесь у поставщика откуда товар родом. Сравните как нанесена маркировка на нормальные чипы и на "плохие" (под микроскопом), шрифты, нет ли признаков сошлифовки тонкого слоя с корпуса (это заметно на точках, обозначающих первый вывод) какая была упаковка чипов? Напишите в атмел, выпускали ли они такую партию?

P.S. Сравните ещё "брюшки" работающих и неработающих чипов.

Не подскажите, в России есть официальный офис ATMEL?

post-37775-1241260515_thumb.jpg

Edited by In_vivo

Share this post


Link to post
Share on other sites

Так а где кристаллы то? На фотографии до них не "доломано"

Share this post


Link to post
Share on other sites

Так а где кристаллы то? На фотографии до них не "доломано"

Кристаллы с обратной стороны металлических подложек, там, ИМХО, ничего интересного - кремний он и в Африке кремний, тем более он раскололся при ломке.

Share this post


Link to post
Share on other sites

Не подскажите, в России есть официальный офис ATMEL?

По меньшей мере две канторы

www.atmel.ru

www.efo.ru

имеют какое то отношение к Атмел. Вы перед тем, как все их расколотить серийные номера запишите.

ЗЫ, это одна и таже кантора :)

Share this post


Link to post
Share on other sites

Не видит прогер чип вообще - ни сигнатура, ничего!

шью Ponyprog-ом, проггер аналогичен STK200 (на LPT, буфер 74hc244). Прикол же в состоит в том, что выкусив из платы "странный" чип и запаяв чип из другой партии ВСЕ нормально программируется и работает! Слышал как-то что бывают "гнилые" чипы распространяемые китайцами , может в этом дело?

....

А на "гнилой" понипрог не подумали?

 

Чем чипы ломать, купите нормальный программатор вначале. У m64 к тому же есть JTAG, через него подключались?

Диву даюсь. Как ломать 3 чипа по 5$ каждый, деньги есть. А как купить программатор, да хотя бы AVR-Dragon за 50$ так нет.

 

Обратите внимание, ни один обладатель SKT500 ни разу не создавал тему, о том что что-то не программируется. Зато у почитателей Ponyprog'а такая тема регулярно появляется.

Share this post


Link to post
Share on other sites

....

А на "гнилой" понипрог не подумали?

 

Чем чипы ломать, купите нормальный программатор вначале. У m64 к тому же есть JTAG, через него подключались?

Диву даюсь. Как ломать 3 чипа по 5$ каждый, деньги есть. А как купить программатор, да хотя бы AVR-Dragon за 50$ так нет.

 

Обратите внимание, ни один обладатель SKT500 ни разу не создавал тему, о том что что-то не программируется. Зато у почитателей Ponyprog'а такая тема регулярно появляется.

Чипы все равно выкушенные из платы были (некогда разбираться было - изделия надо отгружать), так что потери не большие. А насчет понипрога... Ну не знаю, насколько он "гнил", повторюсь, в течении 4 лет сделана масса приборов на 8515, m64, m32, m169, tiny15 (на данном чипе больше 20 000 изделий) все было запрограммировано программатором типа STK200, и никаких проблем не было. Использовался также программатор из CVAVR. Все былочетко.

Я конечно попробую прошить на STK500 в ближайшее время, но сдается мне не в проггере дело...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...