Jump to content

    
Sign in to follow this  
ecos-rtos.in.ua

Первый запуск платы

Recommended Posts

Залил на плату последние версии bootstrap и u-boot и ядро от разработчиков платы.

Файловая система на MMC.

Лог загрузки прикладываю.

Еслии кратко. то загрузка останавливается на строке

mmc0: host does not support reading read-only switch.  Assuming write-enable.                                     
mmcblk0: mmc0:d3f6 SD01G 1006080KiB                                                                               
mmcblk0: p1                                                                                                      
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended                                             
VFS: Mounted root (ext2 filesystem).                                                                              
Freeing init memory: 120K

Если подключить монитор, то на экране в углу сидит пингвин, экран черный.

 

Переменные среды

U-Boot> printenv                                                            
bootdelay=3                                                                 
baudrate=115200                                                             
ethact=macb0                                                                
serverip=192.168.0.1                                                        
ipaddr=192.168.0.10                                                         
ethaddr=04:05:fe:ed:00:18                                                   
filesize=155E88                                                             
bootcmd=cp.b 0xD0042000 0x22200000 0x200000                                 
bootargs=console=ttyS0,115200 root=/dev/mmcblk0p1 rw rootdelay=10 mem=64M   
stdin=serial                                                                
stdout=serial                                                               
stderr=serial                                                               
rootfstype=ext2                                                             

Environment size: 299/16892 bytes

log.txt

Share this post


Link to post
Share on other sites

Пытаюсь поднять сеть.

Симптомы:

Net:   macb0
macb0: Starting autonegotiation...
macb0: Autonegotiation complete
macb0: link up, 100Mbps full-duplex (lpa: 0xcde1)
Hit any key to stop autoboot:  0
Wrong Image Format for bootm command
ERROR: can't get kernel image!
U-Boot> tftpboot 22200000 u.bin
macb0: link up, 100Mbps full-duplex (lpa: 0xcde1)
Using macb0 device
TFTP from server 192.168.0.1; our IP address is 192.168.0.101
Filename 'u.bin'.
Load address: 0x22200000
Loading: T T T T

 

Куда копать?

Связь с компом через кроссовый кабель.

Пинг компа также не проходит.

На изменение скорости 10/100 плата реагирует.

Edited by ecos-rtos_in_ua

Share this post


Link to post
Share on other sites

Запустил звук. Но скорость воспроизведения в два раза больше. Чем это может быть вызвано (есть подозрения на отличия в master clock: у меня 99, у автора 49 МГц)?

В конфиге bootstrap пробовал менять #define MASTER_CLOCK (198656000/4) - не загружаеться :(.

Share this post


Link to post
Share on other sites

Пытаюсь запустить звук.

Ядро и root_fs от разработчиков платы.

 

[root@siberia home]# mpg123 -v 01.mp3

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3

version 0.66; written and copyright by Michael Hipp and others

free software (LGPL/GPL) without any warranty but with best wishes

 

Playing MPEG stream 1 of 1: 01.mp3 ...

Title: Summer Kisses Artist: C. C. CATCH

Comment: http://xx-centurys-gold.nnm.

http://xx-centurys-gold.nnm.ru/

Album: Super 20

Year: 1989 Genre: Pop

MPEG 1.0, Layer: III, Freq: 44100, mode: Stereo, modext: 0, BPF : 1044

Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0.

Bitrate: 320 kbits/s Extension value: 0

initialize_device(): cannot set hw params

audio: Invalid argument

 

[root@siberia home]# ls /proc/asound/

AT73C213@ card0/ cards devices oss/ pcm seq/ timers version

 

[root@siberia home]# cat /proc/asound/devices

0: [ 0] : control

1: : sequencer

16: [ 0- 0]: digital audio playback

33: : timer

 

Ядро карту видит, но плейер вылетает с ошибкой.

Share this post


Link to post
Share on other sites
Пытаюсь запустить звук.

Ядро и root_fs от разработчиков платы.

А какое ядро 2.6.27 или 2.6.24? А то уменя звук работал (правда с удвоенной скоростью) пока только на 2.6.24, к которому патчев нет в наличии.

Share this post


Link to post
Share on other sites
А какое ядро 2.6.27 или 2.6.24? А то уменя звук работал (правда с удвоенной скоростью) пока только на 2.6.24, к которому патчев нет в наличии.

 

sh-3.2# uname -r

2.6.27

 

sh-3.2# cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.17.

 

Интересно узнать - а у самих авторов платы mpg123 работал ?

И если да, то может я что-то не так делаю ?

Share this post


Link to post
Share on other sites
sh-3.2# uname -r

2.6.27

 

sh-3.2# cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.17.

 

Интересно узнать - а у самих авторов платы mpg123 работал ?

И если да, то может я что-то не так делаю ?

для версии ядра 2.6.27 не работает

Share this post


Link to post
Share on other sites

Сеть и ядро 2.6.27:

 

sh-3.2# uname -r

2.6.27

 

sh-3.2# dmesg | grep eth0

eth0: Atmel MACB at 0xfffc4000 irq 21 (00:32:18:9a:12:02)

eth0: attached PHY driver [Davicom DM9161A] (mii_bus:phy_addr=ffffffff:00, irq=-1)

eth0: link up (100/Full)

 

sh-3.2# ping -c 4 192.168.0.21

PING 192.168.0.21 (192.168.0.21): 56 data bytes

64 bytes from 192.168.0.21: seq=0 ttl=64 time=2008.343 ms

64 bytes from 192.168.0.21: seq=1 ttl=64 time=1001.916 ms

64 bytes from 192.168.0.21: seq=2 ttl=64 time=1.151 ms

 

--- 192.168.0.21 ping statistics ---

4 packets transmitted, 3 packets received, 25% packet loss

round-trip min/avg/max = 1.151/1003.803/2008.343 ms

 

Подумываю об откате на 2.6.22 или какую другую.

Под 2.6.22 сеть работает.

Ни у кого нет патчей под эти ядра ?

Разработчикам платы писал, но безуспешно.

Share this post


Link to post
Share on other sites
Сеть и ядро 2.6.27:

--- 192.168.0.21 ping statistics ---

4 packets transmitted, 3 packets received, 25% packet loss

round-trip min/avg/max = 1.151/1003.803/2008.343 ms

У меня 2.6.27 и пинг проходит

 

# ping -c 4 192.168.0.1

PING 192.168.0.1 (192.168.0.1): 56 data bytes

64 bytes from 192.168.0.1: seq=0 ttl=64 time=0.958 ms

64 bytes from 192.168.0.1: seq=1 ttl=64 time=0.350 ms

64 bytes from 192.168.0.1: seq=2 ttl=64 time=0.349 ms

64 bytes from 192.168.0.1: seq=3 ttl=64 time=0.696 ms

 

--- 192.168.0.1 ping statistics ---

4 packets transmitted, 4 packets received, 0% packet loss

round-trip min/avg/max = 0.349/0.588/0.958 ms

 

Правда вместо at91_twi стоит i2c_gpio, так как

 

This driver is BROKEN because the controller which it uses

will easily trigger RX overrun and TX underrun errors. Using

low I2C clock rates may partially work around those issues

on some systems. Another serious problem is that there is no

documented way to issue repeated START conditions, as needed

to support combined I2C messages. Use the i2c-gpio driver

unless your system can cope with those limitations.

Share this post


Link to post
Share on other sites
Езернет работает, только есть newанс при работе с видео езерпакеты пролетают через один.

Попробуйте переключиться на i2c_gpio.

Share this post


Link to post
Share on other sites

Кто то уже работал с этой платой на новых ядрах (2.6.32, 2.6.33-rc8)? Интересует, работает ли звук, видео.

 

У меня на ядре 2.6.33-rc8 (без патчей от maxim.org и с выборочными патчами от siberia 2.6.27) в данный момент работает RTC, eeprom, ethernet, pcf8574a, ics1523, nand. Не работает звук и пока видео.

 

TLV320AIC23B (c драйвером at73c213) в списке устройств ALSA есть, устройство dsp есть, alsamixer позволяет настроить громкость, но при проигрывании mp3 mplayer-ом в наушиках тишина. Версия alsa 1.0.21.

 

В ядре обновился видеодрайвер, появилась поддержка bitblt. Накладываю патч на board- файл от 2.6.27 - вызова драйвера нет, в консоли ошибок не отображаеться и как результат видео не работает.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this