Jump to content

    
Sign in to follow this  
dmitry-rf

AT91RM9200. Пропадают пакеты eth

Recommended Posts

Есть плата на AT91RM9200. По сути - переразведённый AT91RM9200-DK c phy RTL8201. К плате подключен gsm модуль Siemens MC75, установлен linux. Система работает нормально, pppd дозванивается до провайдера и устанавливает соединение.

Неприятность такая - как только ppp соединение установлено, начинают теряться eth пакеты между платой и компьютером (возможно, пакеты начинают теряться еще при открытии ком-порта и дозвоне). Убиваешь pppd - потери пропадают, все пинги проходят. Таблица роутов выглядит нормально.

Есть аналогичная чужая плата, на ней та же сборка линукса в тех же условиях работает без проблем. Таблицы маршрутизации после дозвона совпадают. Схема чужой платы неизвестна, но это тоже модифицированный кит AT91RM9200-DK.

В чём может быть ошибка? Нецжели уарт как-то может влиять на ethernet?

Share this post


Link to post
Share on other sites

GSM излучает до 1 - 1.5 ВТ в эфир, если антена близко от платы, то это может влиять на микрухи. Запусти на компе WireShark или tcpdump и посмотри что приходит от платы.

Share this post


Link to post
Share on other sites

GSM вряд ли на что-то влияет. Антана от платы далеко, да и пакеты, кажется, начинают пропадать уже при открытии порта ppp демоном (но это пока не ясно на 100%). Система представляет собой пирожок: Сверху платка с армом (проц, память, флэш, физика, eth-транс), снизу - gms-модуль. Посередине основная плата с разъёмами и источником питания. Чужая плата - такой же арм-модуль, как и моя. Соответственно, находится в тех же условиях, но работает без сбоев.

Wireshark запускал - показывает то же, что и ping: запрос-ответ, запрос без ответа, запрос-ответ....

Прошивка используется одна и таже, а платы разные. Т.о. я склоняюсь к тому, что проблема аппаратная, но ума не приложу, чем она может быть вызвана.

+++

Запустил pppd не указав логин-пароль. Соответственно, соединение не устанавливается. Пакеты пропадают. Значит, дело именно в какой-то связи ком-порта и эзернета.

Edited by dmitry-rf

Share this post


Link to post
Share on other sites

Есть такое с питанием. У меня GSM передатчик очень сильно просаживал питание в момент передачи.

А на счет связи COM-порта и ethernet - запусти ppp на другом порту, там где нет GSM-передатчика. Можно просто в холостую запустить или с компом связать. Узнаешь точно: это лажа от СОМ-порта или от GSM.

Share this post


Link to post
Share on other sites

Спасибо за подсказки, но ситуация разрешилась весьма необычным образом: виноват оказался чип phy RTL8201BL. Похоже, предприимчивые китайцы продали отбраковку. Замена на аналогичный чип из другой партии решила все проблемы. Видимо, только отсутствие помех по питанию или эфиру позволяло некондиционной микросхеме нормально работать.

Edited by dmitry-rf

Share this post


Link to post
Share on other sites

Рано радовался. Сложилась очень интересная ситуация.

Есть три чипа RTL8201BL из разных партий: 1-й работает без проблем, 2-й теряет 30-50% пакетов, 3-й при включении gsm лежит совсем.

Есть две платы - чужая и аналогичная ей наша разработка. Вышеупомянутые проблемы наблюдаются на нашей плате. На чужой 1 и 2 чипы работают стабильно. 3-й не пробовал да и без него ясно, что есть косяк в нашей плате. Но и чипы различаются.

В даташите подключение RTL8201BL подробно не описано. В частности, нет рекомендаций по подключению трансформатора. Есть у кого-нить работающая схема с этим чипом? Буду очень благодарен за схему.

Взаимосвязь уарта и eth проверяется...

Share this post


Link to post
Share on other sites
Есть у кого-нить работающая схема с этим чипом? Буду очень благодарен за схему.

У Реалтека есть Reference Schematics.

sch_8201bl_120_.zip

 

Взаимосвязь уарта и eth проверяется...

Не тратьте напрасно время.

Share this post


Link to post
Share on other sites
В даташите подключение RTL8201BL подробно не описано. В частности, нет рекомендаций по подключению трансформатора. Есть у кого-нить работающая схема с этим чипом? Буду очень благодарен за схему.

Взаимосвязь уарта и eth проверяется...

Почему у них сайте была схемка отладочной платы, она аналогична вот этой :

http://www.ucrouter.ru/download/evm9200-sch.pdf

 

у клиента была похожая проблемка он подключал по ком порту модуль gprsный но проблемма у него была

в том что на компортовый драйвер не поддерживал управление потоком и пакеты у него там терялись.

Он, точнее она ;-) как с модемными сигналами разобралось, все пришло в норму. Точно пакеты у Вас теряются на ethernete?

Edited by dch

Share this post


Link to post
Share on other sites
У Реалтека есть Reference Schematics.

Спасибо. Нашёл 2 отличия:

- неправильно соединённые средние точки трансформаторов. Сделал как в референсе - потери упали до 8-9%

- нет конденсаторов на ногах питания. Возможно, это причина остальных потерь, хотя я не уверен. GSM-модуль и ARM-модуль питаются от одной линии 12 В, но через раздельные регуляторы на базе L5973. У каждого регулятора на выходе дроссель и конденсатор. Плата АРМа шестислойная, два слоя - 3.3 В и земля, что даёт большой конденсатор.

 

у клиента была похожая проблемка он подключал по ком порту модуль gprsный но проблемма у него была

в том что на компортовый драйвер не поддерживал управление потоком и пакеты у него там терялись.

Он, точнее она ;-) как с модемными сигналами разобралось, все пришло в норму. Точно пакеты у Вас теряются на ethernete?

Точно - яндекс пингуется с роутра без проблем. А вот пакеты между роутером и компьютером теряются.

Edited by dmitry-rf

Share this post


Link to post
Share on other sites
- нет конденсаторов на ногах питания. Возможно, это причина остальных потерь, хотя я не уверен.

Вообще нет?

 

Плата АРМа шестислойная, два слоя - 3.3 В и земля, что даёт большой конденсатор.

Большой конденсатор с очень маленькой емкостью.

Share this post


Link to post
Share on other sites
Вообще нет?

На ногах питания физики нет ни одного. Пробовали повесить их при неправильном подключении средних точек транса - заметных изменений не было. Попробую поставить, но смоневаюсь, что это что-то даст.

AVDD и PWFBIN/PWFBOUT подключены согласно референсу.

Share this post


Link to post
Share on other sites
Пробовали повесить их при неправильном подключении средних точек транса - заметных изменений не было.

для RTL8201BL - на одной средней точке конденсатора быть не должно, а так должно работать особенных проблемм не заметно. А у Вас проблемы с ethernet-ом на 10 И 100 мбитах?

Share this post


Link to post
Share on other sites
для RTL8201BL - на одной средней точке конденсатора быть не должно, а так должно работать особенных проблемм не заметно. А у Вас проблемы с ethernet-ом на 10 И 100 мбитах?

Сейчас конденсатор на землю есть только на средней точке RX. Проблемы только на 100 Мбит.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this