Jump to content

    
Sign in to follow this  
unit900

Cadence IC - вопросы к использующим

Recommended Posts

Лучший вариант обучиться - сделать какую-нибудь простенькую схемку самому. У кэденса довольно толковый мануал.

На фтп помнится были обучающие мануалы.

Спасибо большое, есть небольшой дополнительный вопрос - на ФТП какого сайта? Если можно и не сложно - дайте ссылку.

Share this post


Link to post
Share on other sites
Спасибо большое, есть небольшой дополнительный вопрос - на ФТП какого сайта? Если можно и не сложно - дайте ссылку.

 

На местном фпт ftp://ftp.electronics-portal.org/pub/DOC/Cadence

Share this post


Link to post
Share on other sites

IC 6.1.5

Есть ли возможность сделать так, чтобы при открывании окон, например со схемой, в них не появлялись вкладки слева "Navigator", "Property Editor" итд, а заодно и снизу - "Mouse bar"?

Подозреваю что что-то можно дописать в .cdsenv и/или .cdsinit, пробовал искать в документации - не нашел...

Share this post


Link to post
Share on other sites

Можно :-) модифицируете рабочую область для себя, потом

Window->Workspaces->Save As

в поле введите имя, например My Basic

потом Window->Workspaces->Set Default

и выбираете там My Basic.

настройки рабочей области будут распространены на все открываемые схемы.

Share this post


Link to post
Share on other sites

Есть еще вопрос про IC 6.X.

В версиях 5.X был доступен waveform tool с названием awd. В нем можно было перерасположить трассы как удобно, добавить прямо к графикам какие-то численные значения (через annotate), все это прекрасно сохранялось в стэйте ADE (waveform setup), а потом успешно загружалось из сохраненного. Теперь в IC 6.X waveform viewer поменялся (ViVA) и, хотя фича сохранения состояния вьювера в стэйт работает, но при загрузке стэйта состояние экрана не восстанавливается и при рефреше вьювера не сохраняется. Это так и надо, или я чего-то не заметил?

Share this post


Link to post
Share on other sites

Если стоит галочка при сохранении стэйта Waveform Setup все метки, подписи и состояния выводимых графиков сохраняются.

При загрузке стэйта они подгружаются если стоит галочка напротив Waveform Setup.

При моделировании, после обновления графиков, все метки исчезают(подписи(Label) остаются). мне кажется это баг, так как в области Display bar на тех местах видны "метки" наличия меток на графиках. Единственный способ который мне помогает, это в окне ADE под формой Outputs выбрать Plot after simulation:Refresh

Share this post


Link to post
Share on other sites

Нашел как сделать чтобы оставляло трассы так, как разместил руками. В ADE, во вкладке "Plot after simulation" нужны выбрать "Refresh".

post-28262-1362662239_thumb.png

 

PS. Правда пока не нашел как сделать, чтобы такой режим был по умолчанию при старте кэденса.

Share this post


Link to post
Share on other sites
PS. Правда пока не нашел как сделать, чтобы такой режим был по умолчанию при старте кэденса.

.cdsenv надо править

Что-то вроже строчки:

 

asimenv.plotting artistPlottingMode string "Append"

 

Это правда для пятёрки. Шестой версии под руками пока нет. Как доберусь подскажу если сами раньше не разберётесь.

 

Попробуйте вот это

 

asimenv.plotting autoPlot cyclic "Refresh"

Edited by MayskiyJuk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this