Jump to content

    

Ошибки работы Altium Designer

Работает ли PCB->File->Export->PDF 3D ?

Я экспортирую свою плату, файл получается всего 1.6МБ.

Просматриваю в Adobe Acrobat Reader - пустота

Просматриваю в Adobe Acrobat - 3D data parsing error has occured

В 17 и 16 работает- единственный кривой момент который сильно раздражает, так это то что невозможно в 3д пдф отключать медь послойно, а не по нетлисту. У вас настройки экспорта какие?

Share this post


Link to post
Share on other sites
Работает ли PCB->File->Export->PDF 3D ?

Я экспортирую свою плату, файл получается всего 1.6МБ.

Просматриваю в Adobe Acrobat Reader - пустота

Просматриваю в Adobe Acrobat - 3D data parsing error has occured

 

А если присмотреться к окну открытого в Акробате файла - в верхней части под меню нет запроса на разрешение 3Д контента?

Share this post


Link to post
Share on other sites

Доброго времени суток коллеги.

У меня с Альтиумом произошел какой то не понятный сбой после которого он перестал нормально генерить перечни.

При попытке сгенерить перечень выдается ряд следующих сообщений:

 

"unknown string expression - Formula"

1_1.jpg

 

"Error syntax in string expression"

2_2.jpg

 

Перечень при этом создается но часть информации теряется.

Пробовал полностью переустанавливать Альтиум и Офис с чисткой реестра, но не помогло... На другом компе этаже версия Альтиума и Офиса прекрасно работают и корректно создают BOM-ы.

Если кто-то сталкивался с подобным, подскажите пожалуйста как решили этот глюк.

Спасибо.

Share this post


Link to post
Share on other sites

Добрый день. Решил попробовать отмоделировать некоторый цепи на плате с помощью Signal Integrity и при попытке построить графики(Reflected waveforms) выдаёт ошибку Unexpected Error occured in simulation. Сталкивался кто с этим и можно ли что-то сделать?

Share this post


Link to post
Share on other sites

Подскажите При экспорте композитного гербер файла, Altium 17 вылетает

Share this post


Link to post
Share on other sites

UPD: решено.

 

 

И снова здравствуйте.

Давно не заходил, но вот пришлось....

 

Мой любимый бермудский треугольник- многовариантные проекты.

Вроде все шло хорошо, но сегодня начал чудить Альтий.

 

Имеем:

1. Проект, схемы плата.

2. Прицепленные к нему, его личные SchLib и PcbLib. Обычно юзаю DataBaseLib, но тут, чтоб ничего не напутать, сделал отдельные, чисто для изделий(трансформаторы) применяемых именно в этом проекте. к УГО в SchLib прикреплены Footprints из лежащей рядом библиотеки.

3. Имеем 10 исполнений одного и того-же изделия.

Из них:

а) 5 исполнений с трансформаторами, имеющими ОДИНАКОВЫЕ УГО (только параметры внутри УГО разные), и общий Footprint #1.

б) 5 исполнений с трансформаторами, имеющими ОДИНАКОВЫЕ УГО (только параметры внутри УГО разные), и общий Footprint #2.

 

Прописываем все в редакторе вариантов, делаем апдэйт.

Первые 5 исполнений, при переносе на плату, имеют ОДИН общий Footprint, т.е. так, как и должно быть. Т.е. футпринт один, информация при выводе на монтажки разная. Все правильно.

А вот следующие 5 исполнений, при переносе на плату- дают ПЯТЬ однотипных трансформаторовов связанных веревками за одноименные пины.

Перепроверял уже все, что можно перепроверить. Перезагружал, ничего не помогает.....

 

 

Че может быть? Проект могу дать побаловаться.

 

 

ЗЫ: еще боле странное поведение.

Борясь с проблемой, я сделал универсальный футпринт, все в той-же библиотеке, что паровозиком прицеплена к проекту.

В SchLib я натравил все УГО на один и тот-же футпринт. Ну думаю, так точно полетит.

Дальше на схеме делаю Update form Libraries, типа все обновил, переношу на плату, бац, старые футпринты.

Ладно....

Пошел в менеджер вариантов.

Для каждого варинта, для этих долбанных трансформтаторов, выбираю uUpdate paremeters from libraies, показываю мол чего надо выбрать, жду, что он поменяет футпринт.. а нифига.....

 

Чет прореха какая-то с менеджером вариантов в альтиуме....

 

 

Edited by Sanchosd

Share this post


Link to post
Share on other sites
UPD: решено.

 

ЗЫ: еще боле странное поведение.

Борясь с проблемой, я сделал универсальный футпринт, все в той-же библиотеке, что паровозиком прицеплена к проекту.

В SchLib я натравил все УГО на один и тот-же футпринт. Ну думаю, так точно полетит.

Дальше на схеме делаю Update form Libraries, типа все обновил, переношу на плату, бац, старые футпринты.

Ладно....

Пошел в менеджер вариантов.

Для каждого варинта, для этих долбанных трансформтаторов, выбираю uUpdate paremeters from libraies, показываю мол чего надо выбрать, жду, что он поменяет футпринт.. а нифига.....

 

Чет прореха какая-то с менеджером вариантов в альтиуме....

Несовпадение названий PAD в установленном на PCB варианте (он из старой библиотеки) с новой версией.

Поэтому заменить не может.

Удалите из PCB -- Новый из библиотеки вставит.

Потом

просто переместите новый на старое место

Share this post


Link to post
Share on other sites
Несовпадение названий PAD в установленном на PCB варианте (он из старой библиотеки) с новой версией.

Поэтому заменить не может.

Удалите из PCB -- Новый из библиотеки вставит.

Потом

просто переместите новый на старое место

 

Пробовал, само собой....Ну видать QA в Altium'e не заморачивается вариантными проектами)))))

 

 

Наверное все сталкиваются с тем, что при нажатии какой-то магической комбинации клавиш Альтий перестает отображать "веревки" в PCB редакторе.

Что нажал неизвестно, гугл не помогает.

пересмотрел все галки в меню вид, и в меню "L", ничего путнего не нашел.

 

Share this post


Link to post
Share on other sites
Пробовал, само собой....Ну видать QA в Altium'e не заморачивается вариантными проектами)))))

Да если варианты исполнений делаются правильно-- то и с этим нет проблем.

Просто инструментарий работы с вариантами исполнений желает лучшего.

Share this post


Link to post
Share on other sites
Наверное все сталкиваются с тем, что при нажатии какой-то магической комбинации клавиш Альтий перестает отображать "веревки" в PCB редакторе.

Что нажал неизвестно, гугл не помогает.

пересмотрел все галки в меню вид, и в меню "L", ничего путнего не нашел.

Нажали скорее всего V->C->H

Попробуйте V->C->S

 

Share this post


Link to post
Share on other sites
Нажали скорее всего V->C->H

Попробуйте V->C->S

 

Спасибо тебе добр. человек!!!!

Ох.. каждый новый релиз преподносит новые сюрпризы))))

 

Share this post


Link to post
Share on other sites
Ох.. каждый новый релиз преподносит новые сюрпризы))))

Да вроде указанные операции работают 100 лет

Share this post


Link to post
Share on other sites

Добрый день.

 

Сегодня столкнулся с проблемой краша Алтиума 16.0.6 при компиляции библиотеки.

 

На УГО (1-й скриншот) изменены только шрифты имени пинов.

Футпринт - стандартный SOT23-5 сделанный с помощью мастера. Добавлен 3D-корпус из файла.

 

Во время компиляции программа падает на запуске модуля signal integrity (2-й скриншот).

 

Так же параллельно скомпилировал эту же библиотеку в 13-й версии, где всё прошло успешно.

 

В чём может быть проблема?

 

post-99860-1508612265_thumb.png

 

post-99860-1508612281_thumb.png

Share this post


Link to post
Share on other sites
Добрый день.

 

...

В чём может быть проблема?

 

например, шрифты

Share this post


Link to post
Share on other sites

Здравствуйте, уважаемые разработчики!

Я пришел к вам с вопросом. Хочу поменять систему единиц измерений в Altium. Для чего иду по пути Tools - Document options - Units. По идее, я могу выбирать между метрической и имперской системами. Но у меня по умолчанию стоит вторая, и я не могу поменять ее на первую.

Как мне быть? Очень нужна ваша помощь. Спасибо.

 

0b1f5c003b6d98b6239940e80f0dda74.png

Edited by MetalLunchBox

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now