Jump to content

    
Sign in to follow this  
inter_pro

Ошибки работы Altium Designer

Recommended Posts

Наблюдаю некорректное поведение редактора посадочных мест.

Если после загрузки библиотеки посадочных мест перейти из 2D в 3D то по возвращению в 2D редактор "включает" слои защитных масок, трафаретов и слоев для сверления. Повторно эффект не проявляется. Версия AD - 14.3.14, но вроде и предыдущие были замечены в этом.

Судя по всему необходимо везде проверить сохранение предыдущих настроек. AD уже давненько страдает ЧАСТИЧНОЙ "потерей памяти" :biggrin:

Смотря как заходите и выходите.

если через меню--- оно возвращается не к предыдущему, а к сохраненному в настройках

Share this post


Link to post
Share on other sites

В последних версиях AD заметил следующий баг.

Если сразу после старта AD попробовать обратиться к панели "Libraries", то в каком-то "сервере" случается висяк и как следствие окошко с ошибкой. Судя по всему причинами являются - библиотеки на основе БД и незапущенные "сервера" редакторов схемы и платы.

Лечится закрыванием и повторным открыванием панели "Libraries". Подобное поведение отсутствует если первым делом обратиться к панели "Projects" - при этом AD запускает "сервера" редакторов схемы и платы, и дальше панель "Libraries" открывается нормально.

Share this post


Link to post
Share on other sites

В версиях 14.3.13, 14.3.14 печать в smart PDF перестала растягивать изображение на целый лист. Кто-нибудь знает почему? Настроенные в предыдущих версиях outjob

печатаются уменьшенными.

Share this post


Link to post
Share on other sites
В версиях 14.3.13, 14.3.14 печать в smart PDF перестала растягивать изображение на целый лист. Кто-нибудь знает почему? Настроенные в предыдущих версиях outjob

печатаются уменьшенными.

Это потому что отныне

Цитата(Владимир @ Sep 12 2014, 21:07)

PDF не является нормирующим устройством

 

Share this post


Link to post
Share on other sites
Выберите режим Scale mode который не Fit

 

В моем случае, использование строго масштаба не помогло. Шаблон документа А4, делаешь масштаб 1.1 сразу на два листа разбивает, с масштабом по ширине листа печатает как на рисунке.

Если открыть напечатанный документ в PDF редакторе то видно за границами шаблона много скрытых элементов типа comment. они почему то смещены далеко от компонентов на схеме. Откуда эти штуки берутся не знаю.

Установил я заново 14.3.14, все предыдущие настройки альтиума стер и перезагрузился. Сегодня печатает как и раньше - ХОРОШО!

 

Спасибо за ответы, рисунок со скрытыми коментами прилагаю.

post-28570-1412364472_thumb.jpg

Share this post


Link to post
Share on other sites
В моем случае, использование строго масштаба не помогло. Шаблон документа А4, делаешь масштаб 1.1 сразу на два листа разбивает, с масштабом по ширине листа печатает как на рисунке.

Если открыть напечатанный документ в PDF редакторе то видно за границами шаблона много скрытых элементов типа comment. они почему то смещены далеко от компонентов на схеме. Откуда эти штуки берутся не знаю.

Установил я заново 14.3.14, все предыдущие настройки альтиума стер и перезагрузился. Сегодня печатает как и раньше - ХОРОШО!

 

Спасибо за ответы, рисунок со скрытыми коментами прилагаю.

Разбивает на 2, потому как малые поля от края (по ГОСТ) не поддерживает принтер.

То, что есть за пределами листа--- библиотеки нужно делать так, чтоб параметры не выходили за пределы контура компонента.

 

Эти штуки берет, так как включена опция добавления параметров в PDF. В настройках можно фичу отключить

Share this post


Link to post
Share on other sites

Я правильно понимаю, что скриншот ниже, это откровенный баг:

post-4480-1412625221_thumb.png

 

Не знаю, писали об этом или нет, но лучше наверное повторить - при включенном режиме трассировки Head Up Display "просвечивает" во всех открытых окнах.

Share this post


Link to post
Share on other sites
Я правильно понимаю, что скриншот ниже, это откровенный баг:

 

Не знаю, писали об этом или нет, но лучше наверное повторить - при включенном режиме трассировки Head Up Display "просвечивает" во всех открытых окнах.

Гм. как это получилось? Я не смог воспроизвести, хотя Head Up Display всегда включен

Share this post


Link to post
Share on other sites

Да как обычно, ничего не делал - включил режим трассировки и переключился в другую программу - все, оказалось достаточно:)

Собственно первый раз заметил, когда делал скриншот и был режим трассировки. Проверил - в любой программе видно этот дисплей.

Оно конечно можно сказать - зачем переключаться в что-то еще, когда ведешь дорожку, но странно это...

 

Если что: Win7 Home Premium 64(все актуальные апдейты на данный момент стоят), DirectX 10(деталей пока не нашел, но если апдейты и были, то тоже должны быть установлены), Geforce 650Ti + Driver 320.49

Share this post


Link to post
Share on other sites
Да как обычно, ничего не делал - включил режим трассировки и переключился в другую программу - все, оказалось достаточно:)

Собственно первый раз заметил, когда делал скриншот и был режим трассировки. Проверил - в любой программе видно этот дисплей.

Оно конечно можно сказать - зачем переключаться в что-то еще, когда ведешь дорожку, но странно это...

 

Если что: Win7 Home Premium 64(все актуальные апдейты на данный момент стоят), DirectX 10(деталей пока не нашел, но если апдейты и были, то тоже должны быть установлены), Geforce 650Ti + Driver 320.49

А отловил. Да есть такое. Просто мне в голову не приходило зачем переключаться в другую программу, когда активное действие не завершено.

Наверное баг. Или не должно давать переключаться в таком режиме (но это винда переключает), или завершать активное действие в алтиуме, или приоритет у этого окна не выше всех, а только выше окна PCB/

Share this post


Link to post
Share on other sites

Мне вот интересно, баг с подсвечиванием портов в последних версиях Альтиума вообще собираются исправить или нет?

 

Одному Богу известно, при каких условиях альтиум в схематике решает подсветить цепь, а при каких нет. Часто случается такое что переходишь на лист с главного листа, курсор стоит на нужном порту, а при этом подсвечивается тот что был выбран до этого или вовсе никакого. Хотя иногда работает правильно.

 

Мягко говоря неудобно, когда в панели PCB выбираешь компонент, с целью найти его на плате, а он не подсвечивается. В чём вообще смысл панели PCB, если элементарный функционал не работает. Приходится использовать Cross Select, чтобы выбрать компонент в схематике и увидеть его на плате, что не всегда удобно. Наведение на компонент при выборе в панели PCB работает мягко говоря криво, наводя непонятно на что.

 

Всё это в версиях 14.3.14 и 14.3.15.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this