Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka

Recommended Posts

Уря, перепаял мегу заработало сразу.

естьопять одна проблемка: тервинал виснет при попытке обращения.

Share this post


Link to post
Share on other sites
Уря, перепаял мегу заработало сразу.

естьопять одна проблемка: тервинал виснет при попытке обращения.

что за терминал? какие его настройки?

Share this post


Link to post
Share on other sites

виндозовский

настроки стандартные, кроме скорости-11500

Share this post


Link to post
Share on other sites
виндозовский

настроки стандартные, кроме скорости-11500

Надо ещё отключить "аппаратный контроль потока"

 

P.S.

Прикладываю инструкцию для Виндового гипертерминала.

P.P.S.

Напоминаю: если вы собирали программатор на mega48, то в нём отсутствует терминальный режим.

hyperterm.pdf

Share this post


Link to post
Share on other sites
Надо ещё отключить "аппаратный контроль потока"

вот этого вообще нигде не читал :1111493779:

 

итс ок.

 

 

 

еше один писоеденился к армии :smile3046:

post-52456-1255203995_thumb.jpg

Edited by dr_jenia

Share this post


Link to post
Share on other sites
вот этого вообще нигде не читал :1111493779:

На 15 странице.

Share this post


Link to post
Share on other sites

Уважаемый автор не могли бы выложить последний актуальный на сегодня пакет файлов программатора.

Share this post


Link to post
Share on other sites
Уважаемый автор не могли бы выложить последний актуальный на сегодня пакет файлов программатора.

В самом первом посте.

Share this post


Link to post
Share on other sites
В самом первом посте.

Так на стр.16 примерно встречался доработанный вариант еще.

Share this post


Link to post
Share on other sites
Так на стр.16 примерно встречался доработанный вариант еще.

Модераторами свежие прошивки были перенесены в первый пост.

Share this post


Link to post
Share on other sites

Приветствую, Petka!

 

С неделю назад спаял программатор, засамопрограмил, а видеть подключенный к ISP МК (Мега8) пони програмить и читать отказывается! Светодиод отмигивает при вкл. 5 раз. при подклю таргета - загорается .. и всё. По Моему, никаких сигналов из прогера на таргет не идёт. Пайка качественная. Резюки перепроверил, замыкания/обрывы вроде отсутствуют.

Схема на FT232BL (По ДШ то-же, что и BM, только "Lead Free"??)+ATMega8 16AU. Кварц на 14.745(привезли недавно под заказ на 14.7456)

Более подробно о проблеме + доп. инфа - на робофоруме(этот в это время лежал). Ссылка:

Робофорум. Мой прогер.

 

Уже не знаю, что подозревать... Всё вроде ок...

...Вобщем, HELP!

Share this post


Link to post
Share on other sites
Приветствую, Petka!

..............................

...Вобщем, HELP!

Из-за чрезмерного разрастания данной темы предлагаю продолжить обсуждение программатора в новой теме:

 

Продолжение темы AvrUsb500 by Petka

 

Туда я перенёс ответы на основные вопросы по программатору.

 

 

.....

а видеть подключенный к ISP МК (Мега8) пони програмить и читать отказывается!

Пони прог НЕ поддерживает "AvrUsb500 by Petka". Используйте программы, которые поддерживают stk500v2.

Например ChipBlasterAVR или avrdude.

Share this post


Link to post
Share on other sites

Урраа! Заработалооо! (с) Матроскин ;)

Точно! Запустил под КодВижнАВР - прочитала всё с Тиньки 2313 без проблем!

Проблема была в запуске через Пони и в макетке для Меги8 - она не читается. Буду смотреть, в чём дело - видимо, где-то ошибка.

..ИМХО дезориентирует то, что из Пони проводится самопроганье девайса, а програмить внешние МК из Пони уже нельзя.

...Спасибо, Петка!

..Кстати, проблема решилась после перепрошивки 6й версией. Сигналы появились, и пр.

Всем удачи!

Share this post


Link to post
Share on other sites
Из-за чрезмерного разрастания данной темы ...

Скажите (в личке) какие посты грохнуть\скрыть и тема сильно похудеет.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this