Jump to content

    
Sign in to follow this  
Petka

AvrUsb500 by Petka

Recommended Posts

Может вопрос и не по теме.Я лазил в поисках USB программатора и набрел на этот форум и даже зарегистрировался чтоб скачать.Два твоих файла которых ты прикрепил я скачал ,а вод третий оно скачивает как файл PHP сможешь сказать как скачать твой третий файл ?

странно.

 

попробуйте тут: http://swordgreenline.narod.ru/Pony/Petka_..._SRC_v6_uni.zip

http://swordgreenline.narod.ru/Pony/PetkaDocs.zip

Share this post


Link to post
Share on other sites

Всем привет. Вот и я решил собрать программатор от Пети. Собрал прошил вроде все шло по плану Прошивку использовал AvrUSB500_by_Petka_HEX_SRC_v6_uni

Значит проблемма такая прошивать еще не пробывал, решил запустить CodeVisionAVR и попробывать настроить все вот тут и насторожило меня сообщение скрины ниже. Подскажите как решить и как понять работает ли программатор? В этом деле я новичек строго не судите. Да и еще как активировать выход генератора ? Одну микросхемку запорол с фьюзами надо подправить. В предыдущих постах ничего не нашел по этому поводу. Заранее спасибо.

post-45269-1246383826_thumb.jpg

post-45269-1246383834.jpg

post-45269-1246383839_thumb.jpg

Share this post


Link to post
Share on other sites
...вот тут и насторожило меня сообщение скрины ниже. Подскажите как решить

...Да и еще как активировать выход генератора ? Одну микросхемку запорол с фьюзами надо подправить. В предыдущих постах ничего не нашел по этому поводу. Заранее спасибо.

1) Настройте CodeVision так, что бы ком порт терминалки не совпадал с компортом программатора.

2) Невнимательно читали топик. Включить выход генератора (что заметно снизит скорость программирования) можно через компорт. Настройте терминал на компорт программатора, потом два раза нажмите Enter, запросы на ввод версии программатора, на них отвечаем просто Энтером, когда доходит до опции "fast/1Mhz" говорим "1" и жмём энтер. Всё.

Share this post


Link to post
Share on other sites

Извените но не понял как запустить генератор поставил в настройке терминала COM4 а в настройках программатора COM3 на порты перестал ругаться. после того как установил COM4 на терминал надо нажимать 2 раза ENTER? почемуто не выходит никаких запросов. Объясните по шагам плиз я просто начинающий может не допонимаю чтото.

Share this post


Link to post
Share on other sites
Извените но не понял как запустить генератор поставил в настройке терминала COM4 а в настройках программатора COM3 на порты перестал ругаться. после того как установил COM4 на терминал надо нажимать 2 раза ENTER? почемуто не выходит никаких запросов. Объясните по шагам плиз я просто начинающий может не допонимаю чтото.

в настройках терминала надо выставить Baud rate 115200

Share this post


Link to post
Share on other sites

пробывал уже разные скорости результат ноль. Не могу понять мы настроили терминал после этого нажимаем 2 раза ENTER при этом у меня в окне просто смещаеться курсор на две строки и все.

post-45269-1246390174_thumb.jpg

post-45269-1246390187_thumb.jpg

Share this post


Link to post
Share on other sites
пробывал уже разные скорости результат ноль. Не могу понять мы настроили терминал после этого нажимаем 2 раза ENTER при этом у меня в окне просто смещаеться курсор на две строки и все.

Проверьте программатор по другому. Например подключите к нему AVRку и считайте сигнатуру. А то прошить то вы его прошили, но может фьюзы не выставили или что другое? Заодно посмотрите на мигание светодиода. Мне кажется это легче.

Edited by ds1307

Share this post


Link to post
Share on other sites

Всем спасибо разобрался работает отлично!!!! Спасибо Пете за отличный программатор!!!! Причина была в ерунде просто не внимательно прочитал рекомендации по прошивке и не ту перемычку кинул по завершению прошивки. Еще раз всем спасибо.

Share this post


Link to post
Share on other sites

Добрый день. Я давно работаю с этим программатором (за что очередной раз огромное спасибо Petke). Работает и в винде, и в Linux. Недавно обновил AVRStudio до версии 4.16, и теперь при старте она хочет его обновить. Нужно ли это делать или просто забить.

Share this post


Link to post
Share on other sites
Добрый день. Я давно работаю с этим программатором (за что очередной раз огромное спасибо Petke). Работает и в винде, и в Linux. Недавно обновил AVRStudio до версии 4.16, и теперь при старте она хочет его обновить. Нужно ли это делать или просто забить.

Делать этого нельзя. Однако, что-бы она больше не беспокоилась и не тревожила своими напоминаниями можно зайти терминалкой на программатор и поменять версию на бОльшую.

Share this post


Link to post
Share on other sites

Уважаемый Petka можете сообщить результаты тестирования программатора (скорость )

напримерчтонибудь такое

:\WORK\me_new\FAST_PRG_AVR\TEST\avrdude>avrdude -p m128 -c avrispv2 -Pcom2 -U

ash:w:128.hex

 

vrdude: AVR device initialized and ready to accept instructions

 

eading | ################################################## | 100% 0.02s

 

vrdude: Device signature = 0x1e9702

vrdude: NOTE: FLASH memory has been specified, an erase cycle will be performe

 

To disable this feature, specify the -D option.

vrdude: erasing chip

vrdude: reading input file "128.hex"

vrdude: input file 128.hex auto detected as Intel Hex

vrdude: writing flash (131072 bytes):

 

riting | ################################################## | 100% 11.20s

 

vrdude: 131072 bytes of flash written

vrdude: verifying flash memory against 128.hex:

vrdude: load data flash data from input file 128.hex:

vrdude: input file 128.hex auto detected as Intel Hex

vrdude: input file 128.hex contains 131072 bytes

vrdude: reading on-chip flash data:

 

eading | ################################################## | 100% 5.14s

 

vrdude: verifying ...

vrdude: 131072 bytes of flash verified

 

vrdude: safemode: Fuses OK

 

vrdude done. Thank you.

Зарание благодарен

Share this post


Link to post
Share on other sites

Пользуюсь программатором уже где-то с месяц. Ещё разок спасибо Petka. Никаких нареканий при прошивке Flash, но вот что выяснилось совсем недавно, а именно пару минут назад. EEPROM на контроллерах семейства Mega по-прежнему напрочь отказывается прошивать, а вот Tiny шьет все и даже ООООчень шустро, не чета другим вариантам программаторов. Проверил уже на Tiny12, 13, 13v, 24.

Share this post


Link to post
Share on other sites
Пользуюсь программатором уже где-то с месяц. Ещё разок спасибо Petka. Никаких нареканий при прошивке Flash, но вот что выяснилось совсем недавно, а именно пару минут назад. EEPROM на контроллерах семейства Mega по-прежнему напрочь отказывается прошивать, а вот Tiny шьет все и даже ООООчень шустро, не чета другим вариантам программаторов. Проверил уже на Tiny12, 13, 13v, 24.

чем шьёте? версия прошивки, софт?

Share this post


Link to post
Share on other sites

Прошу прощения, может где-то пропустил ответы.

Но ситуация такая. Собрал, прошил через ЮСБ с такой командной строкой

avrdude -p atmega168 -c stk500_by_petka -P \\.\com3 -i 10 -B 10 -b 9600 -U flash:w:mega168.hex -U hfuse:w:0xDC:m -U lfuse:w:0xD7:m

 

Включаю, светодиод мигает пять раз и загорается постоянно.

Коде вижен АВР не видит программатор.

Повторная перешивка через ЮСБ не получается. avrdude пишет, что АВР девайс не отвечает, а светодиод гаснет. После выдачи ошибки снова загорается.

Что делать, куда смотреть?

Edited by 11111

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this