Jump to content

    

9200EK + Linux + видеоконтролле Epson

Искал в этом форуме - не нашёл :)

Итак, кто-нибудь делал какие-нибудь действия, кроме включения драйвера Epson, чтобы заработало видео ?

Я включаю драйвер - он присутствует совершенно молча и не работает при этом. Ядро 2.6.22.

 

Есть ли какие-нибудь мысли у общественности ?

 

Спасибо.

Share this post


Link to post
Share on other sites
Искал в этом форуме - не нашёл :)

Итак, кто-нибудь делал какие-нибудь действия, кроме включения драйвера Epson, чтобы заработало видео ?

Я включаю драйвер - он присутствует совершенно молча и не работает при этом. Ядро 2.6.22.

 

Есть ли какие-нибудь мысли у общественности ?

 

Спасибо.

 

а какой именно драйвер Epson ты используеш?

может в схеме подключения косяк скрылся?

 

.

Share this post


Link to post
Share on other sites
а какой именно драйвер Epson ты используеш?

может в схеме подключения косяк скрылся?

Подключаю стандартный, что есть в vanilla-ядре, он называется s1d13xxxfb, чтоб ему пусто было.

Со схемой порядок: на dataflash есть загружающийся линукс, собранный моим предшественником - там всё чётко стартует. Ессно, все рецепты утеряны, ибо предшественник уже далеко.

Что-то с софтом.

У тебя нет .config-а, с которым чётко запускается ядро на такой плате и запускается видеоконтроллер ? Если есть, может, поделишься ?

Share this post


Link to post
Share on other sites

не, у меня нет конфига, потому что я еще не использую видеонктроллер

спросил что бы ознакомиться что используеш

 

.

Share this post


Link to post
Share on other sites
Итак, кто-нибудь делал какие-нибудь действия, кроме включения драйвера Epson, чтобы заработало видео ?

Нашёл ниточку. Пока ещё не запустил, но пока не пойму, что делаю - даже пробовать не стану.

В общем, фигня вот в чём: в vanilla-ядре отсуствует код, инициализирующий ножки, диапазоны памяти и прочее для видеоконтроллера. Типа, драйвер видеоконтроллера в ядре есть, а с чем ему работать - он не знает (прошу прощения за вульгарность). В сети болтается патч на ядро 2.6.19 (на файл board-ek.c, главным образом), в частности, который устраняет этот пробел.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this