Jump to content

    

запуск rtc DS1307

По поводу подключения DS1307. Не подскажите куда подтянуть сигнальные линии на +5 В или на +3.3 В. В доке на AT91RM9200 вроде бы не сказано, что допустимы 5-и вольтовых уровни. Для DS1307 3-х вольтовых уровней вроде как достаточно.

Share this post


Link to post
Share on other sites
... Не подскажите куда подтянуть сигнальные линии на +5 В или на +3.3 В...

на +3.3 В

 

PS Посмотрите схему Rainbow :)

Share this post


Link to post
Share on other sites

Напишите как она у Вас заработала. Я немного с ней возился и для меня остались непонятно почему нужно делать паузы после выставления флага чтобы нормально с ней работать. паузы серьезные сотно тактов при кварце 8 МГц.

работал по флагу, а прерывания были от таймера. будет время - еще с ней повожусь.

Share this post


Link to post
Share on other sites

Здравствуйте, пытаюсь поднять RTC M41T56 (вроде как аналог DS1307) на SAM9260+Linux 6.22.10. В ядре включил поддержку I2C и DS1307 (кстати в той же строчке стоит M41T00)... при запуске вижу следующее:

atmel_spi atmel_spi.0: Atmel SPI Controller at 0xfffc8000 (irq 12)
mtd_dataflash spi0.1: AT45DB642x (8448 KBytes)
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
at91_ohci at91_ohci: AT91 OHCI
at91_ohci at91_ohci: new USB bus registered, assigned bus number 1
at91_ohci at91_ohci: irq 20, io mem 0x00500000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
mice: PS/2 mouse device common for all mice
i2c-core: driver [ds1307] registered
i2c /dev entries driver
i2c-core: driver [dev_driver] registered
i2c-adapter i2c-0: adapter [AT91] registered
i2c-adapter i2c-0: found normal entry for adapter 0, addr 0x68
i2c-adapter i2c-0: master_xfer[0] W, addr=0x68, len=0
i2c-adapter i2c-0: at91_xfer: processing 1 messages:
i2c-adapter i2c-0:  #0: writing 0 byte to 0x68
i2c-adapter i2c-0: transfer complete
i2c-adapter i2c-0: master_xfer[0] W, addr=0x68, len=1
i2c-adapter i2c-0: master_xfer[1] R, addr=0x68, len=8
i2c-adapter i2c-0: at91_xfer: processing 2 messages:
i2c-adapter i2c-0:  #0: writing 1 byte to 0x68
i2c-adapter i2c-0: transfer complete
i2c-adapter i2c-0:  #1: reading 8 bytes from 0x68
i2c-adapter i2c-0: transfer complete
i2c-dev: adapter [AT91] registered as minor 0
at91_i2c at91_i2c: AT91 i2c bus driver.
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)

Причем в /dev не создается устройств rtcN... Где я не прав?

Share this post


Link to post
Share on other sites

В ядре 2.6.17 я включал в 2-х местах: в Device drivers -> I2C support и в Device drivers -> Real Time Clock. Причём для последнего пришлось взять драйвер из 2.6.20 и соответствующим образом поправить Kconfig.

И еще, я не уверен, что M41T56 - аналог DS1307. Даже M41T00 - совсем не полный аналог, хотя есть только читать/писать время, то они одинаковы.

Share this post


Link to post
Share on other sites

Здравствуйте! Пытаюсь запустить ds1307 на ядре 2.6.25 на rm9200. На ядре 2.6.20 работает без проблем. В новом ядре - каждый раз при загрузке системы время сбивается. Не могу найти в новом ядре опцию CONFIG_I2C_AT91. Может в этом проблема? Возможно, есть какая-то опция вместо нее.

Share this post


Link to post
Share on other sites
Здравствуйте! Пытаюсь запустить ds1307 на ядре 2.6.25 на rm9200. На ядре 2.6.20 работает без проблем. В новом ядре - каждый раз при загрузке системы время сбивается. Не могу найти в новом ядре опцию CONFIG_I2C_AT91. Может в этом проблема? Возможно, есть какая-то опция вместо нее.

 

 

Челябинские программисты напрямую редактируют .config (я делаю так).

 

PS Без шуток - выложите Ваш конфиг, тогда сможем помочь.

Share this post


Link to post
Share on other sites
Челябинские программисты напрямую редактируют .config (я делаю так).

 

PS Без шуток - выложите Ваш конфиг, тогда сможем помочь.

 

Спасибо, проблема решилась. В новом ядре данная опция не используется, при загрузке не заметил каким девайсом инициализируется rtc (rtc1).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this