Jump to content

    

Восстановление прошивки в камере

Recommended Posts

Propretor!

Коллеги, есть камера c HDMI выходом и 2 USB портами для подключения носителя (записи видео и обновления прошивки).
Процессор Hisilicon Hi3516, флеш - Macronix MX25L25645G 256Мбит(32Мбайт), 3.3В.
Не снимая флеш, решил слить прошивку. Начались странности. Первый раз прочитался один дамп, второй раз считался дамп с бОльшим количеством блоков FF в теле,
третий и четвертый раз отличались лишь еще бОльшим числом FF.
Сдул чип с платы. Программатором считывалась какая-то ерунда, а попытка прошить в чип дамп, слитый в первую попытку чтения не привел к результату.
Чип оказался защищенным от записи. И защита эта не снималась. Каким образом тогда при считывании некоторые блоки замещались на FF непонятно.
Была куплена новая MX25L25645G без защиты записи. После заливки в нее первого дампа и распайке на плате камера не стартует.
Есть обновление прошивки для USB носителя. Но оно не считывается, поскольку, похоже, бут-блок находится в MX25L25645G, и он, похоже, был испорчен при считывании
дампа даже в первый раз.
Есть на плате еще Tx, Rx.
Прошу совета, есть ли способ восстановить работоспособность камеры?
Сам вижу только 2 пути, но не уверен, что они рабочие:
1. Преобразовать файл прошивки для USB-обновления в BIN формат для программатора, добавив каким то магическим образом бут-блок в прошивку.
2. Залить в MX25L25645G программатором какой-то минимальный файл прошивки, содержащий только бут-блок, который уже гарантированно опрашивает USB-носитель c записанным на него обновлением.
3. Залить в камеру прошивку через USB-TTL адаптер на 3.3В. Но вот что? Где взять бут-блок?
Но ведь при производстве ведь флеш чистая как слеза девственницы и каким-то образом производитель "вдыхает жизнь" в свое творение?

Процессор в настоящий момент перестал греться, в отличии от состояния с исправной прошивкой. Полагаю, это нормально, если операционка не загружена и камень простаивает.

Firmware MX25L25645G.7z

Share this post


Link to post
Share on other sites

x893
4 hours ago, Propretor! said:

Есть на плате еще Tx, Rx.

Уже в другой теме было.

Что выводится при включении ?

Google и github в помощь

https://github.com/hi35xx/hi35xx-buildroot

Share this post


Link to post
Share on other sites

tillman

В вашем архиве дамп с камеры? Если да, то он однозначно битый. В нем много повторяющихся блоков. Очень похоже что ваш программатор или не поддерживает эту флешку  или проблемы в проводах\колодке.  Скорее всего и "зашита от записи" из-за вышеуказанных проблем. Попробуйте найти другой программатор и считайте дамп еще раз.

Сделайте хорошее фото платы. Какие есть надписи на плате? Как называется камера? Прикрепите прошивку для USB. По опыту, в прошивке для USB присутствует не все что необходимо для восстановления  камеры. 

 

Edited by tillman

Share this post


Link to post
Share on other sites

Propretor!
21 час назад, tillman сказал:

По опыту, в прошивке для USB присутствует не все что необходимо для восстановления  камеры.

Можете подробнее раскрыть эту тему?

Share this post


Link to post
Share on other sites

tillman

Пример - в камере прошивка состоит из 8 частей + бывает отдельная область с серийниками, сертификатами доступа к облачным сервисам и прочей сервисной информацией.

da=tftp 0xc1000000 u-boot.bin.img;protect off all; flwrite
dr=tftp 0xc1000000 romfs-x.cramfs.img; flwrite
dc=tftp 0xc1000000 custom-x.cramfs.img; flwrite
du=tftp 0xc1000000 user-x.cramfs.img; flwrite
dw=tftp 0xc1000000 web-x.cramfs.img; flwrite
dl=tftp 0xc1000000 logo-x.cramfs.img; flwrite
up=tftp 0xc1000000 update.img; flwrite
tk=tftp 0xc1000000 uImage; bootm 0xc1000000

 

В прошивке может не хватать каких-нибудь частей, и уж точно в ней нет серийников и прочего без которых некоторые камеры отказываются работать.

Share this post


Link to post
Share on other sites

Propretor!
3 часа назад, tillman сказал:

Пример - в камере прошивка состоит из 8 частей + бывает отдельная область с серийниками, сертификатами доступа к облачным сервисам и прочей сервисной информацией.

В прошивке может не хватать каких-нибудь частей, и уж точно в ней нет серийников и прочего без которых некоторые камеры отказываются работать.

Если найти точно такую же камеру и слить прошивку с нее. Получится сделать работоспособный клон камеры? Разве в этом случае будут проблемы?

Share this post


Link to post
Share on other sites

tillman

Чаще всего все работает после бекапа с рабочей камеры. Но в новых камерах стали в памяти хранить сертификат доступа к облачным сервисам, в старых доступ был по уникальному серийнику процессора. В таком случае обычно все работает кроме облака.

Share this post


Link to post
Share on other sites

tillman

Нет. Клон не будет работать с облаком так как при авторизации в облаке используется сертификат и серийный номер проца, а они будут не комплектные.

Share this post


Link to post
Share on other sites

Propretor!

Удалось снять лог загрузки камеры:

System startup

Uncompress Ok!

U-Boot 2020.01 (Oct 20 2021 - 15:15:30 +0800)hi3516av300

DRAM:  SPI Nor:  hifmc_ip_ver_check(38): Check Flash Memory Controller v100 ...hifmc_ip_ver_check(44):  Found
hifmc_spi_nor_probe(2213): SPI Nor ID Table Version 1.0
hifmc_spi_nor_probe(2238): SPI Nor(cs 0) ID: 0xc2 0x20 0x19
hifmc_init_print(2154): Block:64KB hifmc_init_print(2155): Chip:32MB hifmc_init_print(2156): Name:"MX25L25(6/7)XX"
hifmc100_spi_nor_probe(131): SPI Nor total size: 32MB
NAND:  0 MiB
MMC:
Loading Environment from SPI Flash... *** Warning - bad CRC, using default environment

Loading Environment from NAND... *** Warning - readenv() failed, using default environment

In:    serial
Out:   serial
Err:   serial
MMC Device 0 not found
No mmc driver found!
USB0:   Register 1000140 NbrPorts 1
Starting the controller
USB XHCI 1.10
scanning bus 0 for devices... 2 USB Device(s) found
0 Storage Device(s) found
Net:   eth0
Error: eth0 address not set.

Autoboot in 0 seconds
device 0 offset 0x1f00000, size 0x100000

SF: 1048576 bytes @ 0x1f00000 Read: OK
you should first set:

args: [format]
        -<format> : 0: semi-plannar yvu420
        - setenv jpeg_addr     0x--------
        - setenv jpeg_size     0x--------
        - setenv vobuf         0x--------
        - setenv jpeg_emar_buf 0x--------

jpeg decoding ...
<<addr=0x9f000000, size=0x100000, jpeg_emar_buf=0x9f400000, vobuf=0x9f800000>>
hardware decoding success! 1920x1080, stride 1920.
decode jpeg!
dev 0 opened!
video layer 0 opened!
device 0 offset 0x100000, size 0x400000

SF: 4194304 bytes @ 0x100000 Read: OK
## Booting kernel from Legacy Image at 82000000 ...
   Image Name:   Linux-4.19.90
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4098603 Bytes = 3.9 MiB
   Load Address: 80008000
   Entry Point:  80008000
   Loading Kernel Image

Starting kernel ...

Booting Linux on physical CPU 0x0
Linux version 4.19.90 ([email protected]_) (gcc version 7.3.0 (HC&C V1R3C00SPC200B042_20210105)) #4 SMP Mon Sep 27 13:27:21 CST 2021
CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
CPU: div instructions available: patching division code
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
OF: fdt: Machine model: Hisilicon HI3516DV300 DEMO Board
Memory policy: Data cache writealloc
cma: Reserved 16 MiB at 0x8f000000
random: get_random_bytes called from start_kernel+0xa4/0x3ac with crng_init=0
percpu: Embedded 14 pages/cpu s27020 r8192 d22132 u57344
Built 1 zonelists, mobility grouping on.  Total pages: 65024
Kernel command line: mem=256M console=ttyAMA0,115200 root=/dev/mtdblock2 rootfstype=jffs2 rw mtdparts=hi_sfc:1M(u-boot-c21x.bin),4M(kernel-c21x),26M(c212_update),1M(logo.jpg)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 233528K/262144K available (6144K kernel code, 220K rwdata, 1408K rodata, 1024K init, 307K bss, 12232K reserved, 16384K cma-reserved, 0K highmem)
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xd0800000 - 0xff800000   ( 752 MB)
    lowmem  : 0xc0000000 - 0xd0000000   ( 256 MB)
    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
    modules : 0xbf000000 - 0xbfe00000   (  14 MB)
      .text : 0x(ptrval) - 0x(ptrval)   (7136 kB)
      .init : 0x(ptrval) - 0x(ptrval)   (1024 kB)
      .data : 0x(ptrval) - 0x(ptrval)   ( 221 kB)
       .bss : 0x(ptrval) - 0x(ptrval)   ( 308 kB)
SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
rcu: Hierarchical RCU implementation.
NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
Gic dist init...
arch_timer: CPU0: Trapping CNTVCT access
arch_timer: cp15 timer(s) running at 50.00MHz (phys).
clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0xb8812736b, max_idle_ns: 440795202655 ns
sched_clock: 56 bits at 50MHz, resolution 20ns, wraps every 4398046511100ns
Switching to timer-based delay loop, resolution 20ns
Console: colour dummy device 80x30
Calibrating delay loop (skipped), value calculated using timer frequency.. 100.00 BogoMIPS (lpj=500000)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
CPU: Testing write buffer coherency: ok
CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
Setting up static identity map for 0x80100000 - 0x80100060
rcu: Hierarchical SRCU implementation.
smp: Bringing up secondary CPUs ...
arch_timer: CPU1: Trapping CNTVCT access
CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
smp: Brought up 1 node, 2 CPUs
SMP: Total of 2 processors activated (200.00 BogoMIPS).
CPU: All CPU(s) started in SVC mode.
devtmpfs: initialized
VFP support v0.3: implementor 41 architecture 2 part 30 variant 7 rev 5
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
futex hash table entries: 512 (order: 3, 32768 bytes)
pinctrl core: initialized pinctrl subsystem
NET: Registered protocol family 16
DMA: preallocated 256 KiB pool for atomic coherent allocations
Serial: AMBA PL011 UART driver
120a0000.uart: ttyAMA0 at MMIO 0x120a0000 (irq = 21, base_baud = 0) is a PL011 rev2
console [ttyAMA0] enabled
120a1000.uart: ttyAMA1 at MMIO 0x120a1000 (irq = 22, base_baud = 0) is a PL011 rev2
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
videodev: Linux video capture interface: v2.00
Advanced Linux Sound Architecture Driver Initialized.
clocksource: Switched to clocksource arch_sys_counter
NET: Registered protocol family 2
tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes)
TCP established hash table entries: 2048 (order: 1, 8192 bytes)
TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
workingset: timestamp_bits=30 max_order=16 bucket_order=0
NFS: Registering the id_resolver key type
Key type id_resolver registered
Key type id_legacy registered
jffs2: version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
io scheduler noop registered
io scheduler cfq registered (default)
io scheduler mq-deadline registered
io scheduler kyber registered
pl061_gpio 120d0000.gpio_chip: PL061 GPIO chip @0x120d0000 registered
pl061_gpio 120d1000.gpio_chip: PL061 GPIO chip @0x120d1000 registered
pl061_gpio 120d2000.gpio_chip: PL061 GPIO chip @0x120d2000 registered
pl061_gpio 120d3000.gpio_chip: PL061 GPIO chip @0x120d3000 registered
pl061_gpio 120d4000.gpio_chip: PL061 GPIO chip @0x120d4000 registered
pl061_gpio 120d5000.gpio_chip: PL061 GPIO chip @0x120d5000 registered
pl061_gpio 120d6000.gpio_chip: PL061 GPIO chip @0x120d6000 registered
pl061_gpio 120d7000.gpio_chip: PL061 GPIO chip @0x120d7000 registered
pl061_gpio 120d8000.gpio_chip: PL061 GPIO chip @0x120d8000 registered
pl061_gpio 120d9000.gpio_chip: PL061 GPIO chip @0x120d9000 registered
pl061_gpio 120da000.gpio_chip: PL061 GPIO chip @0x120da000 registered
pl061_gpio 120db000.gpio_chip: PL061 GPIO chip @0x120db000 registered
brd: module loaded
hisi-sfc hisi_spi_nor.0: SPI Nor ID Table Version 1.2
hisi-sfc hisi_spi_nor.0: all blocks is unlocked.
hisi-sfc hisi_spi_nor.0: mx25l25635f (32768 Kbytes)
4 cmdlinepart partitions found on MTD device hi_sfc
Creating 4 MTD partitions on "hi_sfc":
0x000000000000-0x000000100000 : "u-boot-c21x.bin"
0x000000100000-0x000000500000 : "kernel-c21x"
0x000000500000-0x000001f00000 : "c212_update"
0x000001f00000-0x000002000000 : "logo.jpg"
SPI Nand ID Table Version 2.7
Cannot found a valid SPI Nand Device
hisi_spi_nand_probe(182): Error: driver probe, result: -19
libphy: hisi_femac_mii_bus: probed
libphy: Fixed MDIO Bus: probed
hisi-femac 10010000.ethernet: using random MAC address 92:ce:d1:0c:88:ac
Generic PHY 10011100.mdio:01: attached PHY driver [Generic PHY] (mii_bus:phy_addr=10011100.mdio:01, irq=POLL)
phy_id=0x0000ffff, phy_mode=rmii
usbcore: registered new interface driver r8152
xhci-hcd 100e0000.xhci_0: xHCI Host Controller
xhci-hcd 100e0000.xhci_0: new USB bus registered, assigned bus number 1
xhci-hcd 100e0000.xhci_0: hcc params 0x0220fe6c hci version 0x110 quirks 0x0000000020010010
xhci-hcd 100e0000.xhci_0: irq 29, io mem 0x100e0000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
xhci-hcd 100e0000.xhci_0: xHCI Host Controller
xhci-hcd 100e0000.xhci_0: new USB bus registered, assigned bus number 2
xhci-hcd 100e0000.xhci_0: Host supports USB 3.0 SuperSpeed
usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
hub 2-0:1.0: USB hub found
hub 2-0:1.0: hub can't support USB3.0
usbcore: registered new interface driver usb-storage
mousedev: PS/2 mouse device common for all mice
usbcore: registered new interface driver xpad
hibvt_rtc 12080000.rtc: rtc core: registered 12080000.rtc as rtc0
hibvt_rtc 12080000.rtc: RTC driver for hibvt enabled
i2c /dev entries driver
hibvt-i2c 120b0000.i2c: [email protected] registered
hibvt-i2c 120b1000.i2c: [email protected] registered
hibvt-i2c 120b2000.i2c: [email protected] registered
hibvt-i2c 120b3000.i2c: [email protected] registered
hibvt-i2c 120b4000.i2c: [email protected] registered
hibvt-i2c 120b5000.i2c: [email protected] registered
hibvt-i2c 120b6000.i2c: [email protected] registered
hibvt-i2c 120b7000.i2c: [email protected] registered
uvcvideo: Unable to create debugfs directory
usbcore: registered new interface driver uvcvideo
USB Video Class driver (1.1.1)
himci: mmc host probe
usb 1-1: new high-speed USB device number 2 using xhci-hcd
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
NET: Registered protocol family 10
Segment Routing with IPv6
NET: Registered protocol family 17
8021q: 802.1Q VLAN Support v1.8
Key type dns_resolver registered
Registering SWP/SWPB emulation handler
hibvt_rtc 12080000.rtc: setting system clock to 2022-04-17 19:44:47 UTC (1650224687)
ALSA device list:
  No soundcards found.
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
VFS: Mounted root (jffs2 filesystem) on device 31:2.
devtmpfs: mounted
Freeing unused kernel memory: 1024K
Run /sbin/init as init process

            _ _ _ _ _ _ _ _ _ _ _ _
            \  _  _   _  _ _ ___
            / /__/ \ |_/
           / __   /  -  _ ___
          / /  / /  / /
  _ _ _ _/ /  /  \_/  \_ ______
___________\___\__________________

[RCS]: /etc/init.d/S00devs
mknod: /dev/console: File exists
mknod: /dev/ttyAMA0: File exists
mknod: /dev/ttyAMA1: File exists
mknod: /dev/null: File exists
[RCS]: /etc/init.d/S01udev
random: udevd: uninitialized urandom read (16 bytes read)
random: udevd: uninitialized urandom read (16 bytes read)
udevd[68]: starting eudev-3.2.9
[RCS]: /etc/init.d/S80network
*** Board tools : ver0.0.1_20121120 ***
[debug]: {source/utils/cmdshell.c:171}cmdstr:himm
0x112f00ac: 0x00000600 --> 0x00000401
[END]
*** Board tools : ver0.0.1_20121120 ***
[debug]: {source/utils/cmdshell.c:171}cmdstr:himm
0x112f0020: 0x00000600 --> 0x00000404
[END]IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

*** Board tools : ver0.0.1_20121120 ***
[debug]: {source/utils/cmdshell.c:171}cmdstr:himm
0x12090000: 0x00100160 --> 0x001001E0
[END]
mmz_start: 0x90000000, mmz_size: 768M
hi_securec: loading out-of-tree module taints kernel.
hi_securec: module license 'unspecified' taints kernel.
Disabling lock debugging due to kernel taint
Module himedia: init ok
Hisilicon Media Memory Zone Manager
hi_osal 1.0 init success!

==========i2c_init==========

==========chip: hi3516av300==========

==========sensor0: imx307==========

==========sensor1: imx307==========
random: udevd: uninitialized urandom read (16 bytes read)
load sys.ko for Hi3516CV500...OK!
load tde.ko for Hi3516CV500...OK!
load region.ko for Hi3516CV500...OK!
load gdc.ko for Hi3516CV500...OK!
load vgs.ko for Hi3516CV500...OK!
load dis.ko for Hi3516CV500...OK!
load vi.ko for Hi3516CV500...OK !
load isp.ko for Hi3516CV500...OK !
load vpss.ko for Hi3516CV500...OK!
load vo.ko for Hi3516CV500...OK!
load hifb.ko OK!
load chnl.ko for Hi3516CV500...OK!
load vedu.ko for Hi3516CV500...OK!
load rc.ko for Hi3516CV500...OK!
load venc.ko for Hi3516CV500...OK!
load h264e.ko for Hi3516CV500...OK!
load h265e.ko for Hi3516CV500...OK!
hisi-femac 10010000.ethernet eth0: Link is Up - 10Mbps/Half - flow control off
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
load jpege.ko for Hi3516CV500...OK!
load jpegd.ko for Hi3516CV500...OK!
load vfmw.ko ....OK!
load vdec.ko for Hi3516CV500...OK!
load iop.ko for Hi3516CV500...OK!
load ive.ko for Hi3516CV500...OK!
load nnie.ko for Hi3516CV500...OK!
load pwm.ko for Hi3516CV500...OK!
load hi_piris.ko for Hi3516CV500...OK!
load sensor_spi.ko for Hi3516CV500...OK !
load hdmi.ko for Hi3516CV500...OK!
insert audio
load mipi_rx driver successful!
alpu_c_drv_init  ok
init start
gpio init successful!
motor init successful!
af pi level:1
pi check over!

Please press Enter to activate this console.
=========================================
VERSON:v1.1.3
DATE:Oct 25 2021,TIME:13:55:31
=========================================
===========================CAPTURE_Init=============================
linear mode
==============================================================
===Sony imx307 sensor 1080P60fps(MIPI) init success!=====
==============================================================
===========================ENCODE_Init=============================
===========================ENCODE_Start=============================
===========================YUV_Start=============================
===========================EDGE_Init=============================
===========================EDGE_Start=============================
===========================DISPLAY_Init=============================
create config file! /opt/app_conf.ini
===========================QT_Init=============================
===========================QT_Start=============================
random: fast init done
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
buildDate QDate("Wed Oct 13 2021") buildTime QTime("14:20:19")
??????
Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf
random: crng init done

Смущают следующие строки:

Loading Environment from SPI Flash... *** Warning - bad CRC, using default environment

Loading Environment from NAND... *** Warning - readenv() failed, using default environment

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

buildDate QDate("Wed Oct 13 2021") buildTime QTime("14:20:19")

Initializing QFontEngineQPF failed for /qt_lib/fonts/DroidSansFallback.ttf

 

Что скажут знающие люди?

Share this post


Link to post
Share on other sites

aaarrr
34 minutes ago, Propretor! said:

Loading Environment from SPI Flash... *** Warning - bad CRC, using default environment

Loading Environment from NAND... *** Warning - readenv() failed, using default environment

Это вполне обычное дело - используется вшитый в u-boot environment.

Share this post


Link to post
Share on other sites

Propretor!

Коллеги, может кто просветит, если знает. Есть рабочий регистратор. Выход - 1920х1080 60FPS, HDMI. Подключаю к монитору FullHD - изображение есть, подключаю к телевизору 3840х - изображение есть. Подключаю к монитору 2560х - изображения нет, экран черный. Монитор исправный и поддерживает 60Гц. С компьютера изображение - без проблем выводится. Что за рулетка?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.