Jump to content

    
a123-flex

Stm4x дохнут при работе с дисплеем

Recommended Posts

Добрый день

 

Продолжается у нас эпопея, вчера мне отдали плату, где кажется у STM сдох интерфейс матрицы. Parallel RGB.

Проц пишется стирается, заходит в отладку, на дебаге вижу что он у меня висит в процедуре "нарисовать красный минус"... а вот на экране никаким минусом и не пахнет. Там вроде летает какой-то мусор. Попробовал сменить матрицу - безрезультатно.

Осцилл возьму завтра, а сегодня мысли. Там на матрицу подается несколько напряжений (+16, -6.8, +9.2, etc), рулится шина данных дисплея у нас напрямую от чипа. Никаких резисторов мы не ставили, те соединение контроллер матрицы - STM - прямое. 

 

Я вот думаю, не может ли такого быть, чтобы дешевая китайская матрица нарушала логические уровни, и на сигнальные линии мне давала бы какие-то возможно выбросы, больше или меньше чем 0...3 В, так чтобы отгорели управляющие линии STM ?

 

Share this post


Link to post
Share on other sites
7 minutes ago, a123-flex said:

Я вот думаю, не может ли такого быть, чтобы дешевая китайская матрица нарушала логические уровни, и на сигнальные линии мне давала бы какие-то возможно выбросы, больше или меньше чем 0...3 В, так чтобы отгорели управляющие линии STM ?

Сомнительно: у матрицы это входы.

Share this post


Link to post
Share on other sites

А они точно сдохли? Может, просто DE или CLK отвалился? Из косвенных признаков - обычно выбитые драйверы хорошо так разогреваются. Если потребление в норме, то вряд ли это оно.

Share this post


Link to post
Share on other sites
56 minutes ago, a123-flex said:

Там на матрицу подается несколько напряжений

Кроме наличия питания - очень важна последовательность включения линий, в доке на дисплей есть картинка с таймингами. Из неприятностей: рандомное выгорание пикселей, иногда целых строк. Стандартный драйвер на одном boost ключе имеет детали выполняющие сразу несколько функций одновременно: задержка, ограничение тока, перекачка энергии. Я к тому что менять номиналы деталей в этой схеме не нужно, и даже опасно.

Share this post


Link to post
Share on other sites

мы сменили все схемы, оставили только номиналы)

sequence - спасибо за вопрос - конкретно нарушили((

ни одна из матриц ПОКА не пострадала, а вот с процами проблема

 

лучше бы наоборот((

Share this post


Link to post
Share on other sites
21 час назад, aaarrr сказал:

А они точно сдохли? Может, просто DE или CLK отвалился? Из косвенных признаков - обычно выбитые драйверы хорошо так разогреваются.

Ну и еще, RGB- это параллельная шина, поэтому, если что-то и сдохло - это эти 2 линии, сигналы данных маловероятно, ибо даже если нет нескольких линий будет просто искажение цветов, синхра будет норм, по линии клока может быть емкости превышены и было превышение по току, или просто "левые" процы попались... Вообщем смотрите осциллом клок и DE линии, особенно клок.

Edited by mantech

Share this post


Link to post
Share on other sites

Ничего не понимаю

Обмерял осциллом линии. DE CLK VSync HSync. Сигналы хоть в книжку загляденье. На экране ничего нет((

Ставил осцилл на захват и триггер ниже/выше нуля на каждой из линий.

Ни на одной из ЭТИХ линий при включении/отключении питания выброс за диапазон 0...3В не происходит, несмотря на то что мы вывернули диаграмму включения дисплея на изнанку от DS((

А 5 плат лежат на столе и ничего не кажут(((:cray:

 

Share this post


Link to post
Share on other sites

Может конструктивно (в приборе) экран неудачно стоит? И например через него заземляется электроника.

Остальные сигналы? Хотя бы просто уровни/фронты. Ну то есть чем по сигнала отличается рабочий контроллер от нерабочего?

Ну и самое просто: может не контроллер, а разъем дисплея ломается?

Share this post


Link to post
Share on other sites
8 часов назад, a123-flex сказал:

Обмерял осциллом линии. DE CLK VSync HSync. Сигналы хоть в книжку загляденье. На экране ничего нет((

Ну вот, значит что и требовалось доказать, скорее всего МК тут не виноват, смотреть плату, разъемы, дисплей и т.д.

Share this post


Link to post
Share on other sites
Только что, aaarrr сказал:

Может, у индикатора какой-нибудь RESET/DISP забыли подключить?

Часть плат от заказчика вернулась. Они работали уже(

Share this post


Link to post
Share on other sites
57 минут назад, a123-flex сказал:

Часть плат от заказчика вернулась. Они работали уже(

Без схемы что-либо сложно сказать, но у меня была похожая проблема из-за тиристорного эффекта, вызванного неправильным порядком включения источников. Проверьте, что на смежные с интерфейсом с LCD пины не приходит какой-нибудь сигнал до появления питания на МК. Да и вообще порядок включения источников при таких проблемах не мешает проверить на всякий случай.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.