Jump to content

    
a123-flex

Stm4x дохнут при работе с дисплеем

Recommended Posts

On 10/7/2021 at 1:45 AM, a123-flex said:

ни одна из матриц ПОКА не пострадала, а вот с процами проблема

Это точно? Т.е. матрицы с отказавших устройств проверены и работают?

В сочетании с -

10 hours ago, a123-flex said:

DE CLK VSync HSync. Сигналы хоть в книжку загляденье.

- просто магия, так не должно быть.

Share this post


Link to post
Share on other sites
2 часа назад, aaarrr сказал:

Может, у индикатора какой-нибудь RESET/DISP забыли подключить?

Может быть недостаточно длительности ресета? Такое бывает с некоторыми контроллерами дисплеев.

Share this post


Link to post
Share on other sites
6 минут назад, Vasily_ сказал:

Не факт, скорее всего какое-то переходное сдохло в печатке.

У всех в одном месте сдохло? Как-то маловероятно...

1 минуту назад, makc сказал:

Такое бывает с некоторыми контроллерами дисплеев.

Бывает, но ТС писал, что изначально работало. Больше походит на проблему пайки\флюса..

Share this post


Link to post
Share on other sites
7 минут назад, mantech сказал:

Бывает, но ТС писал, что изначально работало. Больше походит на проблему пайки\флюса..

У меня с китайскими OLED тоже такое было, сначала работало, а потом полежало и перестало. Все решилось увеличением длительности ресета, причём длительность была какая-то очень большая на мой взгляд: порядка 150...200 мс. Может это твое было связано с пайкой и флюсом, может с температурой, но увеличение длительности решило проблему на все 100%.

Share this post


Link to post
Share on other sites
Цитата

 OSPEEDRy[1:0]: Port x configuration bits (y = 0..15)
These bits are written by software to configure the I/O output speed.
00: Low speed
01: Medium speed
10: High speed
11: Very high speed

я предположил, что возможно у используемых ног (например на шине данных) неправильно выставлены биты, определяющие скорость работы.

Share this post


Link to post
Share on other sites
07.10.2021 в 04:30, a123-flex сказал:

 Там на матрицу подается несколько напряжений (+16, -6.8, +9.2, etc), рулится шина данных дисплея у нас напрямую от чипа.

99% что неправильно стартует, надо проверить время нарастания указанных напряжений и скорректировать время старта. Могут тупо не тот конденсатор впаять.

Share this post


Link to post
Share on other sites

Спасибо всем

 

самая загадочная плата - что с возврата - после пропайки стартовала. Видимо все же был непропай. Кроме того монтажник не отмыл плату.

Промерил еще несколько линий данных - нигде никаких нештатных выбросов напряжения при включении/отключении питания, точно также как и на линиях управления, нет.

 

С остальными платками ковыряюсь

 

6 часов назад, Vasily_ сказал:

Не факт, скорее всего какое-то переходное сдохло в печатке.

Качество сборки у меня ужасное. 

Запустил серийку на своем оборудовании(((

Больше никогда на серию дешевым оборудованием не пойду((

 

В серии всего 25000 компонентов, а геморроя на несколько месяцев, 90% плат брак((

Share this post


Link to post
Share on other sites
20 минут назад, a123-flex сказал:

самая загадочная плата - что с возврата - после пропайки стартовала. Видимо все же был непропай. Кроме того монтажник не отмыл плату.

Вот почему и предположил это ранее, т.к. 5 лет назад у меня был случай - в составе оборудования делали плату преобразователя усб в рс-485, так вот после полугода плата переставала работать, примерно 30% от всех выпущенных, забрали их себе, я проверял, все детали исправны, но плату не видит комп, пропаял все микросхемы и все заработало, начал выяснять, оказывается новый монтажник решил предложить какое-то свое "ноу-хау" при пайке, флюс какой-то суперпупер и пр, оказалось, что все это со временем начинает пропускать ток, и все это превращается в "хау-ноу", пришлось отзывать немало плат и перепаивать, вот таки дела бывают...

Share this post


Link to post
Share on other sites
2 часа назад, a123-flex сказал:

Качество сборки у меня ужасное. 

Запустил серийку на своем оборудовании(((

Больше никогда на серию дешевым оборудованием не пойду((

Вот так люди и знакомятся с волшебным словом "технолог" :)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.