Jump to content

    
Sign in to follow this  
Джоконда

Altium Designer 20 - Почему нумеруется не совсем корректно?

Recommended Posts

Всем добрый день.

Товарищи, такая проблема, схема у меня готова, вот ее фрагмент, нужно пронумеровать компоненты. Нажимаю Annotation - annotation schematics - ставлю parts вместо designator-а, нумерация сверху вниз слева направо, и все далее, как в любом видеоуроке. Но у меня почему то пронумеровалось вот так. Как это исправить?

Нумерация пл.jpg

Edited by Джоконда

Share this post


Link to post
Share on other sites

Ну первоначально нет, когда еще изначально вопросики вместо номеров стояли, а потом уже да, когда пробовал перенумеровывать...А вообще, первый раз такое вижу, чтобы в автонумерации С38 и С39 стояли раньше С37...

Share this post


Link to post
Share on other sites

Есть один момент. Я работаю уже с готовым проектом, там уже встроены свои библиотеки. Я попробовал для эксперимента вместо кондеров из встроенной библиотеки, вставить несколько альтиумовских кондеров...и.., вроде бы пронумеровалось правильно. Как же это может быть? Разве библиотека как то может влиять на корректность работы автоматической нумерации?

Нумерация 2.jpg

Share this post


Link to post
Share on other sites

при аннотировании нужно Reset-ом сбрасывать сначала всю нумерацию и заново её проводить. Скорее всего в этом причина была.

От библиотек ниче не зависит

Share this post


Link to post
Share on other sites
4 hours ago, Джоконда said:

Разве библиотека как то может влиять на корректность работы автоматической нумерации?

может. при указании сортировки по Part, альтиум вроде как смотрит 0-ую точку. и вот куда она попала от этого будет зависеть.

Компонент может быть перевернут на 180 или отзеркален

все неверно, отписался ниже

Share this post


Link to post
Share on other sites

Да, я попробовал кондеры из из встроенной библиотеки, просто повернуть на 180 градусов, нумерация опять поменялась...Кое что стало правильнее, чем было, а что-то не очень. Осталось только узнать в каком месте стоит компонент "правильный", а где отзеркаленный. Хотя, мне кажется, что программе должно быть все равно...

Share this post


Link to post
Share on other sites

программе все равно.

обычно в таких случаях помогает тотальная перерисовка схемы.

ни разу за время работы мне не удалось сэкономить времени на отлове ошибок. сразу все перерисовываю.

Share this post


Link to post
Share on other sites
1 час назад, Uree сказал:

Ну как так-то. взяли и поправились на неправильное написание...

image.png.1677a0d71063bc46e45c4400b3c82c7c.png

Не могу согласиться, и на грамоте.ру не смог просветиться достоверно. В обведённом вами слове не хватает мягкого знака, а 'о' не при чём.

Так, что, специалисты не знают, по какому элементу Альтиум проводит определение положения компонента в схеме?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this