Jump to content

    

Recommended Posts

Здравствуйте. У меня есть несколько приборов с Artix. Все приборы прошиты и работают. Когда понадобилось обновить прошивку, то выявил одну проблему - в одном приборе не обновляется прошивка. 
В Vivado прошивка начинает заливаться, но проходит буквально 2 секунды и окно прошивки закрывается, при этом сообщений об ошибке нет, но в ПЛИС осталась старая прошивка.

Лог когда все ОК:

Скрытый текст

set_property PROBES.FILE {} [get_hw_devices xc7a200t_0]
set_property FULL_PROBES.FILE {} [get_hw_devices xc7a200t_0]
set_property PROGRAM.FILE {D:/version10.bit} [get_hw_devices xc7a200t_0]
program_hw_devices [get_hw_devices xc7a200t_0]
INFO: [Labtools 27-3164] End of startup status: HIGH
program_hw_devices: Time (s): cpu = 00:00:07 ; elapsed = 00:00:07 . Memory (MB): peak = 2519.895 ; gain = 0.000

refresh_hw_device [lindex [get_hw_devices xc7a200t_0] 0]

INFO: [Labtools 27-1434] Device xc7a200t (JTAG device index = 0) is programmed with a design that has no supported debug core(s) in it.

Лог когда нет результата:

Скрытый текст

set_property PROBES.FILE {} [get_hw_devices xc7a200t_0]
set_property FULL_PROBES.FILE {} [get_hw_devices xc7a200t_0]
set_property PROGRAM.FILE {D:/version10.bit} [get_hw_devices xc7a200t_0]

program_hw_devices [get_hw_devices xc7a200t_0]

INFO: [Labtools 27-3164] End of startup status: HIGH

refresh_hw_device [lindex [get_hw_devices xc7a200t_0] 0]
INFO: [Labtools 27-1434] Device xc7a200t (JTAG device index = 0) is programmed with a design that has no supported debug core(s) in it.

Если прошивать флешку, то в этом приборе ошибка:  [Labtools 27-3347] Flash Programming Unsuccessful: Failure to set flash parameters.

Самое интересное, что если запустить Impact, то он прошивает и ПЛИС и флешку нормально в этом приборе.

Скрытый текст

No automatically saved previous project to load.
GUI --- Auto connect to cable...
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Driver file xusb_emb.sys found.
 Driver version: src=1029, dest=1029.
 Driver windrvr6.sys version = 10.2.1.0. WinDriver v10.21 Jungo (c) 1997 - 2010 Build Date: Aug 31 2010 x86_64 64bit SYS 14:14:44, version = 1021.
 Cable PID = 0008.
 Max current requested during enumeration is 150 mA.
Type = 0x0005.
 Cable Type = 3, Revision = 0.
 Setting cable speed to 6 MHz.
Cable connection established.
Firmware version = 2401.
File version of C:/Xilinx2/14.7/ISE_DS/ISE/data/xusb_xp2.hex = 2401.
Firmware hex file version = 2401.
PLD file version = 200Dh.
 PLD version = 200Dh.
PROGRESS_END - End Operation.
Elapsed time =      1 sec.
Type = 0x0005.
ESN option: 1070007FD9D081.
Attempting to identify devices in the boundary-scan chain configuration...
INFO:iMPACT - Current time: 15.05.2021 14:40:57
PROGRESS_START - Starting Operation.
Identifying chain contents...'0': : Manufacturer's ID = Xilinx XC7A200T, Version : 1
INFO:iMPACT:1777 - 
Reading C:/Xilinx2/14.7/ISE_DS/ISE/artix7/data/xc7a200t.bsd...
INFO:iMPACT - Using CseAdapterBSDevice
INFO:iMPACT:501 - '1': Added Device XC7A200T successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
done.
PROGRESS_END - End Operation.
Elapsed time =      0 sec.
'1': Loading file 'D:/bit/version10.bit' ...
done.
INFO:iMPACT - Using CseAdapterBSDevice
INFO:iMPACT:2257 - Startup Clock has been changed to 'JtagClk' in the bitstream stored in memory,
but the original bitstream file remains unchanged.
UserID read from the bitstream file = 0XFFFFFFFF.
Data width read from the bitstream file = 4.
INFO:iMPACT:501 - '1': Added Device xc7a200t successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
PROGRESS_START - Starting Operation.
Maximum TCK operating frequency for this device chain: 66000000.
Validating chain...
Boundary-scan chain validated successfully.
1: Device Temperature: Current Reading:   42.99 C, Min. Reading: -273.00 C, Max. Reading:  230.52 C
1: VCCINT Supply: Current Reading:   0.993 V, Min. Reading:   0.990 V, Max. Reading:   0.996 V
1: VCCAUX Supply: Current Reading:   1.799 V, Min. Reading:   1.796 V, Max. Reading:   1.799 V
INFO:iMPACT - Creating XC7A200T device.
PROGRESS_START - Starting Operation.
'1': Programming device...
 Match_cycle = NoWait.
Match cycle: NoWait
 LCK_cycle = NoWait.
LCK cycle: NoWait
done.
INFO:Cse - Status register values:
INFO:Cse - 0011 1111 1001 1110 0000 1000 0000 0010 
INFO:Cse - '1': Completed downloading bit file to device.
INFO:Cse - '1': Programming completed successfully.
PROGRESS_END - End Operation.
Elapsed time =      6 sec.
 Match_cycle = NoWait.
Match cycle: NoWait
 LCK_cycle = NoWait.
LCK cycle: NoWait
INFO:iMPACT - '1': Checking done pin....done.
'1': Programmed successfully.

Может кто сталкивался с такой проблемой? 

P.S. Разъёмы переподключал, компьютер перезагружал, программатор менял - не помогло.

Share this post


Link to post
Share on other sites
4 hours ago, Skryppy said:

*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates

Возможно, дело в этом. Прошивка на низкой частоте проходит, а в свойсвах битстрима указана высокая

Share this post


Link to post
Share on other sites
7 часов назад, Alex77 сказал:

программатор "китайский"  или однозначно фирменный?

Нет, программаторы фирменные.

 

6 часов назад, pavlovconst сказал:

Возможно, дело в этом. Прошивка на низкой частоте проходит, а в свойсвах битстрима указана высокая

Интересно, спасибо. В vivado у меня стоит максимальная скорость 60 МГц вроде. Надо поменять ее. Завтра проведу эксперимент, вдруг пройдет. Странно, что на остальных 20 приборах никогда таких проблем не возникало.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.