Jump to content

    
zombi

Странная форма сигналов

Recommended Posts

Плис формирует сигналы, все выходы 3.3 В. Самая высокая частота - канал 2.

При 1 MHz наблюдаю:

TEK0001.JPG.aad36b1437fc31d26a55030f3c345067.JPG

 

при 70 MHz :

TEK0000.JPG.f0623df19fc66eb6ec6f3aa7e425d757.JPG

Почему при 70 такой ужас творится на 3 и 4 канале?

Можно ли побороть?

Share this post


Link to post
Share on other sites

 

Побороть осциллограф хотите?

Придётся в настройки лезть и разбираться.

Edited by Herz
Избыточность цитирования

Share this post


Link to post
Share on other sites

Нужно BW Limit для каналов повыключать и щупы настроить. На щупе есть подстроечный конденсатор, а в комплекте осциллографа - пластмассовая отвертка. Подаете на вход сигнал с калибратора и конденсатором добиваетесь прямоугольника. См. документацию на осциллограф.

 

Ну и, конечно же, если у вас осциллограф с полосой в 100 МГц, а вы наблюдаете меандр в 70 МГц, то вы видите именно то, что должны видеть - физику не проведешь ...

Share this post


Link to post
Share on other sites

Нужен осциллограф с аналоговой полосой МГц 500 чтобы нормально смотреть прямоугольные сигналы 70 МГц.

Альтернативой может быть анализатор логический.

Share this post


Link to post
Share on other sites

Ну почти всё.

Почему меандр на 2 канале слабо похож на меандр - ясно.

А вот почему на канале 3, в момент когда должен быть высокий уровень, какой-то инверсный канал 2 наблюдается?

И на канале 4 тоже самое, но в меньшей степени, и выглядит получше.

Share this post


Link to post
Share on other sites

Не знаю, что у вас за прибор. У нас на фирме был 4-канальный, 500 МГц Тектроникс с похожей проблемой. Баг в прошивке (?). Проверка простая - на все четыре канала подаем сигнал с одного генератора, например, меандр в 10 МГц, и смотрим на экран. Так вот, прибор показывает ... заметно разные картинки. Все щупы откалиброваны и все каналы настроены одинаково. Т.е., по идее, и картинки должны быть идентичными (ну, почти). Так нет же ...

Share this post


Link to post
Share on other sites
12 minutes ago, zombi said:

штатным хвостиком.

Каким еще "штатным хвостиком"? :shok:

Начиная с примерно с 20...30 МГц, смотреть нужно только с "пружинкой", а в самой линии нужно обеспечить условия согласования. При наблюдении непосредственно на пинах микросхемы нужно учитывать импеданс щупа.

На скоростных осциллографах нужны специальные коннекторы и согласование линии в условиях подключения коннекторов.

Share this post


Link to post
Share on other sites
2 hours ago, zombi said:

Хочу увидеть более-менее приличную картинку, а не этот кошмар.

Или это невозможно?

Попробовать для начала подключить без щупов, короткими проводочками (до 10см) с последовательными сопротивлениями (~~100 Ом). 

Share this post


Link to post
Share on other sites
28 minutes ago, Leka said:

Попробовать для начала подключить без щупов, короткими проводочками (до 10см) с последовательными сопротивлениями (~~100 Ом). 

Нее господа, всё не настолько критически чтобы я уже проводочки к щупу лепил и за пружинками бежал - волосы назад.

Ну не получилось с моим осциллографом отладить, ну и фиг с ним.

Возвращаюсь к симулятору :biggrin:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.