Jump to content

    
ALEN&Co

STM32H725RGV6 (VFQFPN68) + ST-LINK v.2 вопросы по питанию ядра и запуску

Recommended Posts

Не удаётся запустить STM32H725RGV6 в корпусе VFQFPN68.

Особенность МК этой серии в таком корпусе - отсутствие встроенного LDO (соответственно, и вывода VDDLDO).

На первой странице описания DS13311 Rev 2 сразу и указано: "Embedded DCDC and LDO regulator / (*)VFQFPN68 variant is DCDC only".
При этом нигде не упоминается, а как, собственно, питать ядро? Опыта работы с этой серией нет.

Попробовал подать байпасом на три, соединённых друг с другом, вывода VCAP напряжение с внешнего DCDC 1,35В. На Vdd, Vdda  подаются обычные 3,3В.
SMPS не задействован (на одной плате все ноги в воздухе, на другой VSSSMPS,  VDDSMPS,  VFBSMPS на общем проводе.

Обвязка типовая, конденсаторы по кругу, BOOT0 на общем, на nRST конденсатор 0,1мк.

Но ST-LINK контроллер не видит ("Can not connect to the target!"). 

ST-LINK версии 2, прошивка V2J37S7. Возможно ли, что для этой серии МК нужен ST-LINK более новый (v.3)?
ST-LINK заведомо исправный, с МК серий F1, F4 работает.

 

Share this post


Link to post
Share on other sites

Для STM32H745/755/747/757 описание, как работать с питанием, содержится в соответствующем разделе Reference Manual'а (не даташита!), там же есть и варианты подачи питания. Там довольно хитро, причём, если проц будет гоняться на максимальной частоте, не все схемы годятся. Надо полагать, что и для Вашего МК подобное приведено. А ST-LINK, вполне вероятно, нужно именно третий: проц же достаточно новый, да ещё двухъядерный...

Share this post


Link to post
Share on other sites

По питанию в AN5419 неплохо расписано. Но ничего экстраординарного я там не увидел.

Пока не до максимальной частоты, по умолчанию МК на достаточно низкой должен запуститься. Пока даже ST-LINKом связаться с ним не удаётся.

Насчет версии отладчика - отладочная плата NUCLEO-H743ZI  на STM32H743 имеет на борту ST-LINK/ V2-1. На более новой версии (...ZI2) уже v.3 используется.

Share this post


Link to post
Share on other sites

Пробовал использовать ST-LINK v3 (из Терры), результат тот же.

Интересно, что при отключении МК от ST-LINK окно сообщения немного меняется.

С подключенным МК ошибка такая:

407237348_ST-LINKv.3ERROR.thumb.png.9fc7298cdaa75d57ce371e24b0748e9f.png

 

Если МК вообще отключить от отладчика, всё выглядит несколько по другому:

950556773_ST-LINKv.3ERROR2.thumb.png.d8d1560604e4c0d9b11d85b2ef266835.png

 

Получается, ST-LINK что-то идентифицирует, но полноценную связь установить не может...

 

Share this post


Link to post
Share on other sites

Сделали новую плату, перетрясли схемы питания, запустили SMPS ради интереса, результат один...

Этот корпус LDO не содержит, и при отсутствии подачи питания напрямую на выводы Vcap на них ноль.

Пробовали подавать на Vcap и с SMPS (1.38B), и с внешнего стабилизатора. При подаче питания на ядро на выводе SWDIO появляется подтяжка к +3.
Но это единственное проявление признаков жизни.

Саму микросхему меняли, и неоднократно, так что вопрос неисправного экземпляра исключается.

Как такое может быть?? Что ещё можно проверить?

Работали с разными STM, начиная с F103, F107, F4 разные, и H743 нормально работает, а h725ceu не хочет. ((( 

Чувствую, что-то я не догоняю в элементарных вещах... (((

 

 

Share this post


Link to post
Share on other sites
19 hours ago, x893 said:

Всё вроде разрисовано в подробностях

Согласен, прошерстили этот 5419 вдоль и поперёк, но так и непонятно, чем же этот МК отличается от других похожих, и что ему нужно.

Запаяли на разные платы 5 шт. этих камней, перепробовали разные варианты питания, но увы, результат как в басне про "мартышку и очки".. ((

Share this post


Link to post
Share on other sites
19 minutes ago, ALEN&Co said:

Согласен, прошерстили этот 5419 вдоль и поперёк, но так и непонятно, чем же этот МК отличается от других похожих, и что ему нужно.

Запаяли на разные платы 5 шт. этих камней, перепробовали разные варианты питания, но увы, результат как в басне про "мартышку и очки".. ((

Ну если есть желание, то можете одну плату прислать и схему. Сравню со своей по напряжениям.

Share this post


Link to post
Share on other sites
31 минуту назад, ALEN&Co сказал:

перепробовали разные варианты питания, но увы, результат как в басне про "мартышку и очки".. ((

А чего уперлись-то в питание? А как подключаетесь, по SWD ? Если да, ресет на SWD подключен?

Share this post


Link to post
Share on other sites
1 hour ago, x893 said:

Ну если есть желание, то можете одну плату прислать и схему. Сравню со своей по напряжениям

У Вас именно VFQFPN68?? :dance2:

 

1 hour ago, Ozone said:

А попробуйте через UART встроенным загрузчиком чо нить загрузить и поморгать пином

Да как то уже несколько лет этот способ не использую, и желания нет.

Если МК работает, то должен подключиться отладчик!!

 

1 hour ago, Vasily_ said:

А чего уперлись-то в питание? А как подключаетесь, по SWD ? Если да, ресет на SWD подключен?

Да, SWD два провода.

Чтобы убрать сомнения, убрал все посторонние элементы с интерфейса (защитные резисторы, стабилитроны), и ST-LINK сейчас новый, с последней прошивкой, проверенный на других МК (из последних на STM32G4).

Резета сейчас нет, но пробовал подключать, результата не было.

Вы думаете, что у этого камня он обязательно нужен??

Сомневаюсь, но сейчас ещё попробую.

Share this post


Link to post
Share on other sites
15 минут назад, ALEN&Co сказал:

Вы думаете, что у этого камня он обязательно нужен??

Насчет этого камня точно не скажу, но есть чипы где ресет точно нужен.

Да и на вашем скрине Connect Under Reset как-бы намекает на его наличие.

Share this post


Link to post
Share on other sites
50 минут назад, ALEN&Co сказал:

Да как то уже несколько лет этот способ не использую, и желания нет.

Если МК работает, то должен подключиться отладчик!!

Это для проверки работоспособности.

Отладчик может не подключиться.  На STM32H745 наблюдался глюк, когда ST-LINK китайский отказывался подключаться, я думал спалил контроллер.  Но одновременное нажатие ресет и подключение st-link спасло ситуацию. Не знаю что это с контроллером было.  Больше такого не наблюдалось.  Данную ситуацию на одном из форумов видел.

Если есть дискавери, то попробовать его st-link ом запрограмить.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.