Jump to content

    
Sign in to follow this  
koluna

MSP430, ошибка отладчика (MSP430 Error :Could not find MSP-FET430UIF on specified COM port)

Recommended Posts

Всем привет.

Linux Mint 20.

Установил тулчейн от TI: https://www.ti.com/tool/MSP430-GCC-OPENSOURCE

Но вот как прошить и отлаживать?

Прикупил у китайцев MSP-FET430UIF.

gdb_agent_console запускается, но при попытке подсоединиться из msp430-elf-gdb завершается с ошибкой:

./gdb_agent_console ../msp430.dat 
[sudo] password for koluna:  
CPU Name             Port
--------             ----
msp430              :55000

Starting all cores
CPU Name             Status
--------             ------
msp430               Waiting for client
msp430               Client connected...Connecting to Target
Couldn't find any connected USB FETs!
Failed to initialize FET on TIUSB port. Aborting.
   MSP430 Error :Could not find MSP-FET430UIF on specified COM port
Connection failed...exiting

Пробовал через sudo (совет в быстром старте) - тоже самое.

Пробовал на другом компе с Mint 19.3 - тоже самое.

Макетка китайская на MSP430F149.

Кто-нибудь сталкивался с подобным? Как решить?

Edited by koluna

Share this post


Link to post
Share on other sites

Как вообще проверить этот программатор? Жив или мертв? при подключении к USB мигает зеленым, а потом зажигается красный светодиод.

Отпределяется как ttyUSB0.

Попробовал тот же тулчейн на Win7.

Тоже ошибка (недокументированная ошибка gdb: 10061).

gdb_agent_console ругается, что драйвер не установлен.

 

Share this post


Link to post
Share on other sites
31 minutes ago, koluna said:

 

Скачайте FET-Pro-430  FET-Pro-430-LITE  https://www.elprotronic.com/pages/downloads 

этл бесплатная утилита  позволяет програмировать MSP430  попробуйте подключится . можете посмотреть версию ПО только не обновляйте ПО китайский клон может умереть.

Share this post


Link to post
Share on other sites
28 minutes ago, koluna said:

Как вообще проверить этот программатор? Жив или мертв? при подключении к USB мигает зеленым, а потом зажигается красный светодиод.

ещё можно проверить в ccs или iar.

правда мне тут последний ccs какому-то древнему лаунчпаду  c отладчиком XDS100 (причём свой родной, а не китайский клон) при подключении так обновил прошивку, что я его потом еле обратно оживил.

пришлось то ли до 8 то ли до 7 версии CCS откатиться чтобы он не требовал прошивку обновить.

Share this post


Link to post
Share on other sites
19 hours ago, Vasil_Riabko said:

Скачайте FET-Pro-430  FET-Pro-430-LITE  https://www.elprotronic.com/pages/downloads 

Установил на нетбук с семеркой. Версии ПО посмотрел: у меня 2.04.06.001, предлагает 3.15.00.000. Обновляться не стал...

Про смерть клонов читал, но не понял, почему так происходит? Какая-то несовместимость или защита TI?

Плату сбрасывает по кнопке, прошивку читает (там у меня блинк от производителя). Шить пока не пробовал.

Ну, вроде, работает китайский девайс :) Вот теперь как-то надо его под Линухом запустить...

Спасибо.

Edited by koluna

Share this post


Link to post
Share on other sites
6 hours ago, koluna said:

Про смерть клонов читал, но не понял, почему так происходит? Какая-то несовместимость или защита TI?

 

 

не знаю что там происходит у меня такой клон  http://otladka.com.ua/index.php?page=shop.product_details&flypage=vmj_naru.tpl&product_id=86&category_id=23&option=com_virtuemart&Itemid=71

раза два по невнимательности  обновлял при этом отладчик становился кирпичем  благо продавцы недалеко оба раза восстанавливали .

Share this post


Link to post
Share on other sites
6 hours ago, koluna said:

Про смерть клонов читал, но не понял, почему так происходит? Какая-то несовместимость или защита TI?

вряд ли умышленно, обычное разгильдяйство, они даже для своих собственных девайсов иногда умудряются сломать прошивку, так что девайс окирпичивается.

Share this post


Link to post
Share on other sites

У меня хорошие новости.

Собрал mspdebug, с ним работает... пока проверил отладку немного.

Причем, работает только через полный JTAG (mspdebug -j -d /dev/ttyUSB0 uif gdb), через SBW не работает.

 

Кстати, продавец отладчика в ответ на мои вопросы что-то там выложил... посмотрим...

После скачивания... А посмотрим мы все на китайском и это будет для винды... :(

Edited by koluna

Share this post


Link to post
Share on other sites
10 minutes ago, koluna said:

Причем, работает только через полный JTAG (mspdebug -j -d /dev/ttyUSB0 uif gdb), через SBW не работает.

 

 

 

MSP430F149 не поддерживает SBW

Share this post


Link to post
Share on other sites

Да, спасибо.

Вот, думаю, может, и с gdb_agent_console проблемы из-за этого... по умолчанию через SBW пытается... но что-то в опциях и настройках у него на нашел как выбирать интерфейс: JTAG или SBW.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this