Jump to content

    
Artyk

Проблемма с Layout Team Server

Recommended Posts

Добрый день. Проект запущен в сетевом режиме (RSCM и Team Server), в схемном и топологическом редакторе работают несколько инженеров одновременно.
В один момент при обновлении правил CES (или Plane Assignment) mentor глюканул и у всех пользователей expedition вылетел с ошибкой (create minidump.. ) с предложением восстановления (могу ошибаться с точностью формулировки ошибки).
В итоге Team server перестал запускаться, при этом в сингле проект работает исправно. Сделал Repair project в ICDB Project Backup - не помогло. Перенес с переименованием проект на другой диск, удалил топологию (всю папку и template),сделал template платы в старом проекте и подсунул его в новый проект - не помогло (в сингл работает, а team server не запускается). Во вложении скриншоты окон, которые выскакивают при запуске сервера. После попытки загрузить автосохранения или последнего сохранения teamserver закрывается.

1.jpg

2.jpg

Share this post


Link to post
Share on other sites
8 minutes ago, Artyk said:

Добрый день. Проект запущен в сетевом режиме (RSCM и Team Server), в схемном и топологическом редакторе работают несколько инженеров одновременно.
В один момент при обновлении правил CES (или Plane Assignment) mentor глюканул и у всех пользователей expedition вылетел с ошибкой (create minidump.. ) с предложением восстановления (могу ошибаться с точностью формулировки ошибки).
В итоге Team server перестал запускаться, при этом в сингле проект работает исправно. Сделал Repair project в ICDB Project Backup - не помогло. Перенес с переименованием проект на другой диск, удалил топологию (всю папку и template),сделал template платы в старом проекте и подсунул его в новый проект - не помогло (в сингл работает, а team server не запускается). Во вложении скриншоты окон, которые выскакивают при запуске сервера. После попытки загрузить автосохранения или последнего сохранения teamserver закрывается.

1.jpg

2.jpg

вы Concurrent Design Administrator’s Guide. весь изучили?

проверьте запущен ли сервис MGC_XtremeSvc в сервисах винды

Share this post


Link to post
Share on other sites
16 minutes ago, PBO said:

вы Concurrent Design Administrator’s Guide. весь изучили?

проверьте запущен ли сервис MGC_XtremeSvc в сервисах винды

сервис MGC_XtremeSvc не запущен, есть только MGC.SDD.RSCM.EEVX.2.3

Share this post


Link to post
Share on other sites
3 minutes ago, Artyk said:

сервис MGC_XtremeSvc не запущен, есть только MGC.SDD.RSCM.EEVX.2.3

почитайде документ что выше там написано как его запустить.

Так же попробуйте заново поднять RSCM сервер (остановить его и запустить)

Если не получится, то пишите название своей организации (можете в лс) будем открывать тикет на поддержку.

Также проверьте файл %WDIR%\iCDB\Server\server.cfg в нем должна быть строчка в секции [System] : SingleUserMode = No

Проблема так же может быть в том что проект был запущен в однопользовательском режиме другим приложением. Удаленные приложения не могут совместно использовать сервер iCDB, запущенный в однопользовательском режиме, и эта конфигурация поддерживается только при использовании параметра
Диспетчера конфигурации удаленного сервера (RSCM).

Share this post


Link to post
Share on other sites
2 hours ago, PBO said:

почитайде документ что выше там написано как его запустить.

Так же попробуйте заново поднять RSCM сервер (остановить его и запустить)

Если не получится, то пишите название своей организации (можете в лс) будем открывать тикет на поддержку.

Также проверьте файл %WDIR%\iCDB\Server\server.cfg в нем должна быть строчка в секции [System] : SingleUserMode = No

Проблема так же может быть в том что проект был запущен в однопользовательском режиме другим приложением. Удаленные приложения не могут совместно использовать сервер iCDB, запущенный в однопользовательском режиме, и эта конфигурация поддерживается только при использовании параметра
Диспетчера конфигурации удаленного сервера (RSCM).

- MGC_XtremeSvc запустил
- RSCM сервер перезапустил
- %WDIR%\iCDB\Server\server.cfg в нем должна быть строчка в секции [System] : SingleUserMode = auto - поменял на NO

Итог -
1) designer запустился на обоих машинах.
2) без запуска teamserver: - на 1й машине layout запустился полном доступе,
                                             - на 2й машине layout запустился в доступе на чтение.
3) попытка запуска teamserver - проходит проверку, видит что есть автосохранения, при начале загрузки - вылет

2 hours ago, PBO said:

Проблема так же может быть в том что проект был запущен в однопользовательском режиме другим приложением. Удаленные приложения не могут совместно использовать сервер iCDB, запущенный в однопользовательском режиме, и эта конфигурация поддерживается только при использовании параметра Диспетчера конфигурации удаленного сервера (RSCM).

Как посмотреть какие приложения и в каком режиме используют проект?

Share this post


Link to post
Share on other sites
1 minute ago, Artyk said:

Как посмотреть какие приложения и в каком режиме используют проект?

Вы же наверняка знаете кто работает над этим проектом , пусть все проверят что у них включено в dxd concurrence mode и указан один о тот же сервер rscm. 

Share this post


Link to post
Share on other sites
12 hours ago, PBO said:

Вы же наверняка знаете кто работает над этим проектом , пусть все проверят что у них включено в dxd concurrence mode и указан один о тот же сервер rscm. 

Вчера вечером вышеописанный эксперимент провел при выключенных клиентских машинах. После конфигурации сервера запустил 2ю машину и загрузил designer. На всех машинах проект запущен с галочкой "Enable concurrent mode" в поле "Serve name" указан IPadress компа, где запущен rscm сервер. Возможно где-то в файлах прописалась строчка, которая выбивает загрузку проекта в сетевом режиме...
Картина с предупреждениями о произошедшей критической ошибке и вариантами загрузки бэкапов (скрины в 1м посте), повторяется при каждой попытке запуска teamserver, только дата автосохранения меняется (дата последней работы в одно пользовательском режиме). Причем, когда я делал template из топологии, были такие же сообщения, но после выбора автосэйва проект загрузился и template удалось сохранить.

Share this post


Link to post
Share on other sites
7 minutes ago, Artyk said:

Вчера вечером вышеописанный эксперимент провел при выключенных клиентских машинах. После конфигурации сервера запустил 2ю машину и загрузил designer. На всех машинах проект запущен с галочкой "Enable concurrent mode" в поле "Serve name" указан IPadress компа, где запущен rscm сервер. Возможно где-то в файлах прописалась строчка, которая выбивает загрузку проекта в сетевом режиме...
Картина с предупреждениями о произошедшей критической ошибке и вариантами загрузки бэкапов (скрины в 1м посте), повторяется при каждой попытке запуска teamserver, только дата автосохранения меняется (дата последней работы в одно пользовательском режиме). Причем, когда я делал template из топологии, были такие же сообщения, но после выбора автосэйва проект загрузился и template удалось сохранить.

Если проблема сохраняется, то давайте создадим Тикет в поддержку но мне для этого нужно будет название вашего предприятия) и ещё скорее всего проблемный проект , готовы ?

Если я не ошибаюсь, то в настройках указывается имя сервера а не его ip адрес

 

1863850013_.thumb.png.be233ee7f41f66c4102f2c31957b87ad.png

Share this post


Link to post
Share on other sites
On 9/28/2020 at 5:26 PM, Artyk said:

Добрый день. Проект запущен в сетевом режиме (RSCM и Team Server), в схемном и топологическом редакторе работают несколько инженеров одновременно.
В один момент при обновлении правил CES (или Plane Assignment) mentor глюканул и у всех пользователей expedition вылетел с ошибкой (create minidump.. ) с предложением восстановления (могу ошибаться с точностью формулировки ошибки).
В итоге Team server перестал запускаться, при этом в сингле проект работает исправно. Сделал Repair project в ICDB Project Backup - не помогло. Перенес с переименованием проект на другой диск, удалил топологию (всю папку и template),сделал template платы в старом проекте и подсунул его в новый проект - не помогло (в сингл работает, а team server не запускается). Во вложении скриншоты окон, которые выскакивают при запуске сервера. После попытки загрузить автосохранения или последнего сохранения teamserver закрывается.

1.jpg

2.jpg

Добрый вечер!

Проблема решилась путем переключения слой Layer8  c Plane на Signal в диалоге plane assignments. После этого Team Server удачно стартует. Проверьте у себя.

Share this post


Link to post
Share on other sites
On 10/8/2020 at 10:09 PM, PBO said:

Добрый вечер!

Проблема решилась путем переключения слой Layer8  c Plane на Signal в диалоге plane assignments. После этого Team Server удачно стартует. Проверьте у себя.

Проблема решена, спасибо за поддержку.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.