Jump to content

    
Sign in to follow this  
DpInRock

Выброс при включении DCDC TPS54340

Recommended Posts

DCDC на сабжекте. 

При резком подаче питания на выходе возникает здоровенный выброс длиной прмерно 20 микросекунд.

Высостой - зависит от конкретного входного 9...14 и он от 5 до 8 вольт может быть.

Он есть всегда. Даже когда преобразователь запрещен по входу Enable.

После выброса опять 0 на выходе и далее идет обычный мягкий старт и все хорошо.

Впечателение, что это просто емкостня связь по плате между входом и выходом. Никогда такого не замечал.

Или что-то другое?

1.jpg

Share this post


Link to post
Share on other sites

т.е. на 20мкс у вас заряжаются выходные ёмкости, затем разряжаются в ноль, причём неизвестно на что, а списываете вы это на емкостную наводку по плате?

в общем-то, гадать можно и на кофейной гуще - никто ж не знает, что это за дц-дц и в каких режимах и на какую нагрузку он работает.

Share this post


Link to post
Share on other sites

DCDC в сабжекте. TPS54540B.

Нагрузка не имеет значения вообще. Хоть без нагрузки, хоть 3 ома нагрузка.

Выходные емкости - три штуки 100 мкф керамика плюс хренова туча 0.1...1 мкф по всей плате.

Размер импулься зависит от входного напряжения. Пропорционален.

Share this post


Link to post
Share on other sites

Во-первых, время от enable до останова преобразователя по даташиту 340мкс. А ещё enable используется как UVLO, т.е. имеет свой порог срабатывания. Соответственно, у преобразователя есть время с момента подачи питания до поднятия опор, протекания всяких переходных процессов и перехода в disable. В этом случае, в течение этих 20мкс на выводе SW можно будет наблюдать нормальные импульсы с заданной тактовой частотой.

Share this post


Link to post
Share on other sites

Я запрещаю UVLO прям на землю. Прям сразу. Проводом.

Везде где можно поставил конденсторов (на делителе), чтобы вначале задавить напряжение вниз. Никакого эффекта.

Поменял индуктор, частоту преобразования.

Пофик.

Не то, что нет изменений, а вообще никаких изменений. Четко и строго.

Типа, демоны сидят и входное напряжение на выход передают на 20 микросекунд...

А емкостная связь у меня есть. Заливку сделал, а забыл вырезать лишнее. И Земля облегает хорошо все компоненты.

Share this post


Link to post
Share on other sites
8 minutes ago, DpInRock said:

Не то, что нет изменений, а вообще никаких изменений. Четко и строго.

Опять не рассматриваете внешнее окружение. 
Тут самое главное откуда подаете питание и каким образом его коммутируете на входе. 
Похоже на эффект длинной линии,  мощного источника и керамических входных конденсаторов.
Такой эффект здесь много раз обсуждался. На него налетают чуть больше чем все. :biggrin:  

А осциллогаф просто не показывает овершутинг, воэможно плохие щупы или зарезана полоса или не в том месте измеряется.   

Share this post


Link to post
Share on other sites

Ой!!! Правда ваша. У меня длинющий провод от источника. И тонкий. 

Коммутирую его методом втыкания КЛЕММНИКА разъемного. При нерезкой подаче питания эффекта не наблюдаю.

И шо делать? Ставить ълектролит какой?

Но в чем эффект?

Share this post


Link to post
Share on other sites

Линия метр. 

Но длинная линия и конденсаторы ДО стабилизатора. И стабилизатор выключен.

И за 20 микросекунд зарядить 300--500 микрофарад - это надо уметь. 

Выставил защиту на БП на 7 миллиампер. Она конечно сработала, но импульс был на месте.

Вот резистор 2 ома последовательно с питанием - снизил амплитуду и показал ее конденсаторную природу. 

Резко вверх и плавно вниз.

Share this post


Link to post
Share on other sites

В общем проблему решил. Но отчего она - не знаю.

Решена проблема добавлением конденстаора по самому входу, до защитного диода.

Стоял конденсатор на 0.1. Постаивл 4.7 стало нормально.

Всегда ставил 4.7 чисто так, для порядка. А сейчас чего-то не поставил. И на тебе - век живи, век учись.

 

Share this post


Link to post
Share on other sites

Да вот нет. 

Вот не очень охота отпаивать микросхему. Я ее уже отпаивал (переносил с платы на плату 3 раза).

Вот не зависит это от миркосхемы. Я в техас верю как в дьвола. Всегда норм. 

А тут спешил очень. Развел без зазоров между вещами где нужны зазоры. Вернее, не помешают совсем.

В общем, Александр Y знает в чем дело, но молчит.  Гугл тоже помалкивает, либо выдает таких же лохов, как я.

Руки прочь от Техаса.

 

Share this post


Link to post
Share on other sites

Ну объяснение было бы хорошим, но я не вижу выбросов на входе (см. синюю осцилограмму - это на входном керамическом конденсаторе).

Стабилизатор вообще запрещен к работе. Ключ должен быть закрыт...

 

Хотя, если честно, некоторые случаи непонятного вылета стабилизаторов такого рода становятся понятными.

Что делается то. Уже и керамику не применить. Куда катится мир.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this