Jump to content

    
Sign in to follow this  
Alf256

Вопрос по подключению программатора DLC9LP

Recommended Posts

Имеется запускаемая плата с Artix-7 и имеется китайский клон программатора DLC9LP. Установлена среда Vivado 2019 в windows 10 64 бит. Никак не могу заставить их работать вместе.

При подключении программатора он определился как:

Xilinx USB Cable

драйвер 28.08.2017

версия 1.0.0.0

конечно написано: Устройство работает нормально.

но при этом во вкладке события последняя запись:

Установка драйвера xpcwinusb.inf_amd64_82876d6fbe1ec3a7 для экземпляра устройства с ИД USB\VID_03FD&PID_0008\6&2088E4F&0&4 завершена со следующим состоянием: 0x0.

При подключении программатора загорается красный светодиод, при подключении платы, на которой имеется питание 1,8В ничего не меняется. Vivado программатор не видит, а при автоподключении пишет:

 [Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.
Check cable connectivity and that the target board is powered up then
use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

на сайте Xilinx выложена версия драйвера 2007 года и результат так же отрицательный.

помогите разобраться или может я всё же упустил подобный опубликованный вопрос.

P.S. это моя первая попытка работать с Xilinx и этим программатором, так что сильно не ругайте за косяки.

Share this post


Link to post
Share on other sites

Разберите клон и гляньте что там стоит на выходе. Китайские загружалки плохо работают на  напряжениях ниже 3.3 потому что стоит драйвер не той системы.

У них уже появилась DLC10 возможно в ней они что-то исправили.

Опять же никто не отменял осциллограф. На выходе есть хоть какие то сигналы?

 

Share this post


Link to post
Share on other sites
15 minutes ago, MegaVolt said:

Разберите клон и гляньте что там стоит на выходе. Китайские загружалки плохо работают на  напряжениях ниже 3.3 потому что стоит драйвер не той системы.

У них уже появилась DLC10 возможно в ней они что-то исправили.

Опять же никто не отменял осциллограф. На выходе есть хоть какие то сигналы?

 

Сигналов никаких нет, уровни везде 1.8В очевидно с платы. И не пойму как разобрать - просто так не расщёлкивается - он на винтах похоже, а винты под наклейкой возможно, а портить наклейку пока боюсь - он не мой. Случайно не знаете как он разбирается? он с алиэкспрес вроде.

26 minutes ago, MegaVolt said:

Разберите клон и гляньте что там стоит на выходе. Китайские загружалки плохо работают на  напряжениях ниже 3.3 потому что стоит драйвер не той системы.

У них уже появилась DLC10 возможно в ней они что-то исправили.

Опять же никто не отменял осциллограф. На выходе есть хоть какие то сигналы?

 

разобрал... стоит lvc244a nxp вроде от 1.2В должна работать и плис lattice

Share this post


Link to post
Share on other sites
15 минут назад, Alf256 сказал:

разобрал... стоит lvc244a nxp вроде от 1.2В должна работать и плис lattice

Микросхема не является преобразователем уровней. У неё одно питание. 
Проверьте что затащено на питание? Если на питании 1.8 то большой вопрос понимает ли Латис выходы этого буфера.
Если на питании что-то со стороны латиса то устривают ли плис формируемые сигналы.

Share this post


Link to post
Share on other sites
1 hour ago, MegaVolt said:

Микросхема не является преобразователем уровней. У неё одно питание. 
Проверьте что затащено на питание? Если на питании 1.8 то большой вопрос понимает ли Латис выходы этого буфера.
Если на питании что-то со стороны латиса то устривают ли плис формируемые сигналы.

Посмотрел Lattice - это LFXP2 - по даташит она работает и с 1.8 и 1.2 В. А 244 запитана от 1.8. Если только китайцы не накосячили подав на питание портов другое напряжение - не с JTAG

Share this post


Link to post
Share on other sites
18 минут назад, Alf256 сказал:

Посмотрел Lattice - это LFXP2 - по даташит она работает и с 1.8 и 1.2 В. А 244 запитана от 1.8. Если только китайцы не накосячили подав на питание портов другое напряжение - не с JTAG

Тогда остаются вопросы с дровами и пр... ID читать получается? Прошивалка хоть какие то сигналы кроме постоянных уровней выдаёт наружу?

Share this post


Link to post
Share on other sites
Just now, MegaVolt said:

Тогда остаются вопросы с дровами и пр... ID читать получается? Прошивалка хоть какие то сигналы кроме постоянных уровней выдаёт наружу?

 

1 hour ago, Alf256 said:

Имеется запускаемая плата с Artix-7 и имеется китайский клон программатора DLC9LP. Установлена среда Vivado 2019 в windows 10 64 бит. Никак не могу заставить их работать вместе.

При подключении программатора он определился как:

Xilinx USB Cable

драйвер 28.08.2017

версия 1.0.0.0

конечно написано: Устройство работает нормально.

но при этом во вкладке события последняя запись:

Установка драйвера xpcwinusb.inf_amd64_82876d6fbe1ec3a7 для экземпляра устройства с ИД USB\VID_03FD&PID_0008\6&2088E4F&0&4 завершена со следующим состоянием: 0x0.

При подключении программатора загорается красный светодиод, при подключении платы, на которой имеется питание 1,8В ничего не меняется. Vivado программатор не видит, а при автоподключении пишет:

 [Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.
Check cable connectivity and that the target board is powered up then
use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

на сайте Xilinx выложена версия драйвера 2007 года и результат так же отрицательный.

помогите разобраться или может я всё же упустил подобный опубликованный вопрос.

P.S. это моя первая попытка работать с Xilinx и этим программатором, так что сильно не ругайте за косяки.

1 Попробуйте программатор на другой плате, где сигналы больше 1.8 В.

2 Поэкспериментируйте с разными версиями вивады и операционки (можно на виртуальной машине).

3 Если выше постигла неудача, покупайте другой программатор.

Share this post


Link to post
Share on other sites
21 hours ago, MegaVolt said:

Тогда остаются вопросы с дровами и пр... ID читать получается? Прошивалка хоть какие то сигналы кроме постоянных уровней выдаёт наружу?

Да вот в том то и дело что наружу ничего нет. Но больше похоже на проблемы с дровами. Обещали подтащить проверенный программатор, тогда и посмотрим.

Надеюсь скоро проблема решится. Спасибо за советы, как будут изменения в ситуации обязательно сообщу.

21 hours ago, eugen_pcad_ru said:

 

1 Попробуйте программатор на другой плате, где сигналы больше 1.8 В.

2 Поэкспериментируйте с разными версиями вивады и операционки (можно на виртуальной машине).

3 Если выше постигла неудача, покупайте другой программатор.

К сожалению другой платы нет, но будет какой то другой программатор.

18 hours ago, gosha-z said:

0. Выберите USB-кабель минимальной длины у которого жилы потолще. Лично прошелся по этим граблям.

Да кабель вроде короткий и толстый - длинной меньше метра.

Share this post


Link to post
Share on other sites

К сожалению проблема пока решилась только заменой программатора на оригинальный DLC10. Он заработал сразу и без проблем.

Но всё-таки остаются вопросы:

1. как запустить китайский DLC9LP?

2. будет ли работать с Artix-7 и Vivado 2019 китайский клон DLC10?

надеюсь решения скоро будут.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this